summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-11-01 16:25:07 +0000
committerRoger Leigh <rleigh@debian.org>2008-11-01 16:25:07 +0000
commit7e376f5e6281a783be7db69fbd25b6f68d8401ff (patch)
treef88a3666d24a42c2f1ba254f4438455e6b4e70ff /debian
parent476a9ebf8563f2ce3f17ab1757698511b356cfd8 (diff)
[rules] Use quilt in place of dpatch
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore2
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean0
-rw-r--r--debian/patches/00list0
-rwxr-xr-xdebian/rules17
5 files changed, 19 insertions, 5 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 51eedfe..6f540b7 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -16,4 +16,4 @@ libgutenprint-doc
libgutenprint2
libgutenprintui2-1
libgutenprintui2-dev
-patched
+patches
diff --git a/debian/changelog b/debian/changelog
index 0328ddd..68ed0b9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ gutenprint (5.2.1-2) experimental; urgency=low
+ Save and restore config.sub and config.guess. Thanks to
Till Kamppeter.
- install: Replace use of pwd with $(CURDIR).
+ - Use quilt in place of dpatch, and add rule to generate quilt patch
+ series from patches branch in git.
* debian/control:
- Add W. van den Akker to Uploaders.
- ijsgutenprint: Recommend foomatic-db-gutenprint.
@@ -27,8 +29,9 @@ gutenprint (5.2.1-2) experimental; urgency=low
* debian/patches/21_gutenprintui_plist_localefix.dpatch: Remove. Since
PPD files are no longer generated, we don't need to patch the source
to use /usr/share/ppd.
+ *
- -- Roger Leigh <rleigh@debian.org> Fri, 31 Oct 2008 20:20:43 +0000
+ -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:24:11 +0000
gutenprint (5.2.1-1) experimental; urgency=low
diff --git a/debian/clean b/debian/clean
deleted file mode 100644
index e69de29..0000000
--- a/debian/clean
+++ /dev/null
diff --git a/debian/patches/00list b/debian/patches/00list
deleted file mode 100644
index e69de29..0000000
--- a/debian/patches/00list
+++ /dev/null
diff --git a/debian/rules b/debian/rules
index cb9c668..bb71635 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@
export DH_OPTIONS
# Use dpatch.
-include /usr/share/dpatch/dpatch.make
+include /usr/share/quilt/quilt.make
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
@@ -23,6 +23,17 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+update-patch-series:
+ mkdir -p $(CURDIR)/debian/patches
+ rm -f $(CURDIR)/debian/patches/*.patch
+ git format-patch -o $(CURDIR)/debian/patches patches ^upstream | \
+ xargs -n 1 basename > $(CURDIR)/debian/patches/series
+ for patch in $$(ls $(CURDIR)/debian/patches/*.patch); do \
+ lines=$$(cat $$patch | wc -l); \
+ head -n $$(($$lines - 3)) $$patch > $${patch}.chomped; \
+ mv $${patch}.chomped $$patch; \
+ done
+
autoconfigure: autoconfigure-stamp
autoconfigure-stamp: debian/control
dh_testdir
@@ -41,7 +52,7 @@ autoconfigure-stamp: debian/control
build: build-stamp debian/control
-build-stamp: patch-stamp autoconfigure-stamp
+build-stamp: patch autoconfigure-stamp
dh_testdir
cd debian/build; \
@@ -128,4 +139,4 @@ binary-arch: build install
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install autoconfigure patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install autoconfigure patch unpatch update-patch-series