summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-11-01 16:46:46 +0000
committerRoger Leigh <rleigh@debian.org>2008-11-01 16:46:46 +0000
commit8bbc4da99b6531712e713d3117e43410701d3d0d (patch)
tree2475c4caed34b02d7265bd7589ea23d9bcc99038 /debian
parent3b74cb433e1301207bf0f7eb7adeea9d9489cc5f (diff)
[cups-driver-gutenprint] Document USB backend device ID upgrade problems
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog18
-rw-r--r--debian/cups-driver-gutenprint.NEWS24
-rw-r--r--debian/cups-driver-gutenprint.postinst6
3 files changed, 38 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 7a2621e..4a3ba49 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,11 @@
gutenprint (5.2.1-2) experimental; urgency=low
[ Roger Leigh ]
- * debian/cups-driver-gutenprint.postinst: Automatically upgrade print
- queues using the obsolete canon and epson backends. Attempt to
- determine the most appropriate alternative backend from the device
- name.
+ * debian/cups-driver-gutenprint.postinst:
+ + Automatically upgrade print queues using the obsolete canon and epson
+ backends. Attempt to determine the most appropriate alternative
+ backend from the device name.
+ + Document USB backend device ID upgrade problems.
* debian/compat: Update to debhelper v7 compatibility.
* debian/rules:
- autoconfigure-stamp: Update configure options to create globalised
@@ -22,8 +23,9 @@ gutenprint (5.2.1-2) experimental; urgency=low
- Add W. van den Akker to Uploaders.
- ijsgutenprint: Recommend foomatic-db-gutenprint.
- Update description of GIMP Print plugin.
- * debian/cups-driver-gutenprint.NEWS: New file. Document automatic
- upgrade of print queue backends.
+ * debian/cups-driver-gutenprint.NEWS: New file.
+ - Document automatic upgrade of print queue backends.
+ - Document USB backend device ID upgrade problems.
* debian/cups-driver-gutenprint.*: Replace use of cupsys with cups.
* debian/patches/10_cups_modeldir.dpatch: Remove.
* debian/patches/20_fix_gimpprint_menu_entry.dpatch: Remove. Not needed,
@@ -31,10 +33,8 @@ gutenprint (5.2.1-2) experimental; urgency=low
* debian/patches/21_gutenprintui_plist_localefix.dpatch: Remove. Since
PPD files are no longer generated, we don't need to patch the source
to use /usr/share/ppd.
- *
- *
- -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:26:03 +0000
+ -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:43:27 +0000
gutenprint (5.2.1-1) experimental; urgency=low
diff --git a/debian/cups-driver-gutenprint.NEWS b/debian/cups-driver-gutenprint.NEWS
index 7ba1705..8bb8ff7 100644
--- a/debian/cups-driver-gutenprint.NEWS
+++ b/debian/cups-driver-gutenprint.NEWS
@@ -9,4 +9,26 @@ gutenprint (5.2.1-2) experimental; urgency=low
appropriate backend, but the queues should be checked to make sure
that the correct backend has been selected.
- -- Roger Leigh <rleigh@debian.org> Thu, 30 Oct 2008 22:04:00 +0000
+ In particular, USB printers will require the print queue to be
+ modified to use the correct IEEE-1284 device ID. The device IDs
+ for the USB printers currently connected to the system may be viewed
+ by running
+
+ /usr/lib/cups/backend/usb
+
+ or for all printers with
+
+ lpinfo -v
+
+ and set with
+
+ lpadmin -p PRINTER -v 'usb://DEVICE-ID'
+
+ Alternatively, this may be done using the CUPS web interface by browsing to
+
+ https://localhost:631/printers
+
+ and then choosing "Modify Printer" for each printer in question.
+ The available printers will be shown in a list.
+
+ -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:40:05 +0000
diff --git a/debian/cups-driver-gutenprint.postinst b/debian/cups-driver-gutenprint.postinst
index 3edeeb9..26bbd91 100644
--- a/debian/cups-driver-gutenprint.postinst
+++ b/debian/cups-driver-gutenprint.postinst
@@ -32,6 +32,12 @@ if [ "$1" = "configure" ]; then
[ -x /etc/init.d/cups ] && invoke-rc.d cups force-reload || true
# Upgrade from obsolete epson and canon backends
+
+ # Note that the current CUPS usb backend, unlike the epson and canon
+ # backends, does not allow direct use of device names, so these devices will
+ # require manual modification of the device URI; we can't get the correct
+ # IEEE-1284 device ID for a given device node without digging into the CUPS
+ # internals.
LC_ALL=C lpstat -v |
while read devinfo; do
printer=$(echo $devinfo | sed -e 's;device for \(..*\): \(..*\):/\(.*\);\1;')