summaryrefslogtreecommitdiff
path: root/include/gutenprint
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2012-06-21 23:30:20 +0100
committerRoger Leigh <rleigh@debian.org>2012-06-21 23:30:20 +0100
commit3514df18b289ec827cb6e4c446419feab1813231 (patch)
tree0fe6a3d1afbe720aac197918c6f4fb3583b240e1 /include/gutenprint
parent15578e218035547ca17e25ef351fbe56bc55a4ae (diff)
Imported Upstream version 5.2.8
Diffstat (limited to 'include/gutenprint')
-rw-r--r--include/gutenprint/Makefile.in6
-rw-r--r--include/gutenprint/bit-ops.h13
-rw-r--r--include/gutenprint/vars.h10
3 files changed, 26 insertions, 3 deletions
diff --git a/include/gutenprint/Makefile.in b/include/gutenprint/Makefile.in
index b0940be..fa778f2 100644
--- a/include/gutenprint/Makefile.in
+++ b/include/gutenprint/Makefile.in
@@ -118,6 +118,7 @@ DB2PS = @DB2PS@
DEFS = @DEFS@
DEPDIR = @DEPDIR@
DIALOG = @DIALOG@
+DLLTOOL = @DLLTOOL@
DOXYGEN = @DOXYGEN@
DSYMUTIL = @DSYMUTIL@
DUMPBIN = @DUMPBIN@
@@ -194,6 +195,7 @@ LTLIBOBJS = @LTLIBOBJS@
MAINT = @MAINT@
MAINTAINER_CFLAGS = @MAINTAINER_CFLAGS@
MAKEINFO = @MAKEINFO@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
MSGFMT = @MSGFMT@
MSGFMT_015 = @MSGFMT_015@
@@ -214,6 +216,8 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
PERL = @PERL@
PKG_CONFIG = @PKG_CONFIG@
+PKG_CONFIG_LIBDIR = @PKG_CONFIG_LIBDIR@
+PKG_CONFIG_PATH = @PKG_CONFIG_PATH@
PLUG_IN_PATH = @PLUG_IN_PATH@
POSUB = @POSUB@
RANLIB = @RANLIB@
@@ -237,6 +241,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
am__include = @am__include@
@@ -283,7 +288,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
diff --git a/include/gutenprint/bit-ops.h b/include/gutenprint/bit-ops.h
index 9e0fcc5..6c6a42d 100644
--- a/include/gutenprint/bit-ops.h
+++ b/include/gutenprint/bit-ops.h
@@ -1,5 +1,5 @@
/*
- * "$Id: bit-ops.h,v 1.4 2009/05/17 19:25:36 rlk Exp $"
+ * "$Id: bit-ops.h,v 1.5 2012/04/19 14:41:03 gernot2270 Exp $"
*
* Softweave calculator for gimp-print.
*
@@ -77,6 +77,17 @@ extern void stp_fold_4bit(const unsigned char *line, int single_length,
unsigned char *outbuf);
/**
+ * Interleave a buffer consisting of eight bit strings of length single_length
+ * into one string of packed eight-bit ints.
+ *
+ * @param line the input bit string
+ * @param single_length the length (in bytes) of the input
+ * @param outbuf the output.
+ */
+extern void stp_fold_8bit(const unsigned char *line, int single_length,
+ unsigned char *outbuf);
+
+/**
* Split an input sequence of packed 1 or 2 bit integers into two or more
* outputs of equal length, distributing non-zero integers round robin
* into each output. Used in "high quality" modes when extra passes are
diff --git a/include/gutenprint/vars.h b/include/gutenprint/vars.h
index c2870a0..796e796 100644
--- a/include/gutenprint/vars.h
+++ b/include/gutenprint/vars.h
@@ -438,6 +438,14 @@ extern void *stp_get_errdata(const stp_vars_t *v);
*/
extern void stp_merge_printvars(stp_vars_t *user, const stp_vars_t *print);
+/**
+ * Copy settings from one vars object to another, not modifying anything
+ * unset in the source.
+ * @param to the destination vars.
+ * @param from the vars to merge into user.
+ */
+extern void stp_copy_vars_from(stp_vars_t *to, const stp_vars_t *from);
+
/****************************************************************
* *
@@ -1537,5 +1545,5 @@ stp_fill_parameter_settings(stp_parameter_t *desc,
#endif /* GUTENPRINT_VARS_H */
/*
- * End of "$Id: vars.h,v 1.8 2010/12/05 21:38:14 rlk Exp $".
+ * End of "$Id: vars.h,v 1.10 2011/06/12 00:47:15 rlk Exp $".
*/