summaryrefslogtreecommitdiff
path: root/scripts/autogen.sh
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
committerDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
commite50542121e724e851fc5d6c68bb773f80c0bc12c (patch)
tree655c3f6331a6e8fd8b09ceb4da8f5896484ae16a /scripts/autogen.sh
parent9dd97a029bf391c42b1dc76f2f7c5e386bb8f466 (diff)
New upstream version 5.3.1
Diffstat (limited to 'scripts/autogen.sh')
-rw-r--r--scripts/autogen.sh50
1 files changed, 37 insertions, 13 deletions
diff --git a/scripts/autogen.sh b/scripts/autogen.sh
index 312887a..7b88ee2 100644
--- a/scripts/autogen.sh
+++ b/scripts/autogen.sh
@@ -16,6 +16,23 @@ else
mkdir m4local
fi
+if test -d m4 ; then
+ :
+else
+ echo "Directory \`m4' does not exist. Creating it."
+ if test -e m4 ; then
+ echo "**Error**: A file \`m4' exists and is not a directory."
+ echo "Please remove it."
+ DIE=1
+ fi
+ mkdir m4
+fi
+
+test -f $srcdir/configure.ac && sed "s/XXXRELEASE_DATE=XXX/RELEASE_DATE=\"`date '+%d %b %Y'`\"/" $srcdir/m4extra/stp_release.m4.in > $srcdir/m4/stp_release.m4
+
+# Make sure all of our auto* bits are up to date.
+autoreconf -ivf
+
libtoolv=`libtool --version | head -1 | sed 's,.*[ ]\([0-9][0-9]*\.[0-9][0-9]*\(\.[0-9][0-9]*\)\?\).*[a-z]*\([ ]?.*\|\)$,\1,'`
libtool_major=`echo $libtoolv | awk -F. '{print $1}'`
libtool_minor=`echo $libtoolv | awk -F. '{print $2}'`
@@ -42,8 +59,6 @@ test "$libtool_major" -le 1 && {
DIE=1
}
-test -f $srcdir/configure.ac && sed "s/XXXRELEASE_DATE=XXX/RELEASE_DATE=\"`date '+%d %b %Y'`\"/" $srcdir/m4extra/stp_release.m4.in > $srcdir/m4/stp_release.m4
-
test -f $srcdir/ChangeLog || echo > $srcdir/ChangeLog
(grep "^AM_PROG_LIBTOOL" $srcdir/configure.ac >/dev/null) && {
@@ -103,7 +118,7 @@ test "$gettext_major" -eq 0 && {
echo
echo "**Error**: You must have \`autopoint' installed to"
echo "create a Gutenprint distribution."
- echo "Get ftp://ftp.gnu.org/pub/gnu/gettext/gettext-0.11.5.tar.gz"
+ echo "Get ftp://ftp.gnu.org/pub/gnu/gettext/gettext-0.16.tar.gz"
echo "(or a newer version if it is available)"
DIE=1
NO_AUTOMAKE=yes
@@ -217,17 +232,24 @@ test "$openjade_err" -eq 0 && {
}
}
-# Check for ps2pdf
+db2htmlloc=`type -p db2html`
-ps2pdfloc=`type -p ps2pdf`
+test -z "$db2htmlloc" && {
+ echo " "
+ echo "***Warning***: You must have \"db2html\" installed to"
+ echo "build the Gutenprint user's guide."
+ echo "This usually comes from packages named docbook-utils or docbook-toys."
+ echo " "
+}
-test -z "ps2pdfloc" && {
+db2pdfloc=`type -p db2pdf`
+
+test -z "$db2pdfloc" && {
echo " "
- echo "***Warning***: You must have \"ps2pdf\" installed to"
+ echo "***Warning***: You must have \"db2pdf\" installed to"
echo "build the Gutenprint user's guide."
- echo "\"ps2pdf\" comes from the GNU Ghostscript software package."
- echo "Get ftp://ftp.gnu.org/gnu/ghostscript/ghostscript-6.5.1.tar.gz"
- echo "(or a newer version if available)"
+ echo "This usually comes from packages named docbook-utils-pdf"
+ echo "or docbook-toys."
echo " "
}
@@ -257,7 +279,7 @@ test "$sgmltools_err" -eq 0 && {
echo " "
echo "***Warning***: You must have \"sgmltools-lite\" version 3.0.2"
echo "or newer installed to build the Gutenprint user's guide."
- echo "Get http://prdownloads.sourceforge.net/projects/sgmltools-lite/sgmltools-lite-3.0.2.tar.gz"
+ echo "Get https://sourceforge.net/projects/sgmltools-lite/files/latest/download"
echo "(or a newer version if available)"
echo " "
}
@@ -291,7 +313,7 @@ if test -d /usr/share/sgml/docbook ; then
fi
{
- test -d "/usr/share/sgml/docbook_4" || test -d "/usr/share/sgml/docbook/dtd/4.0" || test -d "/usr/share/sgml/docbook_4.1" || test -n "$fedora_docbook"
+ test -d "/usr/share/sgml/docbook_4" || test -d "/usr/share/sgml/docbook/dtd/4.0" || test -d "/usr/share/sgml/docbook/dtd/4.1" || test -d "/usr/share/sgml/docbook_4.1" || test -n "$fedora_docbook"
} || {
echo " "
echo "***Warning***: You must have Docbook v4 installed to"
@@ -315,7 +337,9 @@ xlc )
am_opt=--include-deps;;
esac
-for coin in `find $srcdir -name configure.ac -print`
+# We don't have subdirectories. We don't want any untarred directories that
+# contain configure.ac files to mess things up for us.
+for coin in "$srcdir/configure.ac"
do
dr=`dirname $coin`
if test -f $dr/NO-AUTO-GEN; then