summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 16:16:09 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 16:16:09 +0000
commit3950c83c2919fe59dbf442c0d4859778fadd0e8d (patch)
treea94521b94f4a256b5b6d7f004f4afd5f9aae5db0 /scripts
parent97aedb05b271e9486f51eac1aee64fce92da64ca (diff)
Imported Upstream version 4.3.99+cvs20060521
Diffstat (limited to 'scripts')
-rw-r--r--scripts/Makefile.in7
-rwxr-xr-xscripts/config.guess69
-rwxr-xr-xscripts/config.sub5
-rw-r--r--scripts/global.mk4
-rw-r--r--scripts/ltmain.sh12
-rwxr-xr-xscripts/mkchlog68
6 files changed, 101 insertions, 64 deletions
diff --git a/scripts/Makefile.in b/scripts/Makefile.in
index ee4e868..1b615fc 100644
--- a/scripts/Makefile.in
+++ b/scripts/Makefile.in
@@ -15,6 +15,9 @@
@SET_MAKE@
# Variables
+
+#export STP_MODULE_PATH = $(top_builddir)/src/main/.libs:$(top_builddir)/src/main
+#export STP_DATA_PATH = $(top_srcdir)/src/main
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
@@ -243,6 +246,7 @@ USE_NLS = @USE_NLS@
USE_NLS_FALSE = @USE_NLS_FALSE@
USE_NLS_TRUE = @USE_NLS_TRUE@
VERSION = @VERSION@
+WHICH_PPDS = @WHICH_PPDS@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
ac_ct_AR = @ac_ct_AR@
@@ -477,9 +481,6 @@ uninstall-am: uninstall-info-am
@SET_MAKE@
-export STP_MODULE_PATH = $(top_builddir)/src/main/.libs:$(top_builddir)/src/main
-export STP_DATA_PATH = $(top_srcdir)/src/main
-
# Rules
$(top_builddir)/src/main/libgutenprint.la:
diff --git a/scripts/config.guess b/scripts/config.guess
index ad5281e..910f4ee 100755
--- a/scripts/config.guess
+++ b/scripts/config.guess
@@ -3,7 +3,7 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-timestamp='2005-08-03'
+timestamp='2005-07-08'
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -138,6 +138,16 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
+case "${UNAME_MACHINE}" in
+ i?86)
+ test -z "$VENDOR" && VENDOR=pc
+ ;;
+ *)
+ test -z "$VENDOR" && VENDOR=unknown
+ ;;
+esac
+test -f /etc/SuSE-release -o -f /.buildenv && VENDOR=suse
+
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
@@ -794,7 +804,7 @@ EOF
i*:UWIN*:*)
echo ${UNAME_MACHINE}-pc-uwin
exit ;;
- amd64:CYGWIN*:*:* | x86_64:CYGWIN*:*:*)
+ amd64:CYGWIN*:*:*)
echo x86_64-unknown-cygwin
exit ;;
p*:CYGWIN*:*)
@@ -815,25 +825,25 @@ EOF
echo ${UNAME_MACHINE}-pc-minix
exit ;;
arm*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
cris:Linux:*:*)
- echo cris-axis-linux-gnu
+ echo cris-axis-linux
exit ;;
crisv32:Linux:*:*)
- echo crisv32-axis-linux-gnu
+ echo crisv32-axis-linux
exit ;;
frv:Linux:*:*)
- echo frv-unknown-linux-gnu
+ echo frv-${VENDOR}-linux
exit ;;
ia64:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
m32r*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
m68*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
mips:Linux:*:*)
eval $set_cc_for_build
@@ -852,7 +862,7 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-${VENDOR}-linux"; exit; }
;;
mips64:Linux:*:*)
eval $set_cc_for_build
@@ -871,16 +881,13 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-${VENDOR}-linux"; exit; }
;;
- or32:Linux:*:*)
- echo or32-unknown-linux-gnu
- exit ;;
ppc:Linux:*:*)
- echo powerpc-unknown-linux-gnu
+ echo powerpc-${VENDOR}-linux
exit ;;
ppc64:Linux:*:*)
- echo powerpc64-unknown-linux-gnu
+ echo powerpc64-${VENDOR}-linux
exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
@@ -894,33 +901,33 @@ EOF
esac
objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
- echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
+ echo ${UNAME_MACHINE}-${VENDOR}-linux${LIBC}
exit ;;
parisc:Linux:*:* | hppa:Linux:*:*)
# Look for CPU level
case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
- PA7*) echo hppa1.1-unknown-linux-gnu ;;
- PA8*) echo hppa2.0-unknown-linux-gnu ;;
- *) echo hppa-unknown-linux-gnu ;;
+ PA7*) echo hppa1.1-${VENDOR}-linux ;;
+ PA8*) echo hppa2.0-${VENDOR}-linux ;;
+ *) echo hppa-${VENDOR}-linux ;;
esac
exit ;;
parisc64:Linux:*:* | hppa64:Linux:*:*)
- echo hppa64-unknown-linux-gnu
+ echo hppa64-${VENDOR}-linux
exit ;;
s390:Linux:*:* | s390x:Linux:*:*)
echo ${UNAME_MACHINE}-ibm-linux
exit ;;
sh64*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
sh*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
sparc:Linux:*:* | sparc64:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-${VENDOR}-linux
exit ;;
x86_64:Linux:*:*)
- echo x86_64-unknown-linux-gnu
+ echo x86_64-${VENDOR}-linux
exit ;;
i*86:Linux:*:*)
# The BFD linker knows what the default object file format is, so
@@ -935,18 +942,18 @@ EOF
p'`
case "$ld_supported_targets" in
elf32-i386)
- TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
+ TENTATIVE="${UNAME_MACHINE}-${VENDOR}-linux"
;;
a.out-i386-linux)
- echo "${UNAME_MACHINE}-pc-linux-gnuaout"
+ echo "${UNAME_MACHINE}-${VENDOR}-linuxaout"
exit ;;
coff-i386)
- echo "${UNAME_MACHINE}-pc-linux-gnucoff"
+ echo "${UNAME_MACHINE}-${VENDOR}-linuxcoff"
exit ;;
"")
- # Either a pre-BFD a.out linker (linux-gnuoldld) or
+ # Either a pre-BFD a.out linker (linuxoldld) or
# one that does not give us useful --help.
- echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
+ echo "${UNAME_MACHINE}-${VENDOR}-linuxoldld"
exit ;;
esac
# Determine whether the default compiler is a.out or elf
@@ -976,7 +983,7 @@ EOF
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^LIBC=`
test x"${LIBC}" != x && {
- echo "${UNAME_MACHINE}-pc-linux-${LIBC}"
+ echo "${UNAME_MACHINE}-${VENDOR}-linux-${LIBC}" | sed 's/linux-gnu/linux/'
exit
}
test x"${TENTATIVE}" != x && { echo "${TENTATIVE}"; exit; }
diff --git a/scripts/config.sub b/scripts/config.sub
index 1c366df..6e2bdbf 100755
--- a/scripts/config.sub
+++ b/scripts/config.sub
@@ -1181,7 +1181,7 @@ case $os in
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
| -chorusos* | -chorusrdb* \
| -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
- | -mingw32* | -linux-gnu* | -linux-uclibc* | -uxpv* | -beos* | -mpeix* | -udk* \
+ | -mingw32* | -linux* | -linux-uclibc* | -uxpv* | -beos* | -mpeix* | -udk* \
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
| -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
@@ -1215,9 +1215,6 @@ case $os in
-linux-dietlibc)
os=-linux-dietlibc
;;
- -linux*)
- os=`echo $os | sed -e 's|linux|linux-gnu|'`
- ;;
-sunos5*)
os=`echo $os | sed -e 's|sunos5|solaris2|'`
;;
diff --git a/scripts/global.mk b/scripts/global.mk
index 026e714..0aa97b9 100644
--- a/scripts/global.mk
+++ b/scripts/global.mk
@@ -3,8 +3,8 @@
# Variables
-export STP_MODULE_PATH = $(top_builddir)/src/main/.libs:$(top_builddir)/src/main
-export STP_DATA_PATH = $(top_srcdir)/src/main
+#export STP_MODULE_PATH = $(top_builddir)/src/main/.libs:$(top_builddir)/src/main
+#export STP_DATA_PATH = $(top_srcdir)/src/main
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
diff --git a/scripts/ltmain.sh b/scripts/ltmain.sh
index 8fc56db..06823e0 100644
--- a/scripts/ltmain.sh
+++ b/scripts/ltmain.sh
@@ -43,7 +43,7 @@ EXIT_FAILURE=1
PROGRAM=ltmain.sh
PACKAGE=libtool
-VERSION="1.5.22 Debian 1.5.22-2"
+VERSION=1.5.22
TIMESTAMP=" (1.1220.2.365 2005/12/18 22:14:06)"
# See if we are running on zsh, and set the options which allow our
@@ -2082,10 +2082,7 @@ EOF
case $pass in
dlopen) libs="$dlfiles" ;;
dlpreopen) libs="$dlprefiles" ;;
- link)
- libs="$deplibs %DEPLIBS%"
- test "X$link_all_deplibs" != Xno && libs="$libs $dependency_libs"
- ;;
+ link) libs="$deplibs %DEPLIBS% $dependency_libs" ;;
esac
fi
if test "$pass" = dlopen; then
@@ -3204,11 +3201,6 @@ EOF
age="$number_minor"
revision="$number_minor"
;;
- *)
- $echo "$modename: unknown library version type \`$version_type'" 1>&2
- $echo "Fatal configuration error. See the $PACKAGE docs for more information." 1>&2
- exit $EXIT_FAILURE
- ;;
esac
;;
no)
diff --git a/scripts/mkchlog b/scripts/mkchlog
index a51c034..4a0b5d0 100755
--- a/scripts/mkchlog
+++ b/scripts/mkchlog
@@ -8,6 +8,7 @@
%logmsgs = (); # Index by date, time, and author
%fileversions = ();
$skipme = 0;
+%basenames = ();
@cvsdirs=`find . -type d -name CVS -print`;
map { chomp; s,^\./,, } @cvsdirs;
@@ -18,6 +19,7 @@ foreach $d (@cvsdirs) {
while (<ENTRIES>) {
local ($type, $file, $version, @junk) = split /\//;
if ($type eq "") {
+ $basenames{"$file"} = "1";
$file = "$rootdir$file";
$fileversions{$file} = $version;
}
@@ -70,15 +72,35 @@ sub compare_versions
# There is a special case: If the working version doesn't exist at all,
# we return true if the log version is on the mainline. This lets us
# see log messages from files that have been deleted.
+ #
+ # Return value:
+ #
+ # 4 if there is no working version and the log version is at top level
+ #
+ # 2 if there is no working version and the log version is not at top
+ # level
+ #
+ # 3 if the number of components in the log version exceeds the number
+ # of components in the working version
+ #
+ # 0 if the log version is later than or on a different branch from
+ # the working version
+ #
+ # 1 otherwise (if the log version is a predecessor of the working version)
my ($vw, $vl) = @_;
+ my (@vvl) = split /\./, $vl;
+
if ($vw eq "") {
- return 2;
+ if ($#vvl < 2) {
+ return 2;
+ } else {
+ return 4;
+ }
}
my (@vvw) = split /\./, $vw;
- my (@vvl) = split /\./, $vl;
if ($#vvl > $#vvw) {
return 3;
}
@@ -110,21 +132,24 @@ while (<>) {
next;
} elsif (/^revision /) {
($ignore, $revision) = split;
+ my ($currentbasefile) = $currentfile;
+ $currentbasefile =~ s;.*/([^/]+);\1;;
my ($check) =&compare_versions($fileversions{$currentfile}, $revision);
#
- # Special case -- if a file is not in the current sandbox, but is
- # at top level, log it; otherwise if it is not in the current
- # sandbox, don't log it.
+ # Special case -- if a file is not in the current sandbox, but it
+ # has the same base name as a file in the sandbox, log it;
+ # otherwise if it is not in the current sandbox, don't log it.
#
- if (($check == 2 && !($currentfile =~ /\//) &&
- ($currentfile =~ /\.[chly]$/)) ||
+ if (($check == 2 && (1 || (
+ ($basenames{"$currentbasefile"} || !($currentfile =~ /\//)) &&
+ ($currentfile =~ /\.[chly]$/)))) ||
$check == 1) {
$skipme = 0;
} else {
$skipme = 1;
}
} elsif (/^date: /) {
- ($ignore, $date, $time, $ignore, $author, $ignore, $ignore,
+ ($ignore, $date, $time, $ignore, $author, $ignore, $state,
$ignore, $plus, $minus, $ignore) = split;
# $time =~ s/[0-9]:[0-9][0-9];$//;
# $time =~ s/[0-9][0-9];$//;
@@ -149,8 +174,14 @@ while (<>) {
$datetimeauthor = "$date $time $author $junkbody $currentfile $revision";
if ($skipme == 0) {
$logmsgs{$datetimeauthor} = $body;
- $plus{$datetimeauthor} = $plus;
- $minus{$datetimeauthor} = $minus;
+ if ($plus eq "") {
+ $plus{$datetimeauthor} = "added";
+ } elsif ($state eq "dead;") {
+ $plus{$datetimeauthor} = "removed";
+ } else {
+ $plus{$datetimeauthor} = $plus;
+ $minus{$datetimeauthor} = $minus;
+ }
}
} # Other junk we ignore
}
@@ -160,13 +191,20 @@ $header="";
@fileinfo = ();
@chlog = reverse sort keys %logmsgs;
+%filenames_printed = ();
foreach $_ (@chlog) {
($date, $time, $author, $junk, $file, $revision) = split;
$date =~ s,/,-,g;
$msg = $logmsgs{$_};
- if ($prevmsg eq $msg) {
- push @fileinfo, "\t\t$file ($revision) ($plus{$_} $minus{$_})\n";
+ my $delta;
+ if (! $minus{$_}) {
+ $delta = "$plus{$_}";
+ } else {
+ $delta = "$plus{$_} $minus{$_}";
+ }
+ if ($prevmsg eq $msg && !$filenames_printed{$file}) {
+ push @fileinfo, "\t\t$file ($revision) ($delta)\n";
} else {
if ($prevmsg ne "" || $#fileinfo >= 0) {
print $header;
@@ -178,15 +216,17 @@ foreach $_ (@chlog) {
$prevmsg =~ s/[ \t]+\n/\n/g;
$prevmsg =~ s/[ \t]+$//g;
print "$prevmsg\n";
+ %filenames_printed = ();
}
$header = "$date\t<$author\@sourceforge.net>\n\n";
$prevmsg = $msg;
@fileinfo = ();
- push @fileinfo, "\t\t$file ($revision) ($plus{$_} $minus{$_})\n";
+ push @fileinfo, "\t\t$file ($revision) ($delta)\n";
+ $filenames_printed{$file} = 1;
}
}
-if ($prevmsg ne "" or $fileinfo ne "") {
+if ($prevmsg ne "" or $#fileinfo >= 0) {
print "$date\t<$author\@sourceforge.net>\n\n";
$filestuff = join "", sort @fileinfo;
$filestuff =~ s/\t/\tFiles:/;