summaryrefslogtreecommitdiff
path: root/src/cups
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 16:11:56 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 16:11:56 +0000
commit7e12d32a372b5661f80b68009730cf47a6bfd062 (patch)
tree821ddd7a41794bb6fec964ce81ba89a13cebb20a /src/cups
parentdfae5860833782af557deb35e286d7e186fe3cf5 (diff)
Imported Upstream version 4.3.99+cvs20050715
Diffstat (limited to 'src/cups')
-rw-r--r--src/cups/Makefile.in1
-rw-r--r--src/cups/cups-genppdupdate.in5
2 files changed, 2 insertions, 4 deletions
diff --git a/src/cups/Makefile.in b/src/cups/Makefile.in
index cba2fe5..bb55b9e 100644
--- a/src/cups/Makefile.in
+++ b/src/cups/Makefile.in
@@ -336,7 +336,6 @@ ac_ct_CXX = @ac_ct_CXX@
ac_ct_F77 = @ac_ct_F77@
ac_ct_RANLIB = @ac_ct_RANLIB@
ac_ct_STRIP = @ac_ct_STRIP@
-ac_pt_PKG_CONFIG = @ac_pt_PKG_CONFIG@
am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
diff --git a/src/cups/cups-genppdupdate.in b/src/cups/cups-genppdupdate.in
index c48723c..42f7cd9 100644
--- a/src/cups/cups-genppdupdate.in
+++ b/src/cups/cups-genppdupdate.in
@@ -1,5 +1,5 @@
#! @PERL@ -w
-# $Id: cups-genppdupdate.in,v 1.19 2005/04/30 11:48:26 rleigh Exp $
+# $Id: cups-genppdupdate.in,v 1.20 2005/07/04 23:07:11 rleigh Exp $
# Update CUPS PPDs for Gutenprint queues.
# Copyright (C) 2002-2003 Roger Leigh (rleigh@debian.org)
#
@@ -427,8 +427,7 @@ sub find_ppd ($$$$) {
# Check that it is a regular file, owned by root.root, not writable
# by other, and is readable by root. i.e. the file is secure.
my @sb = stat $fn or next;
- if (S_ISREG($sb[2]) && ($sb[4] == 0) && ($sb[5] == 0)) {
-# !(S_IWOTH & $sb[2]) && (S_IRUSR & $sb[2])) {
+ if (S_ISREG($sb[2]) && ($sb[4] == 0)) {
# Check that the file is a valid Gutenprint PPD file
# of the correct version.
my $file_version;