summaryrefslogtreecommitdiff
path: root/src/escputil
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2009-08-02 12:01:21 +0100
committerRoger Leigh <rleigh@debian.org>2009-08-02 12:01:21 +0100
commit0f09a5be038c93c1bd5ca2988e152345bbf74c00 (patch)
tree279995ae9eece33b9b05cd82993f4fce98356fe8 /src/escputil
parenta68ece422e0be1a0101dae2fa2408ef0e533c2e9 (diff)
Imported Upstream version 5.2.4
Diffstat (limited to 'src/escputil')
-rw-r--r--src/escputil/Makefile.in33
-rw-r--r--src/escputil/escputil.c28
2 files changed, 33 insertions, 28 deletions
diff --git a/src/escputil/Makefile.in b/src/escputil/Makefile.in
index d441e3c..07325b5 100644
--- a/src/escputil/Makefile.in
+++ b/src/escputil/Makefile.in
@@ -45,11 +45,14 @@ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/isc-posix.m4 \
$(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/nls.m4 \
- $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/progtest.m4 \
- $(top_srcdir)/m4/stp.m4 $(top_srcdir)/m4/stp_cups.m4 \
- $(top_srcdir)/m4/stp_gimp.m4 $(top_srcdir)/m4/stp_option.m4 \
- $(top_srcdir)/m4/stp_release.m4 $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libtool.m4 \
+ $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
+ $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
+ $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
+ $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp.m4 \
+ $(top_srcdir)/m4/stp_cups.m4 $(top_srcdir)/m4/stp_gimp.m4 \
+ $(top_srcdir)/m4/stp_option.m4 $(top_srcdir)/m4/stp_release.m4 \
+ $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
@@ -98,10 +101,6 @@ CUPS_CFLAGS = @CUPS_CFLAGS@
CUPS_CONFIG = @CUPS_CONFIG@
CUPS_LIBS = @CUPS_LIBS@
CUPS_PPD_PS_LEVEL = @CUPS_PPD_PS_LEVEL@
-CXX = @CXX@
-CXXCPP = @CXXCPP@
-CXXDEPMODE = @CXXDEPMODE@
-CXXFLAGS = @CXXFLAGS@
CYGPATH_W = @CYGPATH_W@
DB2HTML = @DB2HTML@
DB2PDF = @DB2PDF@
@@ -111,16 +110,15 @@ DEPDIR = @DEPDIR@
DIALOG = @DIALOG@
DOXYGEN = @DOXYGEN@
DSYMUTIL = @DSYMUTIL@
+DUMPBIN = @DUMPBIN@
DVIPDF = @DVIPDF@
DVIPS = @DVIPS@
-ECHO = @ECHO@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
-F77 = @F77@
-FFLAGS = @FFLAGS@
+FGREP = @FGREP@
FIND = @FIND@
FOOMATIC_CONFIGURE = @FOOMATIC_CONFIGURE@
FOOMATIC_KITLOAD = @FOOMATIC_KITLOAD@
@@ -165,6 +163,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
INTLLIBS = @INTLLIBS@
INTL_MACOSX_LIBS = @INTL_MACOSX_LIBS@
+LD = @LD@
LDFLAGS = @LDFLAGS@
LEX = @LEX@
LEXLIB = @LEXLIB@
@@ -176,6 +175,7 @@ LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
+LIPO = @LIPO@
LN_S = @LN_S@
LTALLOCA = @LTALLOCA@
LTLIBICONV = @LTLIBICONV@
@@ -188,8 +188,12 @@ MKDIR_P = @MKDIR_P@
MSGFMT = @MSGFMT@
MSGFMT_015 = @MSGFMT_015@
MSGMERGE = @MSGMERGE@
+NM = @NM@
NMEDIT = @NMEDIT@
+OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@
+OTOOL = @OTOOL@
+OTOOL64 = @OTOOL64@
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
@@ -223,8 +227,7 @@ abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
ac_ct_CC = @ac_ct_CC@
-ac_ct_CXX = @ac_ct_CXX@
-ac_ct_F77 = @ac_ct_F77@
+ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
am__include = @am__include@
am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
@@ -269,6 +272,7 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
+lt_ECHO = @lt_ECHO@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
@@ -281,6 +285,7 @@ sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
+top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
diff --git a/src/escputil/escputil.c b/src/escputil/escputil.c
index df65b46..0d14b08 100644
--- a/src/escputil/escputil.c
+++ b/src/escputil/escputil.c
@@ -1,5 +1,5 @@
/*
- * "$Id: escputil.c,v 1.99 2008/12/21 18:35:43 rlk Exp $"
+ * "$Id: escputil.c,v 1.100 2009/03/22 01:35:18 rlk Exp $"
*
* Printer maintenance utility for EPSON Stylus (R) printers
*
@@ -1242,7 +1242,7 @@ print_old_ink_levels(const char *ind, stp_string_list_t *color_list)
if (!ind[0] || ind[0] == ';')
return;
val = (get_digit(ind[0]) << 4) + get_digit(ind[1]);
- printf("%18s %20d\n",
+ printf("%20s %20d\n",
gettext(stp_string_list_param(color_list, i)->text), val);
ind += 2;
}
@@ -1292,7 +1292,7 @@ do_old_status(status_cmd_t cmd, const char *buf, const stp_printer_t *printer)
if (cmd == CMD_STATUS)
printf(_("Ink Levels:\n"));
- printf("%18s %20s\n", _("Ink color"), _("Percent remaining"));
+ printf("%20s %20s\n", _("Ink color"), _("Percent remaining"));
print_old_ink_levels(ind, color_list);
stp_string_list_destroy(color_list);
if (cmd == CMD_STATUS)
@@ -1331,16 +1331,16 @@ do_new_status(status_cmd_t cmd, char *buf, int bytes,
ind = buf + i + 3;
if (cmd == CMD_STATUS)
printf(_("Ink Levels:\n"));
- printf("%18s %20s\n", _("Ink color"), _("Percent remaining"));
+ printf("%20s %20s\n", _("Ink color"), _("Percent remaining"));
for (j = 0; j < count; j++)
{
if (ind[0] < color_count && param == 3 &&
(interchangeable_inks || ind[1] >= aux_color_count ||
! aux_colors[(int) ind[1]]))
- printf("%18s %20d\n",
+ printf("%20s %20d\n",
gettext(colors_new[(int) ind[0]]), ind[2]);
else if (ind[1] < aux_color_count && aux_colors[(int) ind[1]])
- printf("%18s %20d\n",
+ printf("%20s %20d\n",
gettext(aux_colors[(int) ind[1]]), ind[2]);
else
printf("%8s 0x%02x 0x%02x %20d\n",
@@ -1603,14 +1603,14 @@ do_extended_ink_info(int extended_output)
&year2, &month2, &id2) == 12)
{
int j;
- printf("%18s %20s %12s %7s\n",
+ printf("%20s %20s %12s %7s\n",
_("Ink cartridge"), _("Percent remaining"), _("Part number"),
_("Date"));
- printf("%18s %20d T0%03d %2d%02d-%02d\n",
+ printf("%20s %20d T0%03d %2d%02d-%02d\n",
gettext(stp_string_list_param(color_list, 0)->text),
iv[0], id, (year > 80 ? 19 : 20), year, month);
for (j = 1; j < 6; j++)
- printf("%18s %20d T0%03d %2d%02d-%02d\n",
+ printf("%20s %20d T0%03d %2d%02d-%02d\n",
gettext(stp_string_list_param(color_list, j)->text),
iv[j], id2, (year2 > 80 ? 19 : 20), year2, month2);
break;
@@ -1627,14 +1627,14 @@ do_extended_ink_info(int extended_output)
&year2, &month2, &id2) == 10)
{
int j;
- printf("%18s %20s %12s %7s\n",
+ printf("%20s %20s %12s %7s\n",
_("Ink cartridge"), _("Percent remaining"), _("Part number"),
_("Date"));
- printf("%18s %20d T0%03d %2d%02d-%02d\n",
+ printf("%20s %20d T0%03d %2d%02d-%02d\n",
gettext(stp_string_list_param(color_list, 0)->text),
iv[0], id, (year > 80 ? 19 : 20), year, month);
for (j = 1; j < 4; j++)
- printf("%18s %20d T0%03d %2d%02d-%02d\n",
+ printf("%20s %20d T0%03d %2d%02d-%02d\n",
gettext(stp_string_list_param(color_list, j)->text),
iv[j], id2, (year2 > 80 ? 19 : 20), year2, month2);
break;
@@ -1647,10 +1647,10 @@ do_extended_ink_info(int extended_output)
&val, &year, &month, &id ) == 4)
{
if (i == 0)
- printf("%18s %20s %12s %7s\n",
+ printf("%20s %20s %12s %7s\n",
_("Ink cartridge"), _("Percent remaining"), _("Part number"),
_("Date"));
- printf("%18s %20d T0%03d %2d%02d-%02d\n",
+ printf("%20s %20d T0%03d %2d%02d-%02d\n",
gettext(stp_string_list_param(color_list, i)->text),
val, id, (year > 80 ? 19 : 20), year, month);
}