summaryrefslogtreecommitdiff
path: root/src/gutenprintui2
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 16:16:44 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 16:16:44 +0000
commit92b02ddce00dec2787514568fa9d644d4f0350e9 (patch)
tree015c66d9d7d4298a26554d12bb84c83d5c477f0e /src/gutenprintui2
parent3950c83c2919fe59dbf442c0d4859778fadd0e8d (diff)
Imported Upstream version 5.0.0
Diffstat (limited to 'src/gutenprintui2')
-rw-r--r--src/gutenprintui2/Makefile.in2
-rw-r--r--src/gutenprintui2/panel.c24
-rw-r--r--src/gutenprintui2/ui-utils.c10
3 files changed, 19 insertions, 17 deletions
diff --git a/src/gutenprintui2/Makefile.in b/src/gutenprintui2/Makefile.in
index 6c56519..9226fe7 100644
--- a/src/gutenprintui2/Makefile.in
+++ b/src/gutenprintui2/Makefile.in
@@ -125,6 +125,8 @@ BUILD_GENPPD_STATIC_FALSE = @BUILD_GENPPD_STATIC_FALSE@
BUILD_GENPPD_STATIC_TRUE = @BUILD_GENPPD_STATIC_TRUE@
BUILD_GHOSTSCRIPT_FALSE = @BUILD_GHOSTSCRIPT_FALSE@
BUILD_GHOSTSCRIPT_TRUE = @BUILD_GHOSTSCRIPT_TRUE@
+BUILD_GIMP2_AS_GUTENPRINT_FALSE = @BUILD_GIMP2_AS_GUTENPRINT_FALSE@
+BUILD_GIMP2_AS_GUTENPRINT_TRUE = @BUILD_GIMP2_AS_GUTENPRINT_TRUE@
BUILD_GIMP2_FALSE = @BUILD_GIMP2_FALSE@
BUILD_GIMP2_TRUE = @BUILD_GIMP2_TRUE@
BUILD_GIMP_FALSE = @BUILD_GIMP_FALSE@
diff --git a/src/gutenprintui2/panel.c b/src/gutenprintui2/panel.c
index 466f684..d979ab7 100644
--- a/src/gutenprintui2/panel.c
+++ b/src/gutenprintui2/panel.c
@@ -1,5 +1,5 @@
/*
- * "$Id: panel.c,v 1.10 2006/03/18 23:56:37 rlk Exp $"
+ * "$Id: panel.c,v 1.11 2006/05/28 16:59:04 rlk Exp $"
*
* Main window code for Print plug-in for the GIMP.
*
@@ -523,7 +523,7 @@ stpui_create_curve(option_t *opt,
gtk_widget_show(opt->info.curve.button);
opt->info.curve.dialog =
- stpui_dialog_new(_(opt->fast_desc->text),
+ stpui_dialog_new(gettext(opt->fast_desc->text),
GTK_WIN_POS_MOUSE, TRUE,
_("Set Default"), set_default_curve_callback,
opt, NULL, NULL, FALSE, FALSE,
@@ -627,7 +627,7 @@ stpui_create_boolean(option_t *opt,
gtk_widget_hide(opt->checkbox);
opt->info.bool.checkbox =
- gtk_toggle_button_new_with_label(_(opt->fast_desc->text));
+ gtk_toggle_button_new_with_label(gettext(opt->fast_desc->text));
gtk_table_attach(GTK_TABLE(table), opt->info.bool.checkbox,
column + 1, column + 3, row, row + 1,
GTK_EXPAND|GTK_FILL, GTK_FILL, 0, 0);
@@ -985,14 +985,14 @@ populate_option_table(GtkWidget *table, int p_class)
case STP_PARAMETER_TYPE_DOUBLE:
stpui_create_scale_entry(opt, GTK_TABLE(table), 0,
vpos[desc->p_level][desc->p_type]++,
- _(desc->text), 200, 0,
+ gettext(desc->text), 200, 0,
opt->info.flt.deflt,
opt->info.flt.lower,
opt->info.flt.upper,
.001, .01, 3, TRUE, 0, 0, NULL,
!(desc->is_mandatory));
stpui_set_adjustment_tooltip(opt->info.flt.adjustment,
- _(desc->help));
+ gettext(desc->help));
g_signal_connect(G_OBJECT(opt->info.flt.adjustment),
"value_changed",
G_CALLBACK(color_update), opt);
@@ -1024,7 +1024,7 @@ populate_option_table(GtkWidget *table, int p_class)
}
stpui_create_scale_entry(opt, GTK_TABLE(table), 0,
vpos[desc->p_level][desc->p_type]++,
- _(desc->text), 200, 0,
+ gettext(desc->text), 200, 0,
opt->info.flt.deflt / unit_scaler,
opt->info.flt.lower / unit_scaler,
opt->info.flt.upper / unit_scaler,
@@ -1032,7 +1032,7 @@ populate_option_table(GtkWidget *table, int p_class)
digits, TRUE, 0, 0, NULL,
!(desc->is_mandatory));
stpui_set_adjustment_tooltip(opt->info.flt.adjustment,
- _(desc->help));
+ gettext(desc->help));
g_signal_connect(G_OBJECT(opt->info.flt.adjustment),
"value_changed",
G_CALLBACK(dimension_update), opt);
@@ -1048,7 +1048,7 @@ populate_option_table(GtkWidget *table, int p_class)
opt->info.curve.current = NULL;
stpui_create_curve(opt, GTK_TABLE(table), 0,
vpos[desc->p_level][desc->p_type]++,
- _(desc->text), opt->info.curve.deflt,
+ gettext(desc->text), opt->info.curve.deflt,
!(desc->is_mandatory));
if (desc->p_level > MAXIMUM_PARAMETER_LEVEL)
stp_set_curve_parameter_active(pv->v, desc->name,
@@ -1059,7 +1059,7 @@ populate_option_table(GtkWidget *table, int p_class)
stp_get_boolean_parameter(pv->v, opt->fast_desc->name);
stpui_create_boolean(opt, GTK_TABLE(table), 0,
vpos[desc->p_level][desc->p_type]++,
- _(desc->text), opt->info.bool.deflt,
+ gettext(desc->text), opt->info.bool.deflt,
!(desc->is_mandatory));
if (desc->p_level > MAXIMUM_PARAMETER_LEVEL)
stp_set_boolean_parameter_active(pv->v, desc->name,
@@ -1294,7 +1294,7 @@ static GtkWidget *
create_positioning_button(GtkWidget *box, int invalid,
const char *text, const char *help)
{
- GtkWidget *button = gtk_button_new_with_label(_(text));
+ GtkWidget *button = gtk_button_new_with_label(gettext(text));
gtk_box_pack_start(GTK_BOX(box), button, FALSE, TRUE, 0);
gtk_widget_show(button);
stpui_set_help_data(button, help);
@@ -2326,11 +2326,11 @@ create_units_frame (void)
for (i = 0; i < unit_count; i++)
{
unit_t *unit = &(units[i]);
- unit->checkbox = gtk_radio_button_new_with_label(group, _(unit->name));
+ unit->checkbox = gtk_radio_button_new_with_label(group, gettext(unit->name));
group = gtk_radio_button_group(GTK_RADIO_BUTTON(unit->checkbox));
stpui_table_attach_aligned(GTK_TABLE(table), i / 2, i % 2, NULL, 0.5,
0.5, unit->checkbox, 1, TRUE);
- stpui_set_help_data(unit->checkbox, _(unit->help));
+ stpui_set_help_data(unit->checkbox, gettext(unit->help));
g_signal_connect(G_OBJECT(unit->checkbox), "toggled",
G_CALLBACK(unit_callback), (gpointer) i);
}
diff --git a/src/gutenprintui2/ui-utils.c b/src/gutenprintui2/ui-utils.c
index b4ec44d..9b8cb01 100644
--- a/src/gutenprintui2/ui-utils.c
+++ b/src/gutenprintui2/ui-utils.c
@@ -1,5 +1,5 @@
/*
- * "$Id: ui-utils.c,v 1.2 2005/04/09 14:52:34 rlk Exp $"
+ * "$Id: ui-utils.c,v 1.3 2006/05/28 16:59:04 rlk Exp $"
*
* Main window code for Print plug-in for the GIMP.
*
@@ -765,11 +765,11 @@ stpui_create_radio_button(radio_group_t *radio, GSList *group,
GtkWidget *table, int hpos, int vpos,
GCallback callback)
{
- radio->button = gtk_radio_button_new_with_label(group, _(radio->name));
+ radio->button = gtk_radio_button_new_with_label(group, gettext(radio->name));
group = gtk_radio_button_group(GTK_RADIO_BUTTON(radio->button));
stpui_table_attach_aligned(GTK_TABLE(table), hpos, vpos, NULL, 0.5, 0.5,
radio->button, 1, FALSE);
- stpui_set_help_data(radio->button, _(radio->help));
+ stpui_set_help_data(radio->button, gettext(radio->help));
g_signal_connect(G_OBJECT(radio->button), "toggled",
G_CALLBACK(callback), (gpointer) radio->value);
return group;
@@ -812,9 +812,9 @@ stpui_create_new_combo(option_t *option, GtkWidget *table,
gtk_container_add(GTK_CONTAINER(event_box), combo);
gtk_widget_show(combo);
gtk_widget_show(event_box);
- stpui_set_help_data(event_box, _(option->fast_desc->help));
+ stpui_set_help_data(event_box, gettext(option->fast_desc->help));
stpui_table_attach_aligned
- (GTK_TABLE(table), hpos + 1, vpos, _(option->fast_desc->text),
+ (GTK_TABLE(table), hpos + 1, vpos, gettext(option->fast_desc->text),
0.0, 0.5, event_box, 2, TRUE);
option->info.list.label = table_label(GTK_TABLE(table), hpos, vpos);
}