summaryrefslogtreecommitdiff
path: root/src/xml/escp2/resolutions/Makefile.am
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
committerDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
commite50542121e724e851fc5d6c68bb773f80c0bc12c (patch)
tree655c3f6331a6e8fd8b09ceb4da8f5896484ae16a /src/xml/escp2/resolutions/Makefile.am
parent9dd97a029bf391c42b1dc76f2f7c5e386bb8f466 (diff)
New upstream version 5.3.1
Diffstat (limited to 'src/xml/escp2/resolutions/Makefile.am')
-rw-r--r--src/xml/escp2/resolutions/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/xml/escp2/resolutions/Makefile.am b/src/xml/escp2/resolutions/Makefile.am
new file mode 100644
index 0000000..5094559
--- /dev/null
+++ b/src/xml/escp2/resolutions/Makefile.am
@@ -0,0 +1,52 @@
+## Copyright (C) 2017 Krawitz
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+@SET_MAKE@
+
+include $(top_srcdir)/scripts/global.mk
+
+## Variables
+
+pkgxmldatadir = $(pkgdatadir)/@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@/xml/escp2/resolutions
+
+pkgxmldata_DATA = \
+ c8x.xml \
+ escp2-i.xml \
+ prox600.xml \
+ sc480.xml \
+ sc680.xml \
+ sc740.xml \
+ sc860.xml \
+ sp700.xml \
+ sp720.xml \
+ wf6xx.xml
+
+xml-stamp: $(pkgxmldata_DATA) $(STAMPS) Makefile.am
+ -rm -f $@ $@.tmp
+ touch $@.tmp
+ for dir in $(SUBDIRS) ; do \
+ sed "s;^;$$dir/;" $${dir}/xml-stamp >> $@.tmp ; \
+ done
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> $@.tmp; done
+ mv $@.tmp $@
+
+all-local: xml-stamp
+
+dist-hook: xml-stamp
+CLEANFILES = xmli18n-tmp.h xml-stamp xml-stamp.tmp
+
+EXTRA_DIST = $(pkgxmldata_DATA)