summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2014-04-16 08:13:45 +0200
committerDidier Raboud <odyx@debian.org>2014-04-16 08:13:45 +0200
commit68062125a3214a6262bb1899b81f93abb35c8be9 (patch)
treec2eaee20fb0e6771187aa50f9fa4fb4850564f5b /src
parentd7d42f6c969dc54157d85b7b6b611581bbfa7595 (diff)
Imported Upstream version 5.2.10~pre2
Diffstat (limited to 'src')
-rw-r--r--src/cups/Makefile.am4
-rw-r--r--src/cups/Makefile.in2
-rw-r--r--src/cups/backend_common.h4
-rw-r--r--src/cups/dnpds40_print.c4
-rw-r--r--src/cups/selphy_print.c93
-rw-r--r--src/escputil/escputil.c18
-rw-r--r--src/foomatic/foomatic-generator.in7
-rw-r--r--src/main/print-olympus.c77
-rw-r--r--src/xml/escp2/model/model_118.xml2
-rw-r--r--src/xml/printers.xml16
10 files changed, 119 insertions, 108 deletions
diff --git a/src/cups/Makefile.am b/src/cups/Makefile.am
index 75691af..939f1a8 100644
--- a/src/cups/Makefile.am
+++ b/src/cups/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.145 2014/02/12 13:42:27 rlk Exp $
+## $Id: Makefile.am,v 1.146 2014/02/19 12:26:43 speachy Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -160,7 +160,7 @@ if BUILD_LIBUSB_BACKENDS
INSTALL_BLACKLIST=install-blacklist
install-blacklist:
$(mkdir_p) $(DESTDIR)$(cupsdata_blacklistdir)
- $(INSTALL_DATA) blacklist $(DESTDIR)$(cupsdata_blacklistdir)/net.sf.gimp-print.usb-quirks
+ $(INSTALL_DATA) $(srcdir)/blacklist $(DESTDIR)$(cupsdata_blacklistdir)/net.sf.gimp-print.usb-quirks
endif
install-data-local: $(INSTALL_DATA_LOCAL_DEPS) $(INSTALL_BLACKLIST)
diff --git a/src/cups/Makefile.in b/src/cups/Makefile.in
index 991e2cd..8af0f4a 100644
--- a/src/cups/Makefile.in
+++ b/src/cups/Makefile.in
@@ -1811,7 +1811,7 @@ $(top_builddir)/src/gutenprintui2/libgutenprintui2.la:
@BUILD_CUPS_TRUE@@BUILD_LIBUSB_BACKENDS_TRUE@ chmod 700 "$(DESTDIR)$(pkglibdir)/backend/gutenprint$(GUTENPRINT_MAJOR_VERSION)$(GUTENPRINT_MINOR_VERSION)+usb"
@BUILD_LIBUSB_BACKENDS_TRUE@install-blacklist:
@BUILD_LIBUSB_BACKENDS_TRUE@ $(mkdir_p) $(DESTDIR)$(cupsdata_blacklistdir)
-@BUILD_LIBUSB_BACKENDS_TRUE@ $(INSTALL_DATA) blacklist $(DESTDIR)$(cupsdata_blacklistdir)/net.sf.gimp-print.usb-quirks
+@BUILD_LIBUSB_BACKENDS_TRUE@ $(INSTALL_DATA) $(srcdir)/blacklist $(DESTDIR)$(cupsdata_blacklistdir)/net.sf.gimp-print.usb-quirks
install-data-local: $(INSTALL_DATA_LOCAL_DEPS) $(INSTALL_BLACKLIST)
if test -n "$(CUPS_PKG)" -a -n "$(INSTALL_DATA_LOCAL_DEPS)" ; then \
diff --git a/src/cups/backend_common.h b/src/cups/backend_common.h
index 286dedd..99f8297 100644
--- a/src/cups/backend_common.h
+++ b/src/cups/backend_common.h
@@ -35,7 +35,7 @@
#include <fcntl.h>
#include <signal.h>
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <arpa/inet.h>
#ifndef __BACKEND_COMMON_H
@@ -68,7 +68,7 @@
uint16_t __x = (x); \
((uint16_t)( \
(((uint16_t)(__x) & (uint16_t)0x00ff) << 8) | \
- (((uint16_t)(__x) & (uint16_t)0xff00) >> 8) | \
+ (((uint16_t)(__x) & (uint16_t)0xff00) >> 8))); \
})
#define be32_to_cpu(__x) __x
#define be16_to_cpu(__x) __x
diff --git a/src/cups/dnpds40_print.c b/src/cups/dnpds40_print.c
index c3cc689..f79df53 100644
--- a/src/cups/dnpds40_print.c
+++ b/src/cups/dnpds40_print.c
@@ -397,12 +397,10 @@ static int dnpds40_read_parse(void *vctx, int data_fd) {
if(!memcmp("CNTRL OVERCOAT", ctx->databuf + ctx->datalen+2, 14)) {
memcpy(buf, ctx->databuf + ctx->datalen + 32, 8);
matte = atoi(buf);
- matte = le32_to_cpu(matte);
}
if(!memcmp("CNTRL MULTICUT", ctx->databuf + ctx->datalen+2, 14)) {
memcpy(buf, ctx->databuf + ctx->datalen + 32, 8);
multicut = atoi(buf);
- multicut = le32_to_cpu(multicut);
}
if(!memcmp("IMAGE YPLANE", ctx->databuf + ctx->datalen + 2, 12)) {
uint32_t x_ppm;
@@ -993,7 +991,7 @@ static int dnpds40_cmdline_arg(void *vctx, int argc, char **argv)
/* Exported */
struct dyesub_backend dnpds40_backend = {
.name = "DNP DS40/DS80/DSRX1",
- .version = "0.29",
+ .version = "0.30",
.uri_prefix = "dnpds40",
.cmdline_usage = dnpds40_cmdline,
.cmdline_arg = dnpds40_cmdline_arg,
diff --git a/src/cups/selphy_print.c b/src/cups/selphy_print.c
index 29284a0..a15c572 100644
--- a/src/cups/selphy_print.c
+++ b/src/cups/selphy_print.c
@@ -37,6 +37,41 @@
#include "backend_common.h"
+/* Exported */
+#define USB_VID_CANON 0x04a9
+#define USB_PID_CANON_CP10 0x304A
+#define USB_PID_CANON_CP100 0x3063
+#define USB_PID_CANON_CP200 0x307C
+#define USB_PID_CANON_CP220 0x30BD
+#define USB_PID_CANON_CP300 0x307D
+#define USB_PID_CANON_CP330 0x30BE
+#define USB_PID_CANON_CP400 0x30F6
+#define USB_PID_CANON_CP500 0x30F5
+#define USB_PID_CANON_CP510 0x3128
+#define USB_PID_CANON_CP520 520 // XXX 316f? 3172? (related to cp740/cp750)
+#define USB_PID_CANON_CP530 0x31b1
+#define USB_PID_CANON_CP600 0x310B
+#define USB_PID_CANON_CP710 0x3127
+#define USB_PID_CANON_CP720 0x3143
+#define USB_PID_CANON_CP730 0x3142
+#define USB_PID_CANON_CP740 0x3171
+#define USB_PID_CANON_CP750 0x3170
+#define USB_PID_CANON_CP760 0x31AB
+#define USB_PID_CANON_CP770 0x31AA
+#define USB_PID_CANON_CP780 0x31DD
+#define USB_PID_CANON_CP790 0x31E7
+#define USB_PID_CANON_CP800 0x3214
+#define USB_PID_CANON_CP810 0x3256
+#define USB_PID_CANON_CP820 820 // XXX
+#define USB_PID_CANON_CP900 0x3255
+#define USB_PID_CANON_CP910 910 // XXX
+#define USB_PID_CANON_ES1 0x3141
+#define USB_PID_CANON_ES2 0x3185
+#define USB_PID_CANON_ES20 0x3186
+#define USB_PID_CANON_ES3 0x31AF
+#define USB_PID_CANON_ES30 0x31B0
+#define USB_PID_CANON_ES40 0x31EE
+
#define READBACK_LEN 12
struct printer_data {
@@ -222,8 +257,8 @@ static struct printer_data selphy_printers[] = {
.ready_m_readback = { 0x04, 0x00, 0x03, 0x00, 0x02, 0x01, -1, 0x01, 0x00, 0x00, 0x00, 0x00 },
.ready_c_readback = { 0x04, 0x00, 0x07, 0x00, 0x02, 0x01, -1, 0x01, 0x00, 0x00, 0x00, 0x00 },
.done_c_readback = { 0x04, 0x00, 0x00, 0x00, 0x02, 0x01, -1, 0x01, 0x00, 0x00, 0x00, 0x00 },
- // .clear_error + clear_error_len
- // .paper_codes
+ .clear_error = { 0x40, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 },
+ .clear_error_len = 12,
.pgcode_offset = 3,
.paper_code_offset = 6,
.error_detect = es1_error_detect,
@@ -237,8 +272,8 @@ static struct printer_data selphy_printers[] = {
.ready_m_readback = { 0x06, 0x00, 0x03, 0x00, -1, 0x00, -1, -1, 0x00, 0x00, 0x00, 0x00 },
.ready_c_readback = { 0x09, 0x00, 0x07, 0x00, -1, 0x00, -1, -1, 0x00, 0x00, 0x00, 0x00 },
.done_c_readback = { 0x09, 0x00, 0x00, 0x00, -1, 0x00, -1, -1, 0x00, 0x00, 0x00, 0x00 },
- // .clear_error + clear_error_len
- // .paper_codes
+ .clear_error = { 0x40, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 },
+ .clear_error_len = 12,
.pgcode_offset = 2,
.paper_code_offset = 4,
.error_detect = es2_error_detect,
@@ -252,8 +287,8 @@ static struct printer_data selphy_printers[] = {
.ready_m_readback = { 0x03, 0xff, 0x02, 0x00, 0xff, 0xff, 0xff, 0xff, 0x00, 0x00, 0x00, 0x00 },
.ready_c_readback = { 0x05, 0xff, 0x03, 0x00, 0xff, 0xff, 0xff, 0xff, 0x00, 0x00, 0x00, 0x00 },
.done_c_readback = { 0x00, 0xff, 0x10, 0x00, 0xff, 0xff, 0xff, 0xff, 0x00, 0x00, 0x00, 0x00 },
- // .clear_error + clear_error_len
- // .paper_codes
+ .clear_error = { 0x40, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 },
+ .clear_error_len = 12,
.pgcode_offset = 2,
.paper_code_offset = -1,
.error_detect = es3_error_detect,
@@ -274,8 +309,8 @@ static struct printer_data selphy_printers[] = {
.ready_m_readback = { 0x00, 0x03, 0x02, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, -1 },
.ready_c_readback = { 0x00, 0x05, 0x03, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, -1 },
.done_c_readback = { 0x00, 0x00, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, -1 },
- // .clear_error + clear_error_len
- // .paper_codes
+ .clear_error = { 0x40, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 },
+ .clear_error_len = 12,
.pgcode_offset = 2,
.paper_code_offset = 11,
.error_detect = es40_error_detect,
@@ -523,9 +558,6 @@ static void canonselphy_attach(void *vctx, struct libusb_device_handle *dev,
device = libusb_get_device(dev);
libusb_get_device_descriptor(device, &desc);
-
-#define USB_PID_CANON_CP790 0x31E7
-#define USB_PID_CANON_ES40 0x31EE
if (desc.idProduct == USB_PID_CANON_CP790)
printer_type = P_CP790;
@@ -892,44 +924,9 @@ top:
return 0;
}
-/* Exported */
-#define USB_VID_CANON 0x04a9
-#define USB_PID_CANON_CP10 0x304A
-#define USB_PID_CANON_CP100 0x3063
-#define USB_PID_CANON_CP200 0x307C
-#define USB_PID_CANON_CP220 0x30BD
-#define USB_PID_CANON_CP300 0x307D
-#define USB_PID_CANON_CP330 0x30BE
-#define USB_PID_CANON_CP400 0x30F6
-#define USB_PID_CANON_CP500 0x30F5
-#define USB_PID_CANON_CP510 0x3128
-#define USB_PID_CANON_CP520 520 // XXX 316f? 3172? (related to cp740/cp750)
-#define USB_PID_CANON_CP530 0x31b1
-#define USB_PID_CANON_CP600 0x310B
-#define USB_PID_CANON_CP710 0x3127
-#define USB_PID_CANON_CP720 0x3143
-#define USB_PID_CANON_CP730 0x3142
-#define USB_PID_CANON_CP740 0x3171
-#define USB_PID_CANON_CP750 0x3170
-#define USB_PID_CANON_CP760 0x31AB
-#define USB_PID_CANON_CP770 0x31AA
-#define USB_PID_CANON_CP780 0x31DD
-#define USB_PID_CANON_CP790 0x31E7
-#define USB_PID_CANON_CP800 0x3214
-#define USB_PID_CANON_CP810 0x3256
-#define USB_PID_CANON_CP820 820 // XXX
-#define USB_PID_CANON_CP900 0x3255
-#define USB_PID_CANON_CP910 910 // XXX
-#define USB_PID_CANON_ES1 0x3141
-#define USB_PID_CANON_ES2 0x3185
-#define USB_PID_CANON_ES20 0x3186
-#define USB_PID_CANON_ES3 0x31AF
-#define USB_PID_CANON_ES30 0x31B0
-#define USB_PID_CANON_ES40 0x31EE
-
struct dyesub_backend canonselphy_backend = {
.name = "Canon SELPHY CP/ES",
- .version = "0.80",
+ .version = "0.81",
.uri_prefix = "canonselphy",
.init = canonselphy_init,
.attach = canonselphy_attach,
@@ -1283,6 +1280,6 @@ struct dyesub_backend canonselphy_backend = {
necessarily identical. So it's possible to have a code of, say,
0x41 if the 'Wide' paper tray is loaded with a 'P' ribbon. A '0' is used
to signify nothing being loaded.
-
+
*/
diff --git a/src/escputil/escputil.c b/src/escputil/escputil.c
index ad50c0a..d7fec55 100644
--- a/src/escputil/escputil.c
+++ b/src/escputil/escputil.c
@@ -1,5 +1,5 @@
/*
- * "$Id: escputil.c,v 1.109 2014/01/04 00:25:38 rlk Exp $"
+ * "$Id: escputil.c,v 1.110 2014/02/21 01:56:24 rlk Exp $"
*
* Printer maintenance utility for EPSON Stylus (R) printers
*
@@ -1619,23 +1619,23 @@ get_ink_channel_list(const stp_printer_t *printer, int fd)
{
STP_DEBUG(printf("*** Case 0: Ink %d %d (%s)\n",
i, ind[i], colors_new[(int) ind[i]]));
- stp_string_list_add_string(color_list,
- colors_new[(int) ind[i]],
- colors_new[(int) ind[i]]);
+ stp_string_list_add_string_unsafe(color_list,
+ colors_new[(int) ind[i]],
+ colors_new[(int) ind[i]]);
}
else if (ind[i] == 0x40 && ind[i + 1] < aux_color_count)
{
STP_DEBUG(printf("*** Case 1: Ink %d %d (%s)\n",
i, ind[i+1], aux_colors[(int) ind[i+1]]));
- stp_string_list_add_string(color_list,
- aux_colors[(int) ind[i + 1]],
- aux_colors[(int) ind[i + 1]]);
+ stp_string_list_add_string_unsafe(color_list,
+ aux_colors[(int) ind[i + 1]],
+ aux_colors[(int) ind[i + 1]]);
}
else
{
STP_DEBUG(printf("*** Case 2: Unknown\n"));
- stp_string_list_add_string(color_list, "Unknown",
- "Unknown");
+ stp_string_list_add_string_unsafe(color_list, "Unknown",
+ "Unknown");
}
i+=3;
}
diff --git a/src/foomatic/foomatic-generator.in b/src/foomatic/foomatic-generator.in
index 51630bd..5b8d96b 100644
--- a/src/foomatic/foomatic-generator.in
+++ b/src/foomatic/foomatic-generator.in
@@ -1334,9 +1334,6 @@ sub qualityorder {
"dpi_photomonodraft2",
"dpi_ohphigh",
"dpi_ohp",
- # Dyesub
- "x600",
- "x300"
);
my ($a, $b) = @_;
# Bring the suffixes to lower case
@@ -1417,11 +1414,11 @@ sub getprintoutmode {
for $quality (keys(%{$stpdata{$stpprn}{'STP_Resolution'}})) {
my ($xres, $yres, $qualstr);
- if ($quality =~ /^(\d+)x(\d+)(\D.*)$/) {
+ if ($quality =~ /^(\d+)x(\d+)(\D.*)?$/) {
$xres = $1;
$yres = $2;
$qualstr = $3;
- } elsif ($quality =~ /^(\d+)(\D.*)$/) {
+ } elsif ($quality =~ /^(\d+)(\D.*)?$/) {
$xres = $1;
$yres = $1;
$qualstr = $2;
diff --git a/src/main/print-olympus.c b/src/main/print-olympus.c
index a51d7df..7854f51 100644
--- a/src/main/print-olympus.c
+++ b/src/main/print-olympus.c
@@ -1,5 +1,5 @@
/*
- * "$Id: print-olympus.c,v 1.152 2014/02/01 01:04:21 speachy Exp $"
+ * "$Id: print-olympus.c,v 1.157 2014/03/07 14:03:36 speachy Exp $"
*
* Print plug-in DyeSub driver (formerly Olympus driver) for the GIMP.
*
@@ -1395,7 +1395,7 @@ LIST(dyesub_printsize_list_t, cx400_printsize_list, dyesub_printsize_t, cx400_pr
static void cx400_printer_init_func(stp_vars_t *v)
{
char pg = '\0';
- const char *pname = "XXXXXX";
+ const char *pname = "XXXXXX";
stp_deprintf(STP_DBG_DYESUB,
"dyesub: fuji driver %s\n", stp_get_driver(v));
@@ -2834,10 +2834,10 @@ LIST(dyesub_resolution_list_t, res_dnpds40_dpi_list, dyesub_resolution_t, res_dn
printer with the full imaging width. */
static const dyesub_pagesize_t dnpds40_dock_page[] =
{
- { "B7", "3.5x5", PT(1920,300)+1, PT(1088,300)+1, PT(112,300), PT(112,300), 0, 0, DYESUB_PORTRAIT},
- { "w288h432", "4x6", PT(1920,300)+1, PT(1240,300)+1, PT(38,300), PT(38,300), 0, 0, DYESUB_PORTRAIT},
+ { "B7", "3.5x5", PT(1088,300)+1, PT(1920,300)+1, 0, 0, PT(112,300), PT(112,300), DYESUB_LANDSCAPE},
+ { "w288h432", "4x6", PT(1240,300)+1, PT(1920,300)+1, 0, 0, PT(38,300), PT(38,300), DYESUB_LANDSCAPE},
#ifdef DNPX2
- { "2x6_x2", "2x6*2", PT(1920,300)+1, PT(1240,300)+1, PT(38,300), PT(38,300), 0, 0, DYESUB_PORTRAIT},
+ { "2x6_x2", "2x6*2", PT(1240,300)+1, PT(1920,300)+1, 0, 0, PT(38,300), PT(38,300), DYESUB_LANDSCAPE},
#endif
{ "w360h504", "5x7", PT(1920,300)+1, PT(2138,300)+1, PT(112,300), PT(112,300), 0, 0, DYESUB_PORTRAIT},
{ "A5", "6x8", PT(1920,300)+1, PT(2436,300)+1, PT(38,300), PT(38,300), 0, 0, DYESUB_PORTRAIT},
@@ -2851,13 +2851,13 @@ LIST(dyesub_pagesize_list_t, dnpds40_dock_page_list, dyesub_pagesize_t, dnpds40_
static const dyesub_printsize_t dnpds40_dock_printsize[] =
{
- { "300x300", "B7", 1920, 1088},
- { "300x600", "B7", 1920, 2176},
- { "300x300", "w288h432", 1920, 1240},
- { "300x600", "w288h432", 1920, 2480},
+ { "300x300", "B7", 1088, 1920},
+ { "300x600", "B7", 2176, 1920},
+ { "300x300", "w288h432", 1240, 1920},
+ { "300x600", "w288h432", 2480, 1920},
#ifdef DNPX2
- { "300x300", "2x6_x2", 1920, 1240},
- { "300x600", "2x6_x2", 1920, 2480},
+ { "300x300", "2x6_x2", 1240, 1920},
+ { "300x600", "2x6_x2", 2480, 1920},
#endif
{ "300x300", "w360h504", 1920, 2138},
{ "300x600", "w360h504", 1920, 4276},
@@ -2981,12 +2981,12 @@ static void dnpds40_plane_init(stp_vars_t *v)
printer with the full imaging width. */
static const dyesub_pagesize_t dnpds80_dock_page[] =
{
- { "w288h576", "8x4", PT(2560,300)+1, PT(1236,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
- { "w360h576", "8x5", PT(2560,300)+1, PT(1536,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
- { "w432h576", "8x6", PT(2560,300)+1, PT(1836,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
- { "w576h576", "8x8", PT(2560,300)+1, PT(2436,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
+ { "w288h576", "8x4", PT(1236,300)+1, PT(2560,300)+1, 0, 0, PT(56,300), PT(56,300), DYESUB_LANDSCAPE},
+ { "w360h576", "8x5", PT(1536,300)+1, PT(2560,300)+1, 0, 0, PT(56,300), PT(56,300), DYESUB_LANDSCAPE},
+ { "w432h576", "8x6", PT(1836,300)+1, PT(2560,300)+1, 0, 0, PT(56,300), PT(56,300), DYESUB_LANDSCAPE},
+ { "w576h576", "8x8", PT(2436,300)+1, PT(2560,300)+1, 0, 0, PT(56,300), PT(56,300), DYESUB_LANDSCAPE},
#ifdef DNPX2
- { "8x4_x2", "8x4*2", PT(2560,300)+1, PT(2502,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
+ { "8x4_x2", "8x4*2", PT(2502,300)+1, PT(2560,300)+1, 0, 0, PT(56,300), PT(56,300), DYESUB_LANDSCAPE},
{ "8x5_8x4", "8x5+8x4", PT(2560,300)+1, PT(2802,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
#endif
{ "c8x10", "8x10", PT(2560,300)+1, PT(3036,300)+1, PT(56,300), PT(56,300), 0, 0, DYESUB_PORTRAIT},
@@ -3008,17 +3008,17 @@ LIST(dyesub_pagesize_list_t, dnpds80_dock_page_list, dyesub_pagesize_t, dnpds80_
static const dyesub_printsize_t dnpds80_dock_printsize[] =
{
- { "300x300", "w288h576", 2560, 1236},
- { "300x600", "w288h576", 2560, 2472},
- { "300x300", "w360h576", 2560, 1536},
- { "300x600", "w360h576", 2560, 3072},
- { "300x300", "w432h576", 2560, 1836},
- { "300x600", "w432h576", 2560, 3672},
- { "300x300", "w576h576", 2560, 2436},
- { "300x600", "w576h576", 2560, 4872},
+ { "300x300", "w288h576", 1236, 2560},
+ { "300x600", "w288h576", 2472, 2560},
+ { "300x300", "w360h576", 1536, 2560},
+ { "300x600", "w360h576", 3072, 2560},
+ { "300x300", "w432h576", 1836, 2560},
+ { "300x600", "w432h576", 3672, 2560},
+ { "300x300", "w576h576", 2436, 2560},
+ { "300x600", "w576h576", 4872, 2560},
#ifdef DNPX2
- { "300x300", "8x4_x2", 2560, 2502},
- { "300x600", "8x4_x2", 2560, 5004},
+ { "300x300", "8x4_x2", 2502, 2560},
+ { "300x600", "8x4_x2", 5004, 2560},
{ "300x300", "8x5_8x4", 2560, 2802},
{ "300x600", "8x5_8x4", 2560, 5604},
#endif
@@ -3537,7 +3537,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
NULL, NULL,
},
{ /* Kodak Easyshare Dock family */
- 4000,
+ 4000,
&ymc_ink_list,
&res_300dpi_list,
&kodak_dock_page_list,
@@ -3552,7 +3552,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
NULL, NULL,
},
{ /* Kodak Photo Printer 6800 */
- 4001,
+ 4001,
&rgb_ink_list,
&res_300dpi_list,
&kodak_6800_page_list,
@@ -3566,7 +3566,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
&kodak_6800_laminate_list, NULL,
},
{ /* Kodak Photo Printer 6850 */
- 4002,
+ 4002,
&rgb_ink_list,
&res_300dpi_list,
&kodak_6850_page_list,
@@ -3580,7 +3580,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
&kodak_6800_laminate_list, NULL,
},
{ /* Kodak Photo Printer 605 */
- 4003,
+ 4003,
&rgb_ink_list,
&res_300dpi_list,
&kodak_6800_page_list,
@@ -3594,7 +3594,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
&kodak_605_laminate_list, NULL,
},
{ /* Kodak Professional 1400 */
- 4004,
+ 4004,
&bgr_ink_list,
&res_301dpi_list,
&kodak_1400_page_list,
@@ -3611,7 +3611,7 @@ static const dyesub_cap_t dyesub_model_capabilities[] =
&kodak_1400_media_list,
},
{ /* Kodak Photo Printer 805 */
- 4005,
+ 4005,
&bgr_ink_list,
&res_301dpi_list,
&kodak_805_page_list,
@@ -4259,7 +4259,18 @@ dyesub_maximum_imageable_area(const stp_vars_t *v,
int *top)
{
int not_used;
- dyesub_imageable_area_internal(v, 1, left, right, bottom, top, &not_used);
+ const int model = stp_get_model_id(v);
+ const dyesub_cap_t *caps = dyesub_get_model_capabilities(model);
+
+ /* For printers that report FEATURE_WHITE_BORDER, we need to
+ respect the margins they define as that's the printable area.
+ The SELPHY models support FEATURE_BORDERLESS as well, so handle
+ that special case. */
+
+ dyesub_imageable_area_internal(v,
+ (!(dyesub_feature(caps, DYESUB_FEATURE_WHITE_BORDER) &&
+ !dyesub_feature(caps, DYESUB_FEATURE_BORDERLESS))),
+ left, right, bottom, top, &not_used);
}
static void
diff --git a/src/xml/escp2/model/model_118.xml b/src/xml/escp2/model/model_118.xml
index 1f3d5de..2d00f80 100644
--- a/src/xml/escp2/model/model_118.xml
+++ b/src/xml/escp2/model/model_118.xml
@@ -75,7 +75,7 @@ xsi:schemaLocation="http://gimp-print.sourceforge.net/xsd/gp.xsd-1.0 gutenprint.
<margins interleave="printer" media="sheet">9 9 0 9</margins>
<margins interleave="soft" media="roll">9 9 0 0</margins>
<margins interleave="printer" media="roll">9 9 0 0</margins>
- <margins duplex="duplex">-32768 -32768 9 9</margins>
+ <margins duplex="duplex">-32768 -32768 0 0</margins>
<AlignmentChoices>4 15 0 0</AlignmentChoices>
<ChannelNames>
<ChannelName translate="text" name="Black" text="Black"/>
diff --git a/src/xml/printers.xml b/src/xml/printers.xml
index 84f0ce9..3e3c91f 100644
--- a/src/xml/printers.xml
+++ b/src/xml/printers.xml
@@ -1,7 +1,7 @@
<?xml version="1.0"?>
<!--
- "$Id: printers.xml,v 1.354 2014/02/13 04:36:16 speachy Exp $"
+ "$Id: printers.xml,v 1.355 2014/02/16 15:05:50 rlk Exp $"
XML description of printers known to libgutenprint
You can add additional printers here, but the underlying driver has
@@ -1335,7 +1335,9 @@
<printer translate="name" name="Epson Stylus NX420" driver="escp2-nx420" manufacturer="Epson" model="94" parameters="standard_params" foomaticid="Epson-Stylus_NX420" />
<printer translate="name" name="Epson Stylus NX515" driver="escp2-nx515" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_NX515" />
<printer translate="name" name="Epson Stylus NX530" driver="escp2-nx530" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_NX530" />
- <printer translate="name" name="Epson Stylus NX635" driver="escp2-nx635" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_NX635" />
+ <printer translate="name" name="Epson Stylus NX630" driver="escp2-nx630" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_NX630" />
+ <printer translate="name" name="Epson Stylus NX635" driver="escp2-nx635" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_NX635" />
+ <printer translate="name" name="Epson Stylus NX645" driver="escp2-nx645" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_NX645" />
<printer translate="name" name="Epson Stylus Photo PX650" driver="escp2-px650" manufacturer="Epson" model="97" parameters="standard_params" foomaticid="Epson-Stylus_Photo_PX650" />
<printer translate="name" name="Epson Stylus Photo PX700W" driver="escp2-px700fw" manufacturer="Epson" model="96" parameters="claria_params" foomaticid="Epson-Stylus_Photo_PX700W" />
<printer translate="name" name="Epson Stylus Photo PX710W" driver="escp2-px710fw" manufacturer="Epson" model="96" parameters="claria_params" foomaticid="Epson-Stylus_Photo_PX710W" />
@@ -1365,6 +1367,9 @@
<printer translate="name" name="Epson Stylus SX600FW" driver="escp2-sx600fw" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_SX600FW" />
<printer translate="name" name="Epson Stylus SX610FW" driver="escp2-sx610fw" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_SX610FW" />
<printer translate="name" name="Epson Stylus SX615" driver="escp2-sx615" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_SX615" />
+ <printer translate="name" name="Epson Stylus SX630" driver="escp2-sx630" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_SX630" />
+ <printer translate="name" name="Epson Stylus SX635" driver="escp2-sx635" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_SX635" />
+ <printer translate="name" name="Epson Stylus SX645" driver="escp2-sx645" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_SX645" />
<printer translate="name" name="Epson Stylus SX650" driver="escp2-sx650" manufacturer="Epson" model="97" parameters="standard_params" foomaticid="Epson-Stylus_SX650" />
<printer translate="name" name="Epson Stylus T13" driver="escp2-t13" manufacturer="Epson" model="101" parameters="standard_params" foomaticid="Epson-Stylus_T13" />
<printer translate="name" name="Epson Stylus T20" driver="escp2-t20" manufacturer="Epson" model="101" parameters="standard_params" foomaticid="Epson-Stylus_T20" />
@@ -1398,6 +1403,9 @@
<printer translate="name" name="Epson Stylus TX550W" driver="escp2-tx550w" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_TX550W" />
<printer translate="name" name="Epson Stylus TX610FW" driver="escp2-tx610fw" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_TX610FW" />
<printer translate="name" name="Epson Stylus TX615" driver="escp2-tx615" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-Stylus_TX615" />
+ <printer translate="name" name="Epson Stylus TX630" driver="escp2-tx630" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_TX630" />
+ <printer translate="name" name="Epson Stylus TX635" driver="escp2-tx635" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_TX635" />
+ <printer translate="name" name="Epson Stylus TX645" driver="escp2-tx645" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-Stylus_TX645" />
<printer translate="name" name="Epson Stylus TX650" driver="escp2-tx650" manufacturer="Epson" model="97" parameters="standard_params" foomaticid="Epson-Stylus_TX650" />
<printer translate="name" name="Epson Stylus TX659" driver="escp2-tx659" manufacturer="Epson" model="97" parameters="standard_params" foomaticid="Epson-Stylus_TX659" />
<printer translate="name" name="Epson PictureMate" driver="escp2-picmate" manufacturer="Epson" model="73" parameters="standard_params" foomaticid="Epson-PictureMate" />
@@ -1427,8 +1435,8 @@
<printer translate="name" name="Epson WorkForce 600" driver="escp2-wf600" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-WorkForce_600" />
<printer translate="name" name="Epson WorkForce 610" driver="escp2-wf610" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-WorkForce_610" />
<printer translate="name" name="Epson WorkForce 615" driver="escp2-wf615" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-WorkForce_615" />
- <printer translate="name" name="Epson WorkForce 630" driver="escp2-wf630" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-WorkForce_630" />
- <printer translate="name" name="Epson WorkForce 635" driver="escp2-wf636" manufacturer="Epson" model="92" parameters="standard_params" foomaticid="Epson-WorkForce_635" />
+ <printer translate="name" name="Epson WorkForce 630" driver="escp2-wf630" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-WorkForce_630" />
+ <printer translate="name" name="Epson WorkForce 635" driver="escp2-wf636" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-WorkForce_635" />
<printer translate="name" name="Epson WorkForce 645" driver="escp2-wf645" manufacturer="Epson" model="118" parameters="standard_params" foomaticid="Epson-WorkForce_645" />
<printer translate="name" name="Epson WorkForce 1100" driver="escp2-wf1100" manufacturer="Epson" model="99" parameters="standard_params" foomaticid="Epson-WorkForce_1100" />
<printer translate="name" name="Epson WF-7010 Series" driver="escp2-wf7010" manufacturer="Epson" model="119" parameters="standard_params" foomaticid="Epson-WorkForce_WF-7010" />