summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2012-07-09 23:15:00 +0100
committerRoger Leigh <rleigh@debian.org>2012-07-09 23:15:00 +0100
commitccd50c2bd4db57503722816aa23a5092cbe69f40 (patch)
tree7b2fffb9ec06a2f0fcf3b25dba66cc04409db70e /src
parent3514df18b289ec827cb6e4c446419feab1813231 (diff)
Imported Upstream version 5.2.9
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.in1
-rw-r--r--src/cups/Makefile.in1
-rw-r--r--src/escputil/Makefile.in1
-rw-r--r--src/foomatic/Makefile.in1
-rw-r--r--src/ghost/Makefile.in1
-rw-r--r--src/gimp2/Makefile.am6
-rw-r--r--src/gimp2/Makefile.in8
-rw-r--r--src/gutenprintui2/Makefile.in1
-rw-r--r--src/main/Makefile.in1
-rw-r--r--src/main/canon-media-mode.h3
-rw-r--r--src/main/canon-media.h13
-rw-r--r--src/main/print-escp2.c6
-rw-r--r--src/testpattern/Makefile.am4
-rw-r--r--src/testpattern/Makefile.in6
-rw-r--r--src/xml/Makefile.in1
-rw-r--r--src/xml/escp2/Makefile.in1
-rw-r--r--src/xml/escp2/inks/Makefile.in1
-rw-r--r--src/xml/escp2/inputslots/Makefile.in1
-rw-r--r--src/xml/escp2/media/Makefile.in1
-rw-r--r--src/xml/escp2/mediasizes/Makefile.in1
-rw-r--r--src/xml/escp2/model/Makefile.in1
-rw-r--r--src/xml/escp2/qualitypresets/Makefile.in1
-rw-r--r--src/xml/escp2/weaves/Makefile.in1
23 files changed, 40 insertions, 22 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 30dc171..9c0d149 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -191,6 +191,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/cups/Makefile.in b/src/cups/Makefile.in
index 8f5418c..8f8309d 100644
--- a/src/cups/Makefile.in
+++ b/src/cups/Makefile.in
@@ -262,6 +262,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/escputil/Makefile.in b/src/escputil/Makefile.in
index eeb6b13..d738e30 100644
--- a/src/escputil/Makefile.in
+++ b/src/escputil/Makefile.in
@@ -174,6 +174,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/foomatic/Makefile.in b/src/foomatic/Makefile.in
index 74f9922..d8b1a44 100644
--- a/src/foomatic/Makefile.in
+++ b/src/foomatic/Makefile.in
@@ -193,6 +193,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/ghost/Makefile.in b/src/ghost/Makefile.in
index 38c9823..1c9259f 100644
--- a/src/ghost/Makefile.in
+++ b/src/ghost/Makefile.in
@@ -184,6 +184,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/gimp2/Makefile.am b/src/gimp2/Makefile.am
index 489e6aa..1b4b408 100644
--- a/src/gimp2/Makefile.am
+++ b/src/gimp2/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.7 2006/07/04 02:57:58 rlk Exp $
+## $Id: Makefile.am,v 1.8 2012/06/25 22:22:04 rlk Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -46,8 +46,8 @@ COMMON_PRINT_SOURCES = \
print_SOURCES = $(COMMON_PRINT_SOURCES) print-print.c
-print_LDADD = $(GIMP2_LIBS) $(GUTENPRINTUI2_LIBS)
-print_DEPENDENCIES = $(GUTENPRINTUI2_LIBS) $(GUTENPRINT_LIBS)
+print_LDADD = $(GIMP2_LIBS) $(GUTENPRINT_LIBS) $(GUTENPRINTUI2_LIBS)
+print_DEPENDENCIES = $(GUTENPRINT_LIBS) $(GUTENPRINTUI2_LIBS)
gutenprint_SOURCES = $(COMMON_PRINT_SOURCES) print-gutenprint.c
gutenprint_LDADD = $(print_LDADD)
diff --git a/src/gimp2/Makefile.in b/src/gimp2/Makefile.in
index 9228e74..5977aae 100644
--- a/src/gimp2/Makefile.in
+++ b/src/gimp2/Makefile.in
@@ -68,7 +68,8 @@ am__objects_1 = print-image-gimp.$(OBJEXT) print.$(OBJEXT)
am_gutenprint_OBJECTS = $(am__objects_1) print-gutenprint.$(OBJEXT)
gutenprint_OBJECTS = $(am_gutenprint_OBJECTS)
am__DEPENDENCIES_1 =
-am__DEPENDENCIES_2 = $(am__DEPENDENCIES_1) $(GUTENPRINTUI2_LIBS)
+am__DEPENDENCIES_2 = $(am__DEPENDENCIES_1) $(GUTENPRINT_LIBS) \
+ $(GUTENPRINTUI2_LIBS)
am_print_OBJECTS = $(am__objects_1) print-print.$(OBJEXT)
print_OBJECTS = $(am_print_OBJECTS)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
@@ -178,6 +179,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
@@ -310,8 +312,8 @@ COMMON_PRINT_SOURCES = \
print_gimp.h
print_SOURCES = $(COMMON_PRINT_SOURCES) print-print.c
-print_LDADD = $(GIMP2_LIBS) $(GUTENPRINTUI2_LIBS)
-print_DEPENDENCIES = $(GUTENPRINTUI2_LIBS) $(GUTENPRINT_LIBS)
+print_LDADD = $(GIMP2_LIBS) $(GUTENPRINT_LIBS) $(GUTENPRINTUI2_LIBS)
+print_DEPENDENCIES = $(GUTENPRINT_LIBS) $(GUTENPRINTUI2_LIBS)
gutenprint_SOURCES = $(COMMON_PRINT_SOURCES) print-gutenprint.c
gutenprint_LDADD = $(print_LDADD)
gutenprint_DEPENDENCIES = $(print_DEPENDENCIES)
diff --git a/src/gutenprintui2/Makefile.in b/src/gutenprintui2/Makefile.in
index e5fb61f..d3f662f 100644
--- a/src/gutenprintui2/Makefile.in
+++ b/src/gutenprintui2/Makefile.in
@@ -218,6 +218,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/main/Makefile.in b/src/main/Makefile.in
index 9b05bf3..6dfeb32 100644
--- a/src/main/Makefile.in
+++ b/src/main/Makefile.in
@@ -307,6 +307,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/main/canon-media-mode.h b/src/main/canon-media-mode.h
index 3052f8e..7025510 100644
--- a/src/main/canon-media-mode.h
+++ b/src/main/canon-media-mode.h
@@ -10112,8 +10112,7 @@ DECLARE_MODEUSES(canon_PIXMA_MG8200);
/* ----------------------------------- Canon Pro9000 ----------------------------------- */
static const char* canon_PIXMA_Pro9000_modeuses_plain[] = {
- "600x600dpi_hig2",
- "600x600dpi_high",
+ "600x600dpi_high2",
"600x600dpi",
"600x600dpi_std2",
"600x600dpi_draft",
diff --git a/src/main/canon-media.h b/src/main/canon-media.h
index 4b47916..7fc3bf7 100644
--- a/src/main/canon-media.h
+++ b/src/main/canon-media.h
@@ -113,7 +113,7 @@ static const canon_slot_t canon_MULTIPASS_MP250_slots[] = {
DECLARE_SLOTS(canon_MULTIPASS_MP250);
static const canon_slot_t canon_PIXMA_MG2100_slots[] = {
- { "Front", N_ ("Front tray"), 0x8 },
+ { "Front", N_ ("Front tray"), 0x8 },
};
DECLARE_SLOTS(canon_PIXMA_MG2100);
@@ -145,13 +145,13 @@ static const canon_slot_t canon_BJC_S800_slots[] = {
DECLARE_SLOTS(canon_BJC_S800);
static const canon_slot_t canon_MULTIPASS_MX7600_slots[] = {
- { "Cassette", N_ ("Cassette"), 0x8 },
+ { "Cassette", N_ ("Cassette"), 0x8 },
};
DECLARE_SLOTS(canon_MULTIPASS_MX7600);
static const canon_slot_t canon_PIXMA_iX7000_slots[] = {
{ "Cassette", N_ ("Cassette"), 0x8 },
- { "HandFeed", N_ ("Hand Feeding"), 0x1 },
+ { "HandFeed", N_ ("Hand Feeding"), 0x1 },
{ "Rear", N_ ("Rear tray"), 0x4 },
};
DECLARE_SLOTS(canon_PIXMA_iX7000);
@@ -178,14 +178,14 @@ DECLARE_SLOTS(canon_MULTIPASS_MX850);
static const canon_slot_t canon_MULTIPASS_MP520_slots[] = {
{ "SelectKey", N_ ("Selected by Paper Select Key"), 0x3 },
{ "Rear", N_ ("Rear tray"), 0x4 },
- { "Front", N_ ("Front tray"), 0x8 },
+ { "Front", N_ ("Front tray"), 0x8 },
/* There is also a "plain media only Front" option, but it seems to have same 0x8 when used, no idea whether it should take different values */
};
DECLARE_SLOTS(canon_MULTIPASS_MP520);
static const canon_slot_t canon_PIXMA_iP3500_slots[] = {
{ "Rear", N_ ("Rear tray"), 0x4 },
- { "Front", N_ ("Front tray"), 0x8 },
+ { "Front", N_ ("Front tray"), 0x8 },
/* There is also a "plain media only Front" option, but it seems to have same 0x8 when used, no idea whether it should take different values */
};
DECLARE_SLOTS(canon_PIXMA_iP3500);
@@ -211,7 +211,7 @@ DECLARE_SLOTS(canon_PIXMA_iP4600);
/* Pro9000, Pro9500 series */
static const canon_slot_t canon_PIXMA_Pro9000_slots[] = {
{ "Rear", N_ ("Rear tray"), 0x4 },
- { "Front", N_ ("Front tray"), 0xb },
+ { "Front", N_ ("Front tray"), 0xb },
{ "CD", N_ ("CD tray"), 0xa },
};
DECLARE_SLOTS(canon_PIXMA_Pro9000);
@@ -374,7 +374,6 @@ static const canon_paper_t canon_PIXMA_iP4100_papers[] = {
{ "DiscOthers", N_ ("Printable Disc (Other)"), 0x0c,0x12,0x00,0.78, 0.25, 0.500, 0, 0, 0 },
{ "TShirt", N_ ("T-Shirt Transfers"), 0x03,0x03,0x00,0.78, 0.25, 0.500, 0, 0, 0 },
{ "Envelope", N_ ("Envelope"), 0x08,0x08,0x00,0.78, 0.25, 0.500, 0, 0, 0 },
- { "Transparency", N_ ("Transparencies"), 0x02,0x02,0x00,0.78, 0.25, 0.900, 0, 0, 0 },
{ "PhotopaperOther", N_ ("Other Photo Paper"), 0x0f,0x14,0x00,0.78, 0.25, 0.500, 0, 0, 0 }, /* untested */
{ "Transparency", N_ ("Transparencies"), 0x02,0x02,0x00,0.78, 0.25, 0.500, 0, 0, 0 }, /* untested */
};
diff --git a/src/main/print-escp2.c b/src/main/print-escp2.c
index 3c95d8e..07effa8 100644
--- a/src/main/print-escp2.c
+++ b/src/main/print-escp2.c
@@ -1,5 +1,5 @@
/*
- * "$Id: print-escp2.c,v 1.438 2012/01/19 13:26:28 m0m Exp $"
+ * "$Id: print-escp2.c,v 1.439 2012/06/16 03:10:56 rlk Exp $"
*
* Print plug-in EPSON ESC/P2 driver for the GIMP.
*
@@ -2304,8 +2304,8 @@ escp2_parameters(const stp_vars_t *v, const char *name,
strcmp(name, "CDYAdjustment") == 0)
{
const input_slot_t *slot = stp_escp2_get_input_slot(v);
- description->bounds.dimension.lower = -15;
- description->bounds.dimension.upper = 15;
+ description->bounds.dimension.lower = -30;
+ description->bounds.dimension.upper = 30;
description->deflt.dimension = 0;
if (stp_escp2_printer_supports_print_to_cd(v) && (!slot || slot->is_cd))
description->is_active = 1;
diff --git a/src/testpattern/Makefile.am b/src/testpattern/Makefile.am
index 6d8434a..a8680f1 100644
--- a/src/testpattern/Makefile.am
+++ b/src/testpattern/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.27 2007/12/02 02:44:29 rlk Exp $
+## $Id: Makefile.am,v 1.28 2012/06/25 22:22:04 rlk Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -41,7 +41,7 @@ AM_LFLAGS = -i
AM_YFLAGS = -d
testpattern_SOURCES = testpattern.c testpatterny.y testpatternl.l testpattern.h
-testpattern_LDADD = $(GUTENPRINT_LIBS)
+testpattern_LDADD = $(GUTENPRINT_LIBS) $(LIBM)
testpatternl.o: testpatterny.o
testpattern.o: testpatterny.o
diff --git a/src/testpattern/Makefile.in b/src/testpattern/Makefile.in
index 9b39a29..e25a132 100644
--- a/src/testpattern/Makefile.in
+++ b/src/testpattern/Makefile.in
@@ -76,7 +76,8 @@ printers_DEPENDENCIES = $(GUTENPRINT_LIBS)
am_testpattern_OBJECTS = testpattern.$(OBJEXT) testpatterny.$(OBJEXT) \
testpatternl.$(OBJEXT)
testpattern_OBJECTS = $(am_testpattern_OBJECTS)
-testpattern_DEPENDENCIES = $(GUTENPRINT_LIBS)
+am__DEPENDENCIES_1 =
+testpattern_DEPENDENCIES = $(GUTENPRINT_LIBS) $(am__DEPENDENCIES_1)
SCRIPTS = $(noinst_SCRIPTS)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/scripts/depcomp
@@ -219,6 +220,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
@@ -348,7 +350,7 @@ TESTS = run-testpattern-1 run-testpattern-2
AM_LFLAGS = -i
AM_YFLAGS = -d
testpattern_SOURCES = testpattern.c testpatterny.y testpatternl.l testpattern.h
-testpattern_LDADD = $(GUTENPRINT_LIBS)
+testpattern_LDADD = $(GUTENPRINT_LIBS) $(LIBM)
printers_LDADD = $(GUTENPRINT_LIBS)
printer_options_LDADD = $(GUTENPRINT_LIBS)
@INSTALL_SAMPLES_TRUE@pkgdata_DATA = testpattern.sample extended.sample
diff --git a/src/xml/Makefile.in b/src/xml/Makefile.in
index 530164f..b19ffe6 100644
--- a/src/xml/Makefile.in
+++ b/src/xml/Makefile.in
@@ -234,6 +234,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/Makefile.in b/src/xml/escp2/Makefile.in
index 56b3b34..84ed55a 100644
--- a/src/xml/escp2/Makefile.in
+++ b/src/xml/escp2/Makefile.in
@@ -191,6 +191,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/inks/Makefile.in b/src/xml/escp2/inks/Makefile.in
index 0a2220e..367177b 100644
--- a/src/xml/escp2/inks/Makefile.in
+++ b/src/xml/escp2/inks/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/inputslots/Makefile.in b/src/xml/escp2/inputslots/Makefile.in
index e092488..0216513 100644
--- a/src/xml/escp2/inputslots/Makefile.in
+++ b/src/xml/escp2/inputslots/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/media/Makefile.in b/src/xml/escp2/media/Makefile.in
index 9e3f5d0..50acdf6 100644
--- a/src/xml/escp2/media/Makefile.in
+++ b/src/xml/escp2/media/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/mediasizes/Makefile.in b/src/xml/escp2/mediasizes/Makefile.in
index 1ad4db8..162a40a 100644
--- a/src/xml/escp2/mediasizes/Makefile.in
+++ b/src/xml/escp2/mediasizes/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/model/Makefile.in b/src/xml/escp2/model/Makefile.in
index c3994ba..4bebb2f 100644
--- a/src/xml/escp2/model/Makefile.in
+++ b/src/xml/escp2/model/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/qualitypresets/Makefile.in b/src/xml/escp2/qualitypresets/Makefile.in
index 3f23a6d..e2fd678 100644
--- a/src/xml/escp2/qualitypresets/Makefile.in
+++ b/src/xml/escp2/qualitypresets/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
diff --git a/src/xml/escp2/weaves/Makefile.in b/src/xml/escp2/weaves/Makefile.in
index ab4ac94..c2d0c83 100644
--- a/src/xml/escp2/weaves/Makefile.in
+++ b/src/xml/escp2/weaves/Makefile.in
@@ -175,6 +175,7 @@ LEXLIB = @LEXLIB@
LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBM = @LIBM@
LIBOBJS = @LIBOBJS@
LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@