summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 16:11:05 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 16:11:05 +0000
commit3b59bb0a607ec27ea60f07d1cd5d1bbb4483c832 (patch)
treec119edaa8374e7b6387de7aa7d65b143732af5db /test/Makefile.am
parenteb5718390731a9746c556317e641320b671f2091 (diff)
Imported Upstream version 4.2.7
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am26
1 files changed, 14 insertions, 12 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 969f7d9..ce13935 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.30 2001/11/10 14:42:43 rlk Exp $
+## $Id: Makefile.am,v 1.30.2.4 2002/06/05 23:52:05 rlk Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -28,31 +28,33 @@ MAINT_CHARSET = latin1
AM_CFLAGS = $(GNUCFLAGS)
INCLUDES = @INCLUDES@ $(LIBGIMPPRINT_CFLAGS) -I$(top_srcdir)/src/main
-LIBS = @LIBS@ ../lib/libprintut.la $(INTLLIBS) ../lib/libprintut.la
+LIBPRINTUT = $(top_builddir)/lib/libprintut.la
+LIBS = $(INTLLIBS) @LIBS@
-TESTS = testdither run-weavetest
+TESTS = run-testdither run-weavetest
## Programs
-TEST_BIN = testdither escp2-weavetest unprint pcl-unprint bjc-unprint
-noinst_PROGRAMS = @TEST_BIN@
-EXTRA_PROGRAMS = escp2-weavetest unprint pcl-unprint bjc-unprint testdither
+if BUILD_TEST
+noinst_PROGRAMS = testdither escp2-weavetest unprint pcl-unprint bjc-unprint
+endif
escp2_weavetest_SOURCES = escp2-weavetest.c
-
-escp2_weavetest.o: escp2_weavetest.c
-escp2_weavetest_LDADD = $(LIBGIMPPRINT_LIBS)
+escp2_weavetest_LDADD = $(LIBPRINTUT) $(LIBGIMPPRINT_LIBS)
escp2_weavetest_DEPENDENCIES = $(LIBGIMPPRINT_LIBS)
unprint_SOURCES = unprint.c
+unprint_LDADD = $(LIBPRINTUT)
pcl_unprint_SOURCES = pcl-unprint.c
+pcl_unprint_LDADD = $(LIBPRINTUT)
bjc_unprint_SOURCES = bjc-unprint.c
+bjc_unprint_LDADD = $(LIBPRINTUT)
testdither_SOURCES = testdither.c
-testdither_LDADD = $(LIBGIMPPRINT_LIBS)
+testdither_LDADD = $(LIBPRINTUT) $(LIBGIMPPRINT_LIBS)
testdither_DEPENDENCIES = $(LIBGIMPPRINT_LIBS)
$(LIBGIMPPRINT_LIBS):
@@ -67,7 +69,7 @@ $(LIBGIMPPRINT_LIBS):
## Clean
-CLEANFILES = $(EXTRA_PROGRAMS) mixed-color-1bit.ppm
+CLEANFILES = mixed-color-1bit.ppm
MAINTAINERCLEANFILES = Makefile.in
-EXTRA_DIST = cyan-sweep.tif parse-escp2 run-weavetest
+EXTRA_DIST = cyan-sweep.tif parse-escp2 run-weavetest run-testdither