summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
committerDidier Raboud <odyx@debian.org>2018-09-25 08:33:05 +0200
commite50542121e724e851fc5d6c68bb773f80c0bc12c (patch)
tree655c3f6331a6e8fd8b09ceb4da8f5896484ae16a /test/Makefile.am
parent9dd97a029bf391c42b1dc76f2f7c5e386bb8f466 (diff)
New upstream version 5.3.1
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ce0ae64..8bc37c2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -11,8 +11,7 @@
## GNU General Public License for more details.
##
## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+## along with this program. If not, see <https://www.gnu.org/licenses/>.
## Process this file with automake to produce Makefile.in.
@@ -20,7 +19,6 @@
include $(top_srcdir)/scripts/global.mk
-
## Variables
LOCAL_CPPFLAGS = -I$(top_srcdir)/src/main $(GUTENPRINT_CFLAGS)
@@ -28,14 +26,19 @@ LOCAL_CPPFLAGS = -I$(top_srcdir)/src/main $(GUTENPRINT_CFLAGS)
## run-weavetest is extremely time consuming and provides little value for
## release testing since the last material change was made in 2008.
## It is essentially a giant unit test for the weave code.
-TESTS = curve run-testdither
+## testdither doesn't actually test anything; there appears to be no way
+## for it to actually return anything.
+TESTS = test-curve run-weavetest run-testdither
## Programs
if BUILD_TEST
+AM_TESTS_ENVIRONMENT=STP_MODULE_PATH=$(top_builddir)/src/main/.libs:$(top_builddir)/src/main STP_DATA_PATH=$(top_srcdir)/src/xml
noinst_PROGRAMS = testdither escp2-weavetest unprint pcl-unprint bjc-unprint curve xml-curve pixma_parse gen-printer-list
endif
+noinst_SCRIPTS=test-curve run-weavetest run-testdither
+
escp2_weavetest_SOURCES = escp2-weavetest.c
escp2_weavetest_LDADD = $(GUTENPRINT_LIBS)
@@ -72,4 +75,4 @@ pixma_parse_SOURCES = pixma_parse.c pixma_parse.h
CLEANFILES = mixed-color-1bit.ppm
MAINTAINERCLEANFILES = Makefile.in
-EXTRA_DIST = cyan-sweep.tif parse-escp2 run-weavetest run-testdither
+EXTRA_DIST = cyan-sweep.tif parse-escp2 run-weavetest run-testdither test-curve