summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-09-20 11:56:08 +0200
committerDidier Raboud <odyx@debian.org>2016-09-20 11:56:08 +0200
commit7f5731038556e5b03d2a886163ca2c873c77333d (patch)
tree8f4194af3949a73accf44b2b0bd8ebfa990ac577 /test
parenta313257bdec71bc92a56598e74d9097c16cb6e48 (diff)
New upstream version 5.2.12~pre2
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am1
-rw-r--r--test/Makefile.in31
-rw-r--r--test/bjc-unprint.c1
-rw-r--r--test/curve.c1
-rw-r--r--test/escp2-weavetest.c1
-rw-r--r--test/gen-printer-list.c4
-rwxr-xr-xtest/parse-escp210
-rw-r--r--test/pcl-unprint.c5
-rw-r--r--test/testdither.c7
-rw-r--r--test/unprint.c1
-rw-r--r--test/xml-curve.c1
11 files changed, 19 insertions, 44 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 60bc2df..ce0ae64 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,3 @@
-## $Id: Makefile.am,v 1.50 2014/05/22 02:08:20 rlk Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
diff --git a/test/Makefile.in b/test/Makefile.in
index 07e6711..bb25f6c 100644
--- a/test/Makefile.in
+++ b/test/Makefile.in
@@ -84,8 +84,7 @@ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
DIST_COMMON = $(top_srcdir)/scripts/global.mk $(srcdir)/Makefile.in \
- $(srcdir)/Makefile.am $(top_srcdir)/scripts/mkinstalldirs \
- $(top_srcdir)/scripts/depcomp \
+ $(srcdir)/Makefile.am $(top_srcdir)/scripts/depcomp \
$(top_srcdir)/scripts/test-driver
TESTS = curve$(EXEEXT) run-testdither
@BUILD_TEST_TRUE@noinst_PROGRAMS = testdither$(EXEEXT) \
@@ -97,19 +96,18 @@ TESTS = curve$(EXEEXT) run-testdither
subdir = test
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
- $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/isc-posix.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libtool.m4 \
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
- $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp.m4 \
- $(top_srcdir)/m4/stp_cups.m4 $(top_srcdir)/m4/stp_gimp.m4 \
- $(top_srcdir)/m4/stp_option.m4 $(top_srcdir)/m4/stp_release.m4 \
- $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/ltoptions.m4 \
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
+ $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/progtest.m4 \
+ $(top_srcdir)/m4/stp.m4 $(top_srcdir)/m4/stp_cups.m4 \
+ $(top_srcdir)/m4/stp_gimp.m4 $(top_srcdir)/m4/stp_option.m4 \
+ $(top_srcdir)/m4/stp_release.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
-mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
+mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
@@ -458,9 +456,6 @@ ENABLE_STATIC = @ENABLE_STATIC@
EXEEXT = @EXEEXT@
FGREP = @FGREP@
FIND = @FIND@
-FOOMATIC_CONFIGURE = @FOOMATIC_CONFIGURE@
-FOOMATIC_KITLOAD = @FOOMATIC_KITLOAD@
-FOOMATIC_PPDFILE = @FOOMATIC_PPDFILE@
GENPPD_LIBS = @GENPPD_LIBS@
GIMP2_CFLAGS = @GIMP2_CFLAGS@
GIMP2_LIBS = @GIMP2_LIBS@
@@ -493,9 +488,6 @@ GUTENPRINT_MICRO_VERSION = @GUTENPRINT_MICRO_VERSION@
GUTENPRINT_MINOR_VERSION = @GUTENPRINT_MINOR_VERSION@
GUTENPRINT_RELEASE_VERSION = @GUTENPRINT_RELEASE_VERSION@
GUTENPRINT_VERSION = @GUTENPRINT_VERSION@
-IJS_CFLAGS = @IJS_CFLAGS@
-IJS_CONFIG = @IJS_CONFIG@
-IJS_LIBS = @IJS_LIBS@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -516,6 +508,7 @@ LIBREADLINE_DEPS = @LIBREADLINE_DEPS@
LIBS = $(INTLLIBS) @LIBS@
LIBTOOL = @LIBTOOL@
LIBTOOL_DEPS = @LIBTOOL_DEPS@
+LIBUSB_BACKEND_LIBDEPS = @LIBUSB_BACKEND_LIBDEPS@
LIBUSB_CFLAGS = @LIBUSB_CFLAGS@
LIBUSB_LIBS = @LIBUSB_LIBS@
LIPO = @LIPO@
diff --git a/test/bjc-unprint.c b/test/bjc-unprint.c
index 6eab9cc..8a5bd0f 100644
--- a/test/bjc-unprint.c
+++ b/test/bjc-unprint.c
@@ -1,4 +1,3 @@
-/* $Id: bjc-unprint.c,v 1.13 2012/08/13 15:41:03 gernot2270 Exp $ */
/*
* Convert BJC-printjobs to xbm files, one for each color channel
*
diff --git a/test/curve.c b/test/curve.c
index 99bc65c..3590cbf 100644
--- a/test/curve.c
+++ b/test/curve.c
@@ -1,5 +1,4 @@
/*
- * "$Id: curve.c,v 1.24 2014/01/04 00:31:38 rlk Exp $"
*
* Copyright 2002 Robert Krawitz (rlk@alum.mit.edu)
*
diff --git a/test/escp2-weavetest.c b/test/escp2-weavetest.c
index f63b956..ad6eb03 100644
--- a/test/escp2-weavetest.c
+++ b/test/escp2-weavetest.c
@@ -1,5 +1,4 @@
/*
- * "$Id: escp2-weavetest.c,v 1.37 2006/05/05 23:23:40 rlk Exp $"
*
* Print plug-in EPSON ESC/P2 driver for the GIMP.
*
diff --git a/test/gen-printer-list.c b/test/gen-printer-list.c
index f6d38ed..679856c 100644
--- a/test/gen-printer-list.c
+++ b/test/gen-printer-list.c
@@ -1,5 +1,4 @@
/*
- * "$Id: gen-printer-list.c,v 1.1 2014/05/22 02:08:20 rlk Exp $"
*
* Test pattern generator for Gutenprint
*
@@ -42,10 +41,9 @@ main(int argc, char **argv)
const stp_printer_t *p = stp_get_printer_by_index(i);
if (strcmp(stp_printer_get_family(p), "ps") &&
strcmp(stp_printer_get_family(p), "raw"))
- printf("<tr><td>%s</td><td>%s</td><td>%s</td><td>%s</td></tr>\n",
+ printf("<tr><td>%s</td><td>%s</td><td>%s</td></tr>\n",
stp_printer_get_long_name(p),
stp_printer_get_driver(p),
- stp_printer_get_foomatic_id(p) ? stp_printer_get_foomatic_id(p) : "",
stp_printer_get_comment(p) ? stp_printer_get_comment(p) : "");
}
return 0;
diff --git a/test/parse-escp2 b/test/parse-escp2
index 30839fa..a0ce69f 100755
--- a/test/parse-escp2
+++ b/test/parse-escp2
@@ -225,11 +225,13 @@ sub print_output_data($$$$$$) {
}
my $savedots = $dots;
if ($comptype == 0) {
- fill_buffer($dots / 8);
- if ($opt_V) {
- printf "%*v02x ", " ", substr($stuff, $curoffset + 0, $dots / 8);
+ foreach $i (0..$rows-1) {
+ fill_buffer($dots / 8);
+ if ($opt_V) {
+ printf "%*v02x ", " ", substr($stuff, $curoffset + 0, $dots / 8);
+ }
+ increment_curpos($dots / 8);
}
- increment_curpos($dots / 8);
} elsif ($comptype == 1) {
foreach $i (0..$rows-1) {
my ($found_something) = 0;
diff --git a/test/pcl-unprint.c b/test/pcl-unprint.c
index c7ef956..1ceee84 100644
--- a/test/pcl-unprint.c
+++ b/test/pcl-unprint.c
@@ -1,6 +1,4 @@
/*
- * "$Id: pcl-unprint.c,v 1.11 2004/09/17 18:38:28 rleigh Exp $"
- *
* pclunprint.c - convert an HP PCL file into an image file for viewing.
*
* Copyright 2000 Dave Hill (dave@minnie.demon.co.uk)
@@ -33,8 +31,6 @@
#include<ctype.h>
#include<string.h>
-static const char *id="@(#) $Id: pcl-unprint.c,v 1.11 2004/09/17 18:38:28 rleigh Exp $";
-
/*
* Size of buffer used to read file
*/
@@ -842,7 +838,6 @@ int main(int argc, char *argv[])
output_data.active_length = 0;
output_data.output_depth = 0;
- id = id; /* Remove compiler warning */
received_rows = NULL;
if(argc == 1){
diff --git a/test/testdither.c b/test/testdither.c
index 4a2d1f3..433b56b 100644
--- a/test/testdither.c
+++ b/test/testdither.c
@@ -1,6 +1,4 @@
/*
- * "$Id: testdither.c,v 1.49 2006/05/07 13:26:27 rlk Exp $"
- *
* Test/profiling program for dithering code.
*
* Copyright 1997-2000 Michael Sweet (mike@easysw.com)
@@ -1006,8 +1004,3 @@ write_photo(FILE *fp,
}
}
}
-
-
-/*
- * End of "$Id: testdither.c,v 1.49 2006/05/07 13:26:27 rlk Exp $".
- */
diff --git a/test/unprint.c b/test/unprint.c
index ee02562..a3b5a97 100644
--- a/test/unprint.c
+++ b/test/unprint.c
@@ -1,4 +1,3 @@
-/* $Id: unprint.c,v 1.46 2011/04/01 02:20:09 rlk Exp $ */
/*
* Generate PPM files from printer output
*
diff --git a/test/xml-curve.c b/test/xml-curve.c
index 6bebf3a..d1d1bbb 100644
--- a/test/xml-curve.c
+++ b/test/xml-curve.c
@@ -1,5 +1,4 @@
/*
- * "$Id: xml-curve.c,v 1.7 2008/08/02 15:10:56 rleigh Exp $"
*
* Copyright 2002 Robert Krawitz (rlk@alum.mit.edu)
*