summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/rules20
2 files changed, 14 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 68ed0b9..7a2621e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,8 @@ gutenprint (5.2.1-2) experimental; urgency=low
+ Remove redundant removal of -stamp files.
+ Save and restore config.sub and config.guess. Thanks to
Till Kamppeter.
+ + Move copying of new config.sub and config.guess to
+ autoconfigure-stamp, or else saving and restoring has no effect.
- install: Replace use of pwd with $(CURDIR).
- Use quilt in place of dpatch, and add rule to generate quilt patch
series from patches branch in git.
@@ -30,8 +32,9 @@ gutenprint (5.2.1-2) experimental; urgency=low
PPD files are no longer generated, we don't need to patch the source
to use /usr/share/ppd.
*
+ *
- -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:24:11 +0000
+ -- Roger Leigh <rleigh@debian.org> Sat, 01 Nov 2008 16:26:03 +0000
gutenprint (5.2.1-1) experimental; urgency=low
diff --git a/debian/rules b/debian/rules
index bb71635..42627c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,6 +36,16 @@ update-patch-series:
autoconfigure: autoconfigure-stamp
autoconfigure-stamp: debian/control
+ [ -r scripts/config.sub.orig ] || \
+ cp -f scripts/config.sub scripts/config.sub.orig
+ [ -r scripts/config.guess.orig ] || \
+ cp -f scripts/config.guess scripts/config.guess.orig
+
+ [ ! -r /usr/share/misc/config.sub ] || \
+ cp -f /usr/share/misc/config.sub scripts/config.sub
+ [ ! -r /usr/share/misc/config.guess ] || \
+ cp -f /usr/share/misc/config.guess scripts/config.guess
+
dh_testdir
mkdir debian/build; \
cd debian/build; \
@@ -64,16 +74,6 @@ clean: realclean unpatch
realclean: debian/control
dh_testdir
- [ -r scripts/config.sub.orig ] || \
- cp -f scripts/config.sub scripts/config.sub.orig
- [ -r scripts/config.guess.orig ] || \
- cp -f scripts/config.guess scripts/config.guess.orig
-
- [ ! -r /usr/share/misc/config.sub ] || \
- cp -f /usr/share/misc/config.sub scripts/config.sub
- [ ! -r /usr/share/misc/config.guess ] || \
- cp -f /usr/share/misc/config.guess scripts/config.guess
-
rm -rf debian/build debian/install
[ ! -f Makefile ] || $(MAKE) distclean