summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh14
1 files changed, 12 insertions, 2 deletions
diff --git a/autogen.sh b/autogen.sh
index 7a88e19..82fef1b 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,15 +1,25 @@
#!/bin/sh
# Run this to generate all the initial makefiles, etc.
-srcdir=`dirname $0`
+srcdir="`dirname $0`"
test -z "$srcdir" && srcdir=.
PKG_NAME="gutenprint"
-(test -f $srcdir/configure.ac) || {
+(test -f "$srcdir/configure.ac") || {
echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
echo " top-level directory"
exit 1
}
+if test $# -gt 0 ; then
+ case "$1" in
+ -h|--help|--help=*)
+ if test -f "$srcdir/configure" ; then
+ exec "$srcdir/configure" "$1"
+ fi ;;
+ *) ;;
+ esac
+fi
+
. $srcdir/scripts/autogen.sh