summaryrefslogtreecommitdiff
path: root/debian/patches/0002-Fix-format-warning.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Fix-format-warning.patch')
-rw-r--r--debian/patches/0002-Fix-format-warning.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/patches/0002-Fix-format-warning.patch b/debian/patches/0002-Fix-format-warning.patch
new file mode 100644
index 0000000..e815317
--- /dev/null
+++ b/debian/patches/0002-Fix-format-warning.patch
@@ -0,0 +1,36 @@
+From fb019c55c5d12c20f0371b417cb416d6caec3ad6 Mon Sep 17 00:00:00 2001
+From: Robert Krawitz <rlk@alum.mit.edu>
+Date: Tue, 25 Sep 2018 13:48:47 -0400
+Subject: Fix format warning
+
+---
+ configure.ac | 2 +-
+ src/cups/gutenprint.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0ae13ba4..b7c54972 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -710,7 +710,7 @@ AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
+
+ dnl Compiler flags
+ if test x$ac_compiler_gnu = "xyes"; then
+- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
++ STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 -Wformat -Werror=format-security -Wmissing-prototypes],, [GNUCFLAGS])
+ if test x${USE_MAINTAINER_MODE} = xyes ; then
+ STP_ADD_COMPILER_ARGS([-D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
+ fi
+diff --git a/src/cups/gutenprint.c b/src/cups/gutenprint.c
+index 6ab2194e..56b55994 100644
+--- a/src/cups/gutenprint.c
++++ b/src/cups/gutenprint.c
+@@ -122,7 +122,7 @@ cat_ppd(const char *uri) /* I - Driver URI */
+ const char *lang = NULL;
+ char *s;
+ char filename[1024], /* Filename */
+- ppd_location[1024]; /* Installed location */
++ ppd_location[2048]; /* Installed location */
+ const char *infix = "";
+ ppd_type_t ppd_type = PPD_STANDARD;
+ gpfile outFD;