summaryrefslogtreecommitdiff
path: root/doc/developer
diff options
context:
space:
mode:
Diffstat (limited to 'doc/developer')
-rw-r--r--doc/developer/Makefile.am4
-rw-r--r--doc/developer/Makefile.in48
-rw-r--r--doc/developer/gutenprint.pdfbin548791 -> 548791 bytes
-rw-r--r--doc/developer/reference-html/book1.html2
-rw-r--r--doc/developer/reference-html/c1717.html2
-rw-r--r--doc/developer/reference-html/c194.html2
-rw-r--r--doc/developer/reference-html/c1968.html2
-rw-r--r--doc/developer/reference-html/c200.html2
-rw-r--r--doc/developer/reference-html/c39.html2
-rw-r--r--doc/developer/reference-html/c464.html2
-rw-r--r--doc/developer/reference-html/c48.html2
-rw-r--r--doc/developer/reference-html/f14.html2
-rw-r--r--doc/developer/reference-html/gpl-terms.html2
-rw-r--r--doc/developer/reference-html/gpl.html2
-rw-r--r--doc/developer/reference-html/ln10.html2
-rw-r--r--doc/developer/reference-html/x1669.html2
-rw-r--r--doc/developer/reference-html/x1734.html2
-rw-r--r--doc/developer/reference-html/x271.html2
-rw-r--r--doc/developer/reference-html/x67.html2
-rw-r--r--doc/developer/reference-html/x79.html2
-rw-r--r--doc/developer/reference-html/x955.html2
21 files changed, 54 insertions, 34 deletions
diff --git a/doc/developer/Makefile.am b/doc/developer/Makefile.am
index e93267c..ec1232f 100644
--- a/doc/developer/Makefile.am
+++ b/doc/developer/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.19 2006/07/16 22:57:23 rlk Exp $
+## $Id: Makefile.am,v 1.19.6.1 2007/03/02 12:01:12 rlk Exp $
## Copyright (C) 2001 Andy Stewart and Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -163,7 +163,7 @@ clean-local:
$(RM) -f $(MANUAL_SRC_FILES) ; \
fi
-$(RM) -rf *.tex *.log *.aux *.dvi *.gz *.out *.junk *.out *.fot
- -$(RM) -rf db2html* DB2HTML*
+ -$(RM) -rf db2html* DB2HTML* CATALOG.local
veryclean:
$(MAKE) MAINT_MODE=true clean
diff --git a/doc/developer/Makefile.in b/doc/developer/Makefile.in
index a86a76e..bc8612f 100644
--- a/doc/developer/Makefile.in
+++ b/doc/developer/Makefile.in
@@ -46,30 +46,34 @@ subdir = doc/developer
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/gimp.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/progtest.m4 \
- $(top_srcdir)/m4/stp.m4 $(top_srcdir)/m4/stp_cups.m4 \
- $(top_srcdir)/m4/stp_gimp.m4 $(top_srcdir)/m4/stp_option.m4 \
- $(top_srcdir)/m4/stp_release.m4 $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/isc-posix.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp.m4 \
+ $(top_srcdir)/m4/stp_cups.m4 $(top_srcdir)/m4/stp_gimp.m4 \
+ $(top_srcdir)/m4/stp_option.m4 $(top_srcdir)/m4/stp_release.m4 \
+ $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
-depcomp =
-am__depfiles_maybe =
SOURCES =
DIST_SOURCES =
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
ALL_LINGUAS = @ALL_LINGUAS@
+AMDEP_FALSE = @AMDEP_FALSE@
+AMDEP_TRUE = @AMDEP_TRUE@
AMTAR = @AMTAR@
AR = @AR@
AUTOCONF = @AUTOCONF@
AUTOHEADER = @AUTOHEADER@
AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
+BUILD_CUPS_1_2_FALSE = @BUILD_CUPS_1_2_FALSE@
+BUILD_CUPS_1_2_TRUE = @BUILD_CUPS_1_2_TRUE@
BUILD_CUPS_FALSE = @BUILD_CUPS_FALSE@
+BUILD_CUPS_PPDS = @BUILD_CUPS_PPDS@
BUILD_CUPS_PPDS_FALSE = @BUILD_CUPS_PPDS_FALSE@
BUILD_CUPS_PPDS_TRUE = @BUILD_CUPS_PPDS_TRUE@
BUILD_CUPS_TRUE = @BUILD_CUPS_TRUE@
@@ -95,6 +99,8 @@ BUILD_LIBGUTENPRINTUI_FALSE = @BUILD_LIBGUTENPRINTUI_FALSE@
BUILD_LIBGUTENPRINTUI_TRUE = @BUILD_LIBGUTENPRINTUI_TRUE@
BUILD_MODULES_FALSE = @BUILD_MODULES_FALSE@
BUILD_MODULES_TRUE = @BUILD_MODULES_TRUE@
+BUILD_SIMPLIFIED_CUPS_PPDS_FALSE = @BUILD_SIMPLIFIED_CUPS_PPDS_FALSE@
+BUILD_SIMPLIFIED_CUPS_PPDS_TRUE = @BUILD_SIMPLIFIED_CUPS_PPDS_TRUE@
BUILD_TESTPATTERN_FALSE = @BUILD_TESTPATTERN_FALSE@
BUILD_TESTPATTERN_TRUE = @BUILD_TESTPATTERN_TRUE@
BUILD_TEST_FALSE = @BUILD_TEST_FALSE@
@@ -102,6 +108,7 @@ BUILD_TEST_TRUE = @BUILD_TEST_TRUE@
BUILD_TRANSLATED_CUPS_PPDS_FALSE = @BUILD_TRANSLATED_CUPS_PPDS_FALSE@
BUILD_TRANSLATED_CUPS_PPDS_TRUE = @BUILD_TRANSLATED_CUPS_PPDS_TRUE@
CC = @CC@
+CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
CONVERT = @CONVERT@
CPP = @CPP@
@@ -114,12 +121,14 @@ CUPS_PPDS_AT_TOP_LEVEL_TRUE = @CUPS_PPDS_AT_TOP_LEVEL_TRUE@
CUPS_PPD_PS_LEVEL = @CUPS_PPD_PS_LEVEL@
CXX = @CXX@
CXXCPP = @CXXCPP@
+CXXDEPMODE = @CXXDEPMODE@
CXXFLAGS = @CXXFLAGS@
CYGPATH_W = @CYGPATH_W@
DB2HTML = @DB2HTML@
DB2PDF = @DB2PDF@
DB2PS = @DB2PS@
DEFS = @DEFS@
+DEPDIR = @DEPDIR@
DIALOG = @DIALOG@
DOXYGEN = @DOXYGEN@
DVIPDF = @DVIPDF@
@@ -154,6 +163,7 @@ GLIB_LIBS = @GLIB_LIBS@
GLIB_MKENUMS = @GLIB_MKENUMS@
GMSGFMT = @GMSGFMT@
GNUCFLAGS = @GNUCFLAGS@
+GREP = @GREP@
GTK2_CFLAGS = @GTK2_CFLAGS@
GTK2_LIBS = @GTK2_LIBS@
GTK_CFLAGS = @GTK_CFLAGS@
@@ -249,14 +259,17 @@ VERSION = @VERSION@
WHICH_PPDS = @WHICH_PPDS@
XGETTEXT = @XGETTEXT@
YACC = @YACC@
-ac_ct_AR = @ac_ct_AR@
+YFLAGS = @YFLAGS@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_F77 = @ac_ct_F77@
-ac_ct_RANLIB = @ac_ct_RANLIB@
-ac_ct_STRIP = @ac_ct_STRIP@
-ac_pt_PKG_CONFIG = @ac_pt_PKG_CONFIG@
+am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
+am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
+am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
+am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
+am__include = @am__include@
am__leading_dot = @am__leading_dot@
+am__quote = @am__quote@
am__tar = @am__tar@
am__untar = @am__untar@
bindir = @bindir@
@@ -273,6 +286,9 @@ cups_exec_prefix = @cups_exec_prefix@
cups_prefix = @cups_prefix@
cups_sbindir = @cups_sbindir@
datadir = @datadir@
+datarootdir = @datarootdir@
+docdir = @docdir@
+dvidir = @dvidir@
exec_prefix = @exec_prefix@
gimp2_plug_indir = @gimp2_plug_indir@
gimp_plug_indir = @gimp_plug_indir@
@@ -290,17 +306,21 @@ host_alias = @host_alias@
host_cpu = @host_cpu@
host_os = @host_os@
host_vendor = @host_vendor@
+htmldir = @htmldir@
includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
libdir = @libdir@
libexecdir = @libexecdir@
+localedir = @localedir@
localstatedir = @localstatedir@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
+pdfdir = @pdfdir@
prefix = @prefix@
program_transform_name = @program_transform_name@
+psdir = @psdir@
sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
@@ -347,9 +367,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(top_srcdir
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu --ignore-deps doc/developer/Makefile'; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu doc/developer/Makefile'; \
cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu --ignore-deps doc/developer/Makefile
+ $(AUTOMAKE) --gnu doc/developer/Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
@@ -617,7 +637,7 @@ clean-local:
$(RM) -f $(MANUAL_SRC_FILES) ; \
fi
-$(RM) -rf *.tex *.log *.aux *.dvi *.gz *.out *.junk *.out *.fot
- -$(RM) -rf db2html* DB2HTML*
+ -$(RM) -rf db2html* DB2HTML* CATALOG.local
veryclean:
$(MAKE) MAINT_MODE=true clean
diff --git a/doc/developer/gutenprint.pdf b/doc/developer/gutenprint.pdf
index 66a6479..e46f495 100644
--- a/doc/developer/gutenprint.pdf
+++ b/doc/developer/gutenprint.pdf
Binary files differ
diff --git a/doc/developer/reference-html/book1.html b/doc/developer/reference-html/book1.html
index 8c8b39c..22d3b84 100644
--- a/doc/developer/reference-html/book1.html
+++ b/doc/developer/reference-html/book1.html
@@ -10,7 +10,7 @@ REL="NEXT"
TITLE="Preface"
HREF="f14.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="book"
><DIV
diff --git a/doc/developer/reference-html/c1717.html b/doc/developer/reference-html/c1717.html
index 3a40313..8d788c0 100644
--- a/doc/developer/reference-html/c1717.html
+++ b/doc/developer/reference-html/c1717.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Weaving algorithms"
HREF="x1734.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c194.html b/doc/developer/reference-html/c194.html
index 40d250a..9b10465 100644
--- a/doc/developer/reference-html/c194.html
+++ b/doc/developer/reference-html/c194.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Adding a new printer"
HREF="c200.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c1968.html b/doc/developer/reference-html/c1968.html
index 6604cc4..2f76563 100644
--- a/doc/developer/reference-html/c1968.html
+++ b/doc/developer/reference-html/c1968.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="GNU General Public License"
HREF="gpl.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c200.html b/doc/developer/reference-html/c200.html
index a995e70..113c95f 100644
--- a/doc/developer/reference-html/c200.html
+++ b/doc/developer/reference-html/c200.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="The driver file"
HREF="x271.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c39.html b/doc/developer/reference-html/c39.html
index 1b6ce3e..ddadc9f 100644
--- a/doc/developer/reference-html/c39.html
+++ b/doc/developer/reference-html/c39.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Using libgutenprint"
HREF="c48.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c464.html b/doc/developer/reference-html/c464.html
index 059dc9a..6dfb8d3 100644
--- a/doc/developer/reference-html/c464.html
+++ b/doc/developer/reference-html/c464.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Remote Mode Commands"
HREF="x955.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/c48.html b/doc/developer/reference-html/c48.html
index 907e61a..71e4a89 100644
--- a/doc/developer/reference-html/c48.html
+++ b/doc/developer/reference-html/c48.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Linking with libgutenprint"
HREF="x67.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="chapter"
><DIV
diff --git a/doc/developer/reference-html/f14.html b/doc/developer/reference-html/f14.html
index b9e5ab2..48eaa51 100644
--- a/doc/developer/reference-html/f14.html
+++ b/doc/developer/reference-html/f14.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="Copying, modification and redistribution"
HREF="c39.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="preface"
><DIV
diff --git a/doc/developer/reference-html/gpl-terms.html b/doc/developer/reference-html/gpl-terms.html
index a457062..16c410f 100644
--- a/doc/developer/reference-html/gpl-terms.html
+++ b/doc/developer/reference-html/gpl-terms.html
@@ -16,7 +16,7 @@ REL="PREVIOUS"
TITLE="GNU General Public License"
HREF="gpl.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/gpl.html b/doc/developer/reference-html/gpl.html
index ccdc927..3a7280e 100644
--- a/doc/developer/reference-html/gpl.html
+++ b/doc/developer/reference-html/gpl.html
@@ -16,7 +16,7 @@ REL="NEXT"
TITLE="TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION"
HREF="gpl-terms.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="appendix"
><DIV
diff --git a/doc/developer/reference-html/ln10.html b/doc/developer/reference-html/ln10.html
index cf959ef..87e4a78 100644
--- a/doc/developer/reference-html/ln10.html
+++ b/doc/developer/reference-html/ln10.html
@@ -11,7 +11,7 @@ REL="NEXT"
TITLE="Preface"
HREF="f14.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
><DIV
CLASS="NAVHEADER"
diff --git a/doc/developer/reference-html/x1669.html b/doc/developer/reference-html/x1669.html
index 9f290fe..4785a2f 100644
--- a/doc/developer/reference-html/x1669.html
+++ b/doc/developer/reference-html/x1669.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="Weaving for inkjet printers"
HREF="c1717.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/x1734.html b/doc/developer/reference-html/x1734.html
index 1a3623a..9004db7 100644
--- a/doc/developer/reference-html/x1734.html
+++ b/doc/developer/reference-html/x1734.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="Dithering"
HREF="c1968.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/x271.html b/doc/developer/reference-html/x271.html
index 6be31a9..288dbfa 100644
--- a/doc/developer/reference-html/x271.html
+++ b/doc/developer/reference-html/x271.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="ESC/P2"
HREF="c464.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/x67.html b/doc/developer/reference-html/x67.html
index 9130f98..c402044 100644
--- a/doc/developer/reference-html/x67.html
+++ b/doc/developer/reference-html/x67.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="Integrating libgutenprint"
HREF="x79.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/x79.html b/doc/developer/reference-html/x79.html
index 05f0608..4b4d156 100644
--- a/doc/developer/reference-html/x79.html
+++ b/doc/developer/reference-html/x79.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="Reporting Bugs"
HREF="c194.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV
diff --git a/doc/developer/reference-html/x955.html b/doc/developer/reference-html/x955.html
index cd11971..5570b9f 100644
--- a/doc/developer/reference-html/x955.html
+++ b/doc/developer/reference-html/x955.html
@@ -19,7 +19,7 @@ REL="NEXT"
TITLE="Appropriate Remote Commands"
HREF="x1669.html"><META
http-equiv="Content-Type"
-content="text/html; charset=UTF-8"></HEAD
+content="text/html; charset=@encoding@"></HEAD
><BODY
CLASS="sect1"
><DIV