summaryrefslogtreecommitdiff
path: root/include/gutenprintui2/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'include/gutenprintui2/Makefile.in')
-rw-r--r--include/gutenprintui2/Makefile.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/gutenprintui2/Makefile.in b/include/gutenprintui2/Makefile.in
index 868ba48..139edb7 100644
--- a/include/gutenprintui2/Makefile.in
+++ b/include/gutenprintui2/Makefile.in
@@ -289,7 +289,7 @@ stpui_built_public_sources = \
@BUILD_LIBGUTENPRINTUI2_TRUE@ $(stpui_built_public_sources)
@MAINTAINER_MODE_TRUE@typebuiltins_extra_deps = Makefile
-MAINTAINERCLEANFILES = Makefile.in typebuiltins.h
+MAINTAINERCLEANFILES = Makefile.in typebuiltins.h typebuiltins.h.tmp
all: all-am
.SUFFIXES:
@@ -543,7 +543,8 @@ $(srcdir)/typebuiltins.h: $(stpui_public_h_sources) $(typebuiltins_extra_deps)
--fprod "/* enumerations from \"@filename@\" */\n" \
--vhead "GType @enum_name@_get_type (void);\n#define STPUI_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
--ftail "G_END_DECLS\n\n#endif /* GUTENPRINTUI_TYPE_BUILTINS_H */" \
- $(stpui_public_h_sources) ) > $@
+ $(stpui_public_h_sources) ) > $@.tmp
+ mv $@.tmp $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: