summaryrefslogtreecommitdiff
path: root/src/foomatic
diff options
context:
space:
mode:
Diffstat (limited to 'src/foomatic')
-rw-r--r--src/foomatic/Makefile.in39
-rw-r--r--src/foomatic/foomatic-printermap32
-rw-r--r--src/foomatic/gutenprint-version.c2
-rw-r--r--src/foomatic/paper_sizes.c2
-rw-r--r--src/foomatic/printer_margins.c2
-rw-r--r--src/foomatic/printer_options.c2
-rw-r--r--src/foomatic/printers.c2
7 files changed, 44 insertions, 37 deletions
diff --git a/src/foomatic/Makefile.in b/src/foomatic/Makefile.in
index 872d850..d854d6a 100644
--- a/src/foomatic/Makefile.in
+++ b/src/foomatic/Makefile.in
@@ -48,13 +48,12 @@ DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
subdir = src/foomatic
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
- $(top_srcdir)/m4/gimp.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/isc-posix.m4 $(top_srcdir)/m4/lib-ld.m4 \
- $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
- $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/stp.m4 \
- $(top_srcdir)/m4/stp_cups.m4 $(top_srcdir)/m4/stp_gimp.m4 \
- $(top_srcdir)/m4/stp_option.m4 $(top_srcdir)/m4/stp_release.m4 \
- $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/isc-posix.m4 \
+ $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
+ $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/progtest.m4 \
+ $(top_srcdir)/m4/stp.m4 $(top_srcdir)/m4/stp_cups.m4 \
+ $(top_srcdir)/m4/stp_gimp.m4 $(top_srcdir)/m4/stp_option.m4 \
+ $(top_srcdir)/m4/stp_release.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(SHELL) $(top_srcdir)/scripts/mkinstalldirs
@@ -145,27 +144,13 @@ FOOMATIC_PPDFILE = @FOOMATIC_PPDFILE@
GENPPD_LIBS = @GENPPD_LIBS@
GIMP2_CFLAGS = @GIMP2_CFLAGS@
GIMP2_LIBS = @GIMP2_LIBS@
-GIMPTOOL = @GIMPTOOL@
GIMPTOOL2_CHECK = @GIMPTOOL2_CHECK@
-GIMPTOOL_CHECK = @GIMPTOOL_CHECK@
-GIMP_CFLAGS = @GIMP_CFLAGS@
-GIMP_CFLAGS_NOUI = @GIMP_CFLAGS_NOUI@
-GIMP_DATA_DIR = @GIMP_DATA_DIR@
-GIMP_LIBS = @GIMP_LIBS@
-GIMP_LIBS_NOUI = @GIMP_LIBS_NOUI@
-GIMP_PLUGIN_DIR = @GIMP_PLUGIN_DIR@
-GLIB_CFLAGS = @GLIB_CFLAGS@
-GLIB_CONFIG = @GLIB_CONFIG@
-GLIB_LIBS = @GLIB_LIBS@
GLIB_MKENUMS = @GLIB_MKENUMS@
GMSGFMT = @GMSGFMT@
GNUCFLAGS = @GNUCFLAGS@
GREP = @GREP@
GTK2_CFLAGS = @GTK2_CFLAGS@
GTK2_LIBS = @GTK2_LIBS@
-GTK_CFLAGS = @GTK_CFLAGS@
-GTK_CONFIG = @GTK_CONFIG@
-GTK_LIBS = @GTK_LIBS@
GUTENPRINTUI2_BINARY_AGE = @GUTENPRINTUI2_BINARY_AGE@
GUTENPRINTUI2_CFLAGS = @GUTENPRINTUI2_CFLAGS@
GUTENPRINTUI2_CURRENT_INTERFACE = @GUTENPRINTUI2_CURRENT_INTERFACE@
@@ -173,13 +158,6 @@ GUTENPRINTUI2_INTERFACE_AGE = @GUTENPRINTUI2_INTERFACE_AGE@
GUTENPRINTUI2_LIBDEPS = @GUTENPRINTUI2_LIBDEPS@
GUTENPRINTUI2_LIBS = $(top_builddir)/src/gutenprintui2/libgutenprintui2.la
GUTENPRINTUI2_VERSION = @GUTENPRINTUI2_VERSION@
-GUTENPRINTUI_BINARY_AGE = @GUTENPRINTUI_BINARY_AGE@
-GUTENPRINTUI_CFLAGS = @GUTENPRINTUI_CFLAGS@
-GUTENPRINTUI_CURRENT_INTERFACE = @GUTENPRINTUI_CURRENT_INTERFACE@
-GUTENPRINTUI_INTERFACE_AGE = @GUTENPRINTUI_INTERFACE_AGE@
-GUTENPRINTUI_LIBDEPS = @GUTENPRINTUI_LIBDEPS@
-GUTENPRINTUI_LIBS = $(top_builddir)/src/gutenprintui/libgutenprintui.la
-GUTENPRINTUI_VERSION = @GUTENPRINTUI_VERSION@
GUTENPRINT_BINARY_AGE = @GUTENPRINT_BINARY_AGE@
GUTENPRINT_CFLAGS = @GUTENPRINT_CFLAGS@
GUTENPRINT_CURRENT_INTERFACE = @GUTENPRINT_CURRENT_INTERFACE@
@@ -284,16 +262,12 @@ docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
gimp2_plug_indir = @gimp2_plug_indir@
-gimp_plug_indir = @gimp_plug_indir@
gutenprint_cflags = @gutenprint_cflags@
gutenprint_libdeps = @gutenprint_libdeps@
gutenprint_libs = @gutenprint_libs@
gutenprintui2_cflags = @gutenprintui2_cflags@
gutenprintui2_libdeps = @gutenprintui2_libdeps@
gutenprintui2_libs = @gutenprintui2_libs@
-gutenprintui_cflags = @gutenprintui_cflags@
-gutenprintui_libdeps = @gutenprintui_libdeps@
-gutenprintui_libs = @gutenprintui_libs@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
@@ -322,6 +296,7 @@ target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(LOCAL_CPPFLAGS) $(GNUCFLAGS)
+GUTENPRINTUI_LIBS = $(top_builddir)/src/gutenprintui/libgutenprintui.la
DISTDIRS = foomatic-templates-ijs
LOCAL_CPPFLAGS = $(GUTENPRINT_CFLAGS)
@BUILD_FOOMATIC_3_TRUE@BUILD_FOOMATIC = 1
diff --git a/src/foomatic/foomatic-printermap b/src/foomatic/foomatic-printermap
index d2efaa9..cbe6867 100644
--- a/src/foomatic/foomatic-printermap
+++ b/src/foomatic/foomatic-printermap
@@ -105,6 +105,7 @@
#gptofoo bjc-PIXMA-iP5000 printer/Canon-PIXMA-iP5000
#gptofoo bjc-PIXMA-iP5200 printer/Canon-PIXMA-iP5200
#gptofoo bjc-PIXMA-iP5300 printer/Canon-PIXMA-iP5300
+#gptofoo bjc-PIXMA-iP6000D printer/Canon-PIXMA-iP6000D
#gptofoo bjc-PIXMA-iP6700 printer/Canon-PIXMA-iP6700
#gptofoo bjc-PIXMA-iP8500 printer/Canon-PIXMA-iP8500
#gptofoo bjc-PIXMA-iX5000 printer/Canon-PIXMA-iX5000
@@ -113,6 +114,7 @@
#gptofoo bjc-MULTIPASS-MP170 printer/Canon-MULTIPASS-MP170
#gptofoo bjc-MULTIPASS-MP180 printer/Canon-MULTIPASS-MP180
#gptofoo bjc-MULTIPASS-MP500 printer/Canon-MULTIPASS-MP500
+#gptofoo bjc-MULTIPASS-MP520 printer/Canon-MULTIPASS-MP520
#gptofoo bjc-MULTIPASS-MP610 printer/Canon-MULTIPASS-MP610
#gptofoo bjc-MULTIPASS-MP700 printer/Canon-MULTIPASS-MP700
#gptofoo bjc-MULTIPASS-MP710 printer/Canon-MULTIPASS-MP710
@@ -163,6 +165,11 @@
#gptofoo escp2-e100 printer/Epson-E_100
#gptofoo escp2-e150 printer/Epson-E_150
#gptofoo escp2-e200 printer/Epson-E_200
+#gptofoo escp2-e300 printer/Epson-E_300
+#gptofoo escp2-e500 printer/Epson-E_500
+#gptofoo escp2-e520 printer/Epson-E_520
+#gptofoo escp2-e700 printer/Epson-E_700
+#gptofoo escp2-e720 printer/Epson-E_720
#gptofoo escp2-mc10000 printer/Epson-MC_10000
#gptofoo escp2-mc2000 printer/Epson-MC_2000
#gptofoo escp2-mc5000 printer/Epson-MC_5000
@@ -233,14 +240,21 @@
#gptofoo escp2-pxv780 printer/Epson-PX_V780
#gptofoo escp2-picmate printer/Epson-PictureMate
#gptofoo escp2-picmated printer/Epson-PictureMate_Deluxe
+#gptofoo escp2-picmatedash printer/Epson-PictureMate_Dash
#gptofoo escp2-picmateflash printer/Epson-PictureMate_Flash
#gptofoo escp2-picmatepal printer/Epson-PictureMate_Pal
#gptofoo escp2-picmatesnap printer/Epson-PictureMate_Snap
+#gptofoo escp2-picmate100 printer/Epson-PictureMate_100
#gptofoo escp2-picmate200 printer/Epson-PictureMate_200
#gptofoo escp2-picmate210 printer/Epson-PictureMate_210
#gptofoo escp2-picmate240 printer/Epson-PictureMate_240
#gptofoo escp2-picmate250 printer/Epson-PictureMate_250
+#gptofoo escp2-picmate260 printer/Epson-PictureMate_260
+#gptofoo escp2-picmate270 printer/Epson-PictureMate_270
#gptofoo escp2-picmate280 printer/Epson-PictureMate_280
+#gptofoo escp2-picmate290 printer/Epson-PictureMate_290
+#gptofoo escp2-picmate500 printer/Epson-PictureMate_500
+#gptofoo escp2-picmate2005 printer/Epson-PictureMate_2005
#gptofoo escp2-c20 printer/Epson-Stylus_C20
#gptofoo escp2-c20sx printer/Epson-Stylus_C20SX
#gptofoo escp2-c20ux printer/Epson-Stylus_C20UX
@@ -354,13 +368,21 @@
#gptofoo escp2-pro printer/Epson-Stylus_Color_PRO
#gptofoo escp2-d68 printer/Epson-Stylus_D68
#gptofoo escp2-d88 printer/Epson-Stylus_D88
+#gptofoo escp2-d92 printer/Epson-Stylus_D92
#gptofoo escp2-d120 printer/Epson-Stylus_D120
#gptofoo escp2-dx3800 printer/Epson-Stylus_DX3800
#gptofoo escp2-dx3850 printer/Epson-Stylus_DX3850
#gptofoo escp2-dx4050 printer/Epson-Stylus_DX4050
#gptofoo escp2-dx4200 printer/Epson-Stylus_DX4200
#gptofoo escp2-dx4250 printer/Epson-Stylus_DX4250
+#gptofoo escp2-dx4400 printer/Epson-Stylus_DX4400
+#gptofoo escp2-dx4450 printer/Epson-Stylus_DX4450
#gptofoo escp2-dx4800 printer/Epson-Stylus_DX4800
+#gptofoo escp2-dx7000f printer/Epson-Stylus_DX7000F
+#gptofoo escp2-dx7400 printer/Epson-Stylus_DX7400
+#gptofoo escp2-dx7450 printer/Epson-Stylus_DX7450
+#gptofoo escp2-dx8400 printer/Epson-Stylus_DX8400
+#gptofoo escp2-dx8450 printer/Epson-Stylus_DX8450
#gptofoo escp2-photo printer/Epson-Stylus_Photo
#gptofoo escp2-1200 printer/Epson-Stylus_Photo_1200
#gptofoo escp2-1270 printer/Epson-Stylus_Photo_1270
@@ -405,6 +427,8 @@
#gptofoo escp2-r260 printer/Epson-Stylus_Photo_R260
#gptofoo escp2-r265 printer/Epson-Stylus_Photo_R265
#gptofoo escp2-r270 printer/Epson-Stylus_Photo_R270
+#gptofoo escp2-r280 printer/Epson-Stylus_Photo_R280
+#gptofoo escp2-r285 printer/Epson-Stylus_Photo_R285
#gptofoo escp2-r300 printer/Epson-Stylus_Photo_R300
#gptofoo escp2-r310 printer/Epson-Stylus_Photo_R310
#gptofoo escp2-r320 printer/Epson-Stylus_Photo_R320
@@ -422,12 +446,15 @@
#gptofoo escp2-rx510 printer/Epson-Stylus_Photo_RX510
#gptofoo escp2-rx560 printer/Epson-Stylus_Photo_RX560
#gptofoo escp2-rx580 printer/Epson-Stylus_Photo_RX580
+#gptofoo escp2-rx585 printer/Epson-Stylus_Photo_RX585
#gptofoo escp2-rx590 printer/Epson-Stylus_Photo_RX590
#gptofoo escp2-rx595 printer/Epson-Stylus_Photo_RX595
#gptofoo escp2-rx600 printer/Epson-Stylus_Photo_RX600
#gptofoo escp2-rx620 printer/Epson-Stylus_Photo_RX620
#gptofoo escp2-rx630 printer/Epson-Stylus_Photo_RX630
#gptofoo escp2-rx640 printer/Epson-Stylus_Photo_RX640
+#gptofoo escp2-rx680 printer/Epson-Stylus_Photo_RX680
+#gptofoo escp2-rx685 printer/Epson-Stylus_Photo_RX685
#gptofoo escp2-rx700 printer/Epson-Stylus_Photo_RX700
#gptofoo escp2-10000 printer/Epson-Stylus_Pro_10000
#gptofoo escp2-5000 printer/Epson-Stylus_Pro_5000
@@ -453,6 +480,11 @@
#gptofoo pcl-g_5c printer/Generic-PCL_5c_Printer
#gptofoo pcl-g_5e printer/Generic-PCL_5e_Printer
#gptofoo pcl-g_6 printer/Generic-PCL_6_PCL_XL_Printer
+#gptofoo pcl-g_4_l printer/Generic-PCL_4_LF_Printer
+#gptofoo pcl-g_5_l printer/Generic-PCL_5_LF_Printer
+#gptofoo pcl-g_5c_l printer/Generic-PCL_5c_LF_Printer
+#gptofoo pcl-g_5e_l printer/Generic-PCL_5e_LF_Printer
+#gptofoo pcl-g_6_l printer/Generic-PCL_6_PCL_XL_LF_Printer
#gptofoo pcl-2000 printer/HP-2000C
#gptofoo pcl-2500 printer/HP-2500C
#gptofoo hp-2500cm printer/HP-2500CM
diff --git a/src/foomatic/gutenprint-version.c b/src/foomatic/gutenprint-version.c
index 16c248a..d9910b2 100644
--- a/src/foomatic/gutenprint-version.c
+++ b/src/foomatic/gutenprint-version.c
@@ -1,5 +1,5 @@
/*
- * "$Id: gutenprint-version.c,v 1.2.18.1 2007/03/04 23:57:48 tillkamppeter Exp $"
+ * "$Id: gutenprint-version.c,v 1.3 2007/03/05 00:04:00 tillkamppeter Exp $"
*
* Dump the per-printer options for the OpenPrinting database
*
diff --git a/src/foomatic/paper_sizes.c b/src/foomatic/paper_sizes.c
index 7b12fe1..26f4f02 100644
--- a/src/foomatic/paper_sizes.c
+++ b/src/foomatic/paper_sizes.c
@@ -1,5 +1,5 @@
/*
- * "$Id: paper_sizes.c,v 1.8.18.1 2007/03/04 23:57:48 tillkamppeter Exp $"
+ * "$Id: paper_sizes.c,v 1.9 2007/03/05 00:04:00 tillkamppeter Exp $"
*
* Dump the per-printer options for the OpenPrinting database
*
diff --git a/src/foomatic/printer_margins.c b/src/foomatic/printer_margins.c
index 11c50ad..66af0d8 100644
--- a/src/foomatic/printer_margins.c
+++ b/src/foomatic/printer_margins.c
@@ -1,5 +1,5 @@
/*
- * "$Id: printer_margins.c,v 1.17.8.2 2007/05/29 01:47:27 rlk Exp $"
+ * "$Id: printer_margins.c,v 1.21 2007/05/06 19:38:10 rlk Exp $"
*
* Dump the per-printer margins for the OpenPrinting database
*
diff --git a/src/foomatic/printer_options.c b/src/foomatic/printer_options.c
index 6848354..a5b4c45 100644
--- a/src/foomatic/printer_options.c
+++ b/src/foomatic/printer_options.c
@@ -1,5 +1,5 @@
/*
- * "$Id: printer_options.c,v 1.50.8.2 2007/05/29 01:47:27 rlk Exp $"
+ * "$Id: printer_options.c,v 1.52 2007/05/06 19:38:10 rlk Exp $"
*
* Dump the per-printer options for the OpenPrinting database
*
diff --git a/src/foomatic/printers.c b/src/foomatic/printers.c
index 9eb34ce..24643e7 100644
--- a/src/foomatic/printers.c
+++ b/src/foomatic/printers.c
@@ -1,5 +1,5 @@
/*
- * "$Id: printers.c,v 1.10.18.1 2007/03/04 23:57:48 tillkamppeter Exp $"
+ * "$Id: printers.c,v 1.11 2007/03/05 00:04:00 tillkamppeter Exp $"
*
* Dump the per-printer options for the OpenPrinting database
*