summaryrefslogtreecommitdiff
path: root/src/gimp2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gimp2/Makefile.am')
-rw-r--r--src/gimp2/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/gimp2/Makefile.am b/src/gimp2/Makefile.am
new file mode 100644
index 0000000..49f45fa
--- /dev/null
+++ b/src/gimp2/Makefile.am
@@ -0,0 +1,52 @@
+## $Id: Makefile.am,v 1.5 2004/12/29 19:09:55 rlk Exp $
+## Copyright (C) 2000 Roger Leigh
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.4 gnu
+
+@SET_MAKE@
+
+MAINT_CHARSET = latin1
+
+include $(top_srcdir)/scripts/global.mk
+
+
+## Variables
+
+LOCAL_CPPFLAGS = $(GUTENPRINT_CFLAGS) $(GIMP2_CFLAGS)
+
+
+## Programs
+
+if BUILD_GIMP2
+gimp2_plug_in_PROGRAMS = print
+endif
+
+print_SOURCES = \
+ print-image-gimp.c \
+ print-intl.h \
+ print.c \
+ print_gimp.h
+
+print_LDADD = $(GIMP2_LIBS) $(GUTENPRINTUI2_LIBS)
+print_DEPENDENCIES = $(GUTENPRINTUI2_LIBS) $(GUTENPRINT_LIBS)
+
+
+## Clean
+
+MAINTAINERCLEANFILES = Makefile.in