summaryrefslogtreecommitdiff
path: root/src/xml/papers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/papers/Makefile.am')
-rw-r--r--src/xml/papers/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/xml/papers/Makefile.am b/src/xml/papers/Makefile.am
new file mode 100644
index 0000000..fb3c562
--- /dev/null
+++ b/src/xml/papers/Makefile.am
@@ -0,0 +1,42 @@
+## Copyright (C) 2017 Robert Krawitz
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+@SET_MAKE@
+
+include $(top_srcdir)/scripts/global.mk
+
+## Variables
+
+pkgxmldatadir = $(pkgdatadir)/@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@/xml/papers
+
+pkgxmldata_DATA = \
+ standard.xml \
+ labels.xml
+
+
+xml-stamp: $(pkgxmldata_DATA) Makefile.am
+ -rm -f $@ $@.tmp
+ touch $@.tmp
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> $@.tmp; done
+ mv $@.tmp $@
+
+all-local: xml-stamp
+
+dist-hook: xml-stamp
+CLEANFILES = xmli18n-tmp.h xml-stamp xml-stamp.tmp
+
+EXTRA_DIST = $(pkgxmldata_DATA)