summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2013-11-29 18:10:43 +0100
committerDidier Raboud <odyx@debian.org>2018-02-26 20:23:12 +0100
commitda18bab1c6c1bc3cae4a1e3f83c4044a36b60cdc (patch)
tree28aa465bdf65cb9c03cb56a209183d3c1ce5846d
parent73ec78d75b4a803e56ed910f32639f94dc30a1e0 (diff)
Import Debian version 2
hannah-foo2zjs (1:2) unstable; urgency=low [ Didier Raboud ] * Orphan properly: set Maintainer to the QA group * Replace dependency against foo2zjs to printer-driver-foo2zjs as the former was transitional in latest stable [ Pino Toscano ] * Allow kde-runtime as alternative to kdebase-runtime (Closes: #666683) [ Ronny Standtke ] * Update desktop file (Closes: #631389)
-rw-r--r--Makefile52
-rw-r--r--debian/changelog16
-rw-r--r--debian/control4
-rw-r--r--hannah.desktop7
4 files changed, 58 insertions, 21 deletions
diff --git a/Makefile b/Makefile
index 5027f0e..0921e27 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
#############################################################################
# Makefile for building: hannah
-# Generated by qmake (2.01a) (Qt 4.5.2) on: Mi. Aug 19 20:56:33 2009
+# Generated by qmake (2.01a) (Qt 4.8.6) on: Fri Nov 29 17:25:27 2013
# Project: hannah.pro
# Template: app
# Command: /usr/bin/qmake-qt4 -unix -o Makefile hannah.pro
@@ -11,12 +11,12 @@
CC = gcc
CXX = g++
DEFINES = -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED
-CFLAGS = -pipe -O2 -Wall -W -D_REENTRANT $(DEFINES)
-CXXFLAGS = -pipe -O2 -Wall -W -D_REENTRANT $(DEFINES)
-INCPATH = -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I. -I.
+CFLAGS = -m64 -pipe -O2 -Wall -W -D_REENTRANT $(DEFINES)
+CXXFLAGS = -m64 -pipe -O2 -Wall -W -D_REENTRANT $(DEFINES)
+INCPATH = -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I. -I.
LINK = g++
-LFLAGS = -Wl,-O1
-LIBS = $(SUBLIBS) -L/usr/lib -lQtGui -lQtCore -lpthread
+LFLAGS = -m64 -Wl,-O1
+LIBS = $(SUBLIBS) -L/usr/lib/x86_64-linux-gnu -lQtGui -lQtCore -lpthread
AR = ar cqs
RANLIB =
QMAKE = /usr/bin/qmake-qt4
@@ -26,11 +26,12 @@ COPY = cp -f
SED = sed
COPY_FILE = $(COPY)
COPY_DIR = $(COPY) -r
+STRIP = strip
INSTALL_FILE = install -m 644 -p
INSTALL_DIR = $(COPY_DIR)
INSTALL_PROGRAM = install -m 755 -p
DEL_FILE = rm -f
-SYMLINK = ln -sf
+SYMLINK = ln -f -s
DEL_DIR = rmdir
MOVE = mv -f
CHK_DIR_EXISTS= test -d
@@ -47,9 +48,12 @@ SOURCES = gui.cpp \
OBJECTS = gui.o \
main.o \
moc_gui.o
-DIST = /usr/share/qt4/mkspecs/common/g++.conf \
- /usr/share/qt4/mkspecs/common/unix.conf \
+DIST = /usr/share/qt4/mkspecs/common/unix.conf \
/usr/share/qt4/mkspecs/common/linux.conf \
+ /usr/share/qt4/mkspecs/common/gcc-base.conf \
+ /usr/share/qt4/mkspecs/common/gcc-base-unix.conf \
+ /usr/share/qt4/mkspecs/common/g++-base.conf \
+ /usr/share/qt4/mkspecs/common/g++-unix.conf \
/usr/share/qt4/mkspecs/qconfig.pri \
/usr/share/qt4/mkspecs/features/qt_functions.prf \
/usr/share/qt4/mkspecs/features/qt_config.prf \
@@ -57,6 +61,8 @@ DIST = /usr/share/qt4/mkspecs/common/g++.conf \
/usr/share/qt4/mkspecs/features/default_pre.prf \
/usr/share/qt4/mkspecs/features/release.prf \
/usr/share/qt4/mkspecs/features/default_post.prf \
+ /usr/share/qt4/mkspecs/features/shared.prf \
+ /usr/share/qt4/mkspecs/features/unix/gdb_dwarf_index.prf \
/usr/share/qt4/mkspecs/features/warn_on.prf \
/usr/share/qt4/mkspecs/features/qt.prf \
/usr/share/qt4/mkspecs/features/unix/thread.prf \
@@ -98,9 +104,12 @@ all: Makefile $(TARGET)
$(TARGET): $(OBJECTS)
$(LINK) $(LFLAGS) -o $(TARGET) $(OBJECTS) $(OBJCOMP) $(LIBS)
-Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++/qmake.conf /usr/share/qt4/mkspecs/common/g++.conf \
- /usr/share/qt4/mkspecs/common/unix.conf \
+Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++-64/qmake.conf /usr/share/qt4/mkspecs/common/unix.conf \
/usr/share/qt4/mkspecs/common/linux.conf \
+ /usr/share/qt4/mkspecs/common/gcc-base.conf \
+ /usr/share/qt4/mkspecs/common/gcc-base-unix.conf \
+ /usr/share/qt4/mkspecs/common/g++-base.conf \
+ /usr/share/qt4/mkspecs/common/g++-unix.conf \
/usr/share/qt4/mkspecs/qconfig.pri \
/usr/share/qt4/mkspecs/features/qt_functions.prf \
/usr/share/qt4/mkspecs/features/qt_config.prf \
@@ -108,6 +117,8 @@ Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++/qmake.conf /usr/share/qt4
/usr/share/qt4/mkspecs/features/default_pre.prf \
/usr/share/qt4/mkspecs/features/release.prf \
/usr/share/qt4/mkspecs/features/default_post.prf \
+ /usr/share/qt4/mkspecs/features/shared.prf \
+ /usr/share/qt4/mkspecs/features/unix/gdb_dwarf_index.prf \
/usr/share/qt4/mkspecs/features/warn_on.prf \
/usr/share/qt4/mkspecs/features/qt.prf \
/usr/share/qt4/mkspecs/features/unix/thread.prf \
@@ -117,12 +128,15 @@ Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++/qmake.conf /usr/share/qt4
/usr/share/qt4/mkspecs/features/yacc.prf \
/usr/share/qt4/mkspecs/features/lex.prf \
/usr/share/qt4/mkspecs/features/include_source_dir.prf \
- /usr/lib/libQtGui.prl \
- /usr/lib/libQtCore.prl
+ /usr/lib/x86_64-linux-gnu/libQtGui.prl \
+ /usr/lib/x86_64-linux-gnu/libQtCore.prl
$(QMAKE) -unix -o Makefile hannah.pro
-/usr/share/qt4/mkspecs/common/g++.conf:
/usr/share/qt4/mkspecs/common/unix.conf:
/usr/share/qt4/mkspecs/common/linux.conf:
+/usr/share/qt4/mkspecs/common/gcc-base.conf:
+/usr/share/qt4/mkspecs/common/gcc-base-unix.conf:
+/usr/share/qt4/mkspecs/common/g++-base.conf:
+/usr/share/qt4/mkspecs/common/g++-unix.conf:
/usr/share/qt4/mkspecs/qconfig.pri:
/usr/share/qt4/mkspecs/features/qt_functions.prf:
/usr/share/qt4/mkspecs/features/qt_config.prf:
@@ -130,6 +144,8 @@ Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++/qmake.conf /usr/share/qt4
/usr/share/qt4/mkspecs/features/default_pre.prf:
/usr/share/qt4/mkspecs/features/release.prf:
/usr/share/qt4/mkspecs/features/default_post.prf:
+/usr/share/qt4/mkspecs/features/shared.prf:
+/usr/share/qt4/mkspecs/features/unix/gdb_dwarf_index.prf:
/usr/share/qt4/mkspecs/features/warn_on.prf:
/usr/share/qt4/mkspecs/features/qt.prf:
/usr/share/qt4/mkspecs/features/unix/thread.prf:
@@ -139,8 +155,8 @@ Makefile: hannah.pro /usr/share/qt4/mkspecs/linux-g++/qmake.conf /usr/share/qt4
/usr/share/qt4/mkspecs/features/yacc.prf:
/usr/share/qt4/mkspecs/features/lex.prf:
/usr/share/qt4/mkspecs/features/include_source_dir.prf:
-/usr/lib/libQtGui.prl:
-/usr/lib/libQtCore.prl:
+/usr/lib/x86_64-linux-gnu/libQtGui.prl:
+/usr/lib/x86_64-linux-gnu/libQtCore.prl:
qmake: FORCE
@$(QMAKE) -unix -o Makefile hannah.pro
@@ -161,6 +177,8 @@ distclean: clean
-$(DEL_FILE) Makefile
+check: first
+
mocclean: compiler_moc_header_clean compiler_moc_source_clean
mocables: compiler_moc_header_make_all compiler_moc_source_make_all
@@ -169,7 +187,7 @@ compiler_moc_header_make_all: moc_gui.cpp
compiler_moc_header_clean:
-$(DEL_FILE) moc_gui.cpp
moc_gui.cpp: gui.h
- /usr/bin/moc-qt4 $(DEFINES) $(INCPATH) gui.h -o moc_gui.cpp
+ /usr/lib/x86_64-linux-gnu/qt4/bin/moc $(DEFINES) $(INCPATH) gui.h -o moc_gui.cpp
compiler_rcc_make_all:
compiler_rcc_clean:
diff --git a/debian/changelog b/debian/changelog
index 5fe50ee..7cc6fd5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+hannah-foo2zjs (1:2) unstable; urgency=low
+
+ [ Didier Raboud ]
+ * Orphan properly: set Maintainer to the QA group
+ * Replace dependency against foo2zjs to printer-driver-foo2zjs as the
+ former was transitional in latest stable
+
+ [ Pino Toscano ]
+ * Allow kde-runtime as alternative to kdebase-runtime
+ (Closes: #666683)
+
+ [ Ronny Standtke ]
+ * Update desktop file (Closes: #631389)
+
+ -- Didier Raboud <odyx@debian.org> Fri, 29 Nov 2013 18:10:43 +0100
+
hannah-foo2zjs (1:1) unstable; urgency=low
* Initial release. Separated out from foo2zjs package.
diff --git a/debian/control b/debian/control
index 5ef90ee..6481de6 100644
--- a/debian/control
+++ b/debian/control
@@ -1,13 +1,13 @@
Source: hannah-foo2zjs
Section: contrib/text
Priority: optional
-Maintainer: Michael Koch <konqueror@gmx.de>
+Maintainer: Debian QA Group <packages@qa.debian.org>
Build-Depends: debhelper (>= 7), libqt4-dev
Standards-Version: 3.8.2
Package: hannah-foo2zjs
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, foo2zjs, gksu | kdebase-bin (<< 4:4.4.0-1) | kdebase-runtime | ktsuss | sux
+Depends: ${shlibs:Depends}, ${misc:Depends}, printer-driver-foo2zjs, gksu | kdebase-bin (<< 4:4.4.0-1) | kde-runtime | kdebase-runtime | ktsuss | sux
Conflicts: foo2zjs (<= 20090301dfsg-4)
Replaces: foo2zjs (<= 20090301dfsg-4)
Description: Graphical firmware downloader for the foo2zjs package
diff --git a/hannah.desktop b/hannah.desktop
index 859d80d..47c2aff 100644
--- a/hannah.desktop
+++ b/hannah.desktop
@@ -1,7 +1,10 @@
[Desktop Entry]
-Name=Foo2ZJS Firmware Installer (Hannah)
+Name=Hannah
+GenericName=Printer Firmware Installer
+GenericName[de]=Drucker-Firmware-Installation
+Comment=Foo2ZJS Firmware Downloader and Installer
Exec=/usr/bin/su-to-root -X -c /usr/bin/hannah-foo2zjs
+Icon=printer
Type=Application
-Comment=Foo2ZJS Firmware Downloader and Installer
Terminal=0
Categories=System;Settings;