summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorPeter Becich <peterbecich@gmail.com>2020-09-09 22:33:25 -0700
committerPeter Becich <peterbecich@gmail.com>2020-09-09 22:33:25 -0700
commit2a02159b0ff6ccb99ffac43e58dbe250c99ee152 (patch)
tree356f9de813f2b1e706d2527f8e94ea3d07021b56 /.travis.yml
parente23039c485e85fa58f35dce0c9f740d235effe06 (diff)
Travis CI sandboxed build
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml4
1 files changed, 4 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index c7793bf9..87ccad22 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,4 +1,5 @@
# https://github.com/purcell/nix-emacs-ci
+# https://nixos.wiki/wiki/Nix_on_Travis
language: nix
cache:
@@ -41,6 +42,9 @@ before_cache:
- mkdir -p $HOME/nix.store
- nix copy --to file://$HOME/nix.store -f default.nix buildInputs
+before_script:
+ - sudo mkdir -p /etc/nix && echo 'sandbox = true' | sudo tee /etc/nix/nix.conf
+
install:
# The default "emacs" executable on the $PATH will now be the version named by $EMACS_CI
- bash <(curl https://raw.githubusercontent.com/purcell/nix-emacs-ci/master/travis-install)