summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Volpiatto <thierry.volpiatto@gmail.com>2018-02-26 10:01:11 +0100
committerThierry Volpiatto <thierry.volpiatto@gmail.com>2018-02-26 10:01:11 +0100
commit9a3e7de1009a5d460fce886ca54662ccbcdb7c88 (patch)
treedd198811e42d005fc300370abb8892d20e577c59
parenta5e9a7b7277ecc30fba608a711ac55925e860453 (diff)
Add make install/uninstall
* Makefile: Do it.
-rw-r--r--Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 24872e9c..63fd6d86 100644
--- a/Makefile
+++ b/Makefile
@@ -72,3 +72,18 @@ clean:
autoloads:
$(EVAL) "(let ((generated-autoload-file (expand-file-name \"helm-autoloads.el\" \"$(PKGDIR)\")) \
(backup-inhibited t)) (update-directory-autoloads \"$(PKGDIR)\"))"
+
+PREFIX=/usr/local/
+BIN=${PREFIX}bin/
+DESTDIR=${PREFIX}share/emacs/site-lisp/helm/
+install:
+ test -d ${DESTDIR} || mkdir ${DESTDIR}
+ cp -vf *.elc $(DESTDIR)
+ cp -vf helm-autoloads.el $(DESTDIR)
+ cp -vf emacs-helm.sh $(DESTDIR)
+ ln -s ${DESTDIR}emacs-helm.sh ${BIN}helm
+uninstall:
+ rm -vf ${DESTDIR}*.elc
+ rm -vf ${DESTDIR}*.el
+ rm -vf ${DESTDIR}emacs-helm.sh
+ rm -vf ${BIN}helm