summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThierry Volpiatto <thievol@posteo.net>2021-09-08 08:27:47 +0200
committerThierry Volpiatto <thievol@posteo.net>2021-09-08 08:27:47 +0200
commit1a49c09c0052da7405f93fe00c87c54c102b76af (patch)
tree2eb339e7338f848e5341c0aebc268430bd7bc598 /Makefile
parent3fe4076076eea8d244793b80a0274de0d685bd9d (diff)
Remove all the doc/info system which is not ready for now
and update Makefile accordingly.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile100
1 files changed, 2 insertions, 98 deletions
diff --git a/Makefile b/Makefile
index 9cf52b4c..accc8baf 100644
--- a/Makefile
+++ b/Makefile
@@ -66,71 +66,11 @@ EL := $(sort $(wildcard helm*.el))
# Compiled files
ELC := $(EL:.el=.elc)
-# How to make a pdf file from a texinfo file
-TEXI2PDF = texi2pdf --batch --clean --expand
-# How to make a pdf file from a tex file
-PDFTEX = pdftex
-
-# How to create directories with leading path components
-MKDIR = mkdir -m 755 -p # try this if you have no install
-# MKDIR = install -m 755 -d
-
-# How to create the info files from the texinfo file
-MAKEINFO = makeinfo
-
-# How to create the HTML file
-TEXI2HTML = makeinfo --html --number-sections --css-ref "https://www.gnu.org/software/emacs/manual.css"
-
-# Name of the program to install info files
-# INSTALL_INFO = ginstall-info # Debian: avoid harmless warning message
-INSTALL_INFO = install-info
-
-ORGFILES := doc/helm-bugs.org doc/helm-devel.org doc/helm-manual-1.org doc/helm-manual.org doc/helm.org doc/helm-classes.org
-TEXIFILES := $(ORGFILES:.org=.texi)
-INFOFILES := $(ORGFILES:.org=.info)
-HTMLFILES := $(ORGFILES:.org=.html)
-PDFFILES := $(ORGFILES:.org=.pdf)
-
-.PHONY: clean autoloads batch-compile clean-doc
+.PHONY: clean autoloads batch-compile
all: clean autoloads batch-compile
-doc: doc/ox-texinfo.el
-doc: info
-doc: html
-# doc: pdf
-
-pdf: $(PDFFILES)
-html: $(HTMLFILES)
-info: $(INFOFILES)
-texi: $(TEXIFILES)
-
-$(TEXIFILES): | doc/ox-texinfo.el
-
-doc/ox-texinfo.el:
- wget https://code.orgmode.org/bzg/org-mode/raw/maint/lisp/ox-texinfo.el -O $@
- # test -f doc/ox-texinfo.el || wget https://code.orgmode.org/bzg/org-mode/raw/maint/lisp/ox-texinfo.el -O $@
-
-%.texi: doc/ox-texinfo.el
-
-%.texi: %.org
- $(EMACS) $(LOADPATH) -l doc/ox-texinfo.el -l doc/ox-texinfo+.el --file=$< --eval '(org-texinfo-export-to-texinfo+)'
-
-%.info: %.texi
- $(MAKEINFO) --no-split $< -o $@
-
-# the following two lines work around a bug in some versions of texi2dvi
-%.pdf: LC_ALL=C
-%.pdf: LANG=C
-%.pdf: %.texi
- $(TEXI2PDF) $<
-%.pdf: %.tex
- PDFLATEX=$(PDFTEX) $(TEXI2PDF) $<
-
-%.html: %.texi
- $(TEXI2HTML) --no-split -o $@ $<
-
$(ELC): %.elc: %.el
$(EMACS) $(LOADPATH) -f batch-byte-compile $<
@@ -142,11 +82,7 @@ batch-compile:
$(EMACS) $(LOADPATH) -f batch-byte-compile $(EL)
# Remove all generated files
-clean-doc:
- rm -f doc/ox-texinfo.el $(TEXIFILES) $(INFOFILES) $(HTMLFILES) $(PDFFILES)
-
-clean : clean-doc
-clean: clean-doc
+clean:
rm -f $(ELC)
# Make autoloads file
@@ -157,20 +93,6 @@ autoloads:
PREFIX=/usr/local/
BIN=${PREFIX}bin/
DESTDIR=${PREFIX}share/emacs/site-lisp/helm/
-
-# On Debian, paths in `Info-default-directory-list' are in the order
-# as below:
-
-# INFODIR = /usr/local/share/info
-# INFODIR = /usr/local/info
-INFODIR = /usr/share/info
-# INFODIR = /usr/local/share/info
-
-# /usr/share/info is where Debian puts the info file for EMMS. So,
-# just mimic it.
-
-# For non-standard value of INFODIR, see `Info-directory-list'.
-
install:
test -d ${DESTDIR} || mkdir ${DESTDIR}
rm -f ${DESTDIR}*.el
@@ -185,21 +107,3 @@ uninstall:
rm -vf ${DESTDIR}*.el
rm -vf ${DESTDIR}emacs-helm.sh
rm -vf ${BIN}helm
-
-$(DESTDIR)$(infodir)/%.info: doc/%.info
-
-install-info: $(INFOFILES)
- if [ ! -d $(INFODIR) ]; then $(MKDIR) $(INFODIR); else true; fi ;
- if [ ! -d $(INFODIR)/helm-figures ]; then $(MKDIR) $(INFODIR)/helm-figures; else true; fi ;
- cp -r doc/helm-figures $(INFODIR);
- for f in $(INFOFILES:doc/%=%) ; do \
- cp doc/$$f $(INFODIR); \
- $(INSTALL_INFO) --info-dir=$(INFODIR) $(INFODIR)/$$f; \
- done
-
-clean-install-info:
- $(RM) -r $(INFODIR)/helm-figures;
- for f in $(INFOFILES:doc/%=%) ; do \
- $(INSTALL_INFO) --remove --info-dir=$(INFODIR) --remove $(INFODIR)/$$f; \
- $(RM) $(INFODIR)/$$f; \
- done