summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRamesh Nedunchezian <rameshnedunchezian@outlook.com>2021-05-01 12:55:58 +0530
committerRamesh Nedunchezian <rameshnedunchezian@outlook.com>2021-05-01 20:12:16 +0530
commit7be071e511bb46f4e4e6b03173f206d4d8790ccb (patch)
tree660e59d8f0c464a6ccb499539c7f1299d78ebad6 /Makefile
parent68b8676dc7f91a81a0512c4c344f4e7b5bab5563 (diff)
* doc/helm-classes.org: Include class diagrams
* Makefile: Install figures in INFODIR
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1e86fd33..9cf52b4c 100644
--- a/Makefile
+++ b/Makefile
@@ -109,7 +109,8 @@ texi: $(TEXIFILES)
$(TEXIFILES): | doc/ox-texinfo.el
doc/ox-texinfo.el:
- wget https://code.orgmode.org/bzg/org-mode/raw/maint/lisp/ox-texinfo.el -O $@
+ wget https://code.orgmode.org/bzg/org-mode/raw/maint/lisp/ox-texinfo.el -O $@
+ # test -f doc/ox-texinfo.el || wget https://code.orgmode.org/bzg/org-mode/raw/maint/lisp/ox-texinfo.el -O $@
%.texi: doc/ox-texinfo.el
@@ -189,12 +190,15 @@ $(DESTDIR)$(infodir)/%.info: doc/%.info
install-info: $(INFOFILES)
if [ ! -d $(INFODIR) ]; then $(MKDIR) $(INFODIR); else true; fi ;
+ if [ ! -d $(INFODIR)/helm-figures ]; then $(MKDIR) $(INFODIR)/helm-figures; else true; fi ;
+ cp -r doc/helm-figures $(INFODIR);
for f in $(INFOFILES:doc/%=%) ; do \
cp doc/$$f $(INFODIR); \
$(INSTALL_INFO) --info-dir=$(INFODIR) $(INFODIR)/$$f; \
done
clean-install-info:
+ $(RM) -r $(INFODIR)/helm-figures;
for f in $(INFOFILES:doc/%=%) ; do \
$(INSTALL_INFO) --remove --info-dir=$(INFODIR) --remove $(INFODIR)/$$f; \
$(RM) $(INFODIR)/$$f; \