summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2021-12-27 12:42:34 -0700
committerSean Whitton <spwhitton@spwhitton.name>2021-12-27 12:51:09 -0700
commit9fa3764bd17f6b0ba557488ef386b9011ed1cbd8 (patch)
treeced7fe24ca2f976a580a3f60717ce850523ad329 /debian
parent7f211d9b31340d160f10beb30bc3f31fc359663d (diff)
build and install new info and html docs
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control7
-rw-r--r--debian/elpa-helm.docs2
-rw-r--r--debian/elpa-helm.links1
-rwxr-xr-xdebian/rules4
5 files changed, 18 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index b67bf278..e48f11b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,13 @@
helm (3.8.0-1) UNRELEASED; urgency=medium
* Update to new upstream version 3.8.0.
+ * Patch new docs build in Makefile for Debian.
+ * Build and install new HTML and info docs.
+ - Add d/elpa-helm.links.
+ - Drop d/elpa-helm.docs.
+ - Build the docs in override_dh_auto_build.
+ - Install the docs in override_dh_auto_install.
+ - Add build-deps on elpa-org >= 9.5.2, elpa-ox-texinfo+ and texinfo.
-- Sean Whitton <spwhitton@spwhitton.name> Sat, 18 Dec 2021 16:09:12 -0700
diff --git a/debian/control b/debian/control
index 37d533c3..54cc41a8 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,12 @@ Section: lisp
Priority: optional
Maintainer: Debian Emacsen team <debian-emacsen@lists.debian.org>
Uploaders: Sean Whitton <spwhitton@spwhitton.name>
-Build-Depends: debhelper (>= 10), dh-elpa (>= 0.0.18)
+Build-Depends:
+ debhelper (>= 10),
+ dh-elpa (>= 0.0.18),
+ elpa-org (>= 9.5.2),
+ elpa-ox-texinfo+,
+ texinfo,
Standards-Version: 4.1.1
Homepage: https://emacs-helm.github.io/helm/
Vcs-Git: https://salsa.debian.org/emacsen-team/helm.git/
diff --git a/debian/elpa-helm.docs b/debian/elpa-helm.docs
deleted file mode 100644
index f8767e13..00000000
--- a/debian/elpa-helm.docs
+++ /dev/null
@@ -1,2 +0,0 @@
-README.md
-images/helm-grep-ag-persistent.png
diff --git a/debian/elpa-helm.links b/debian/elpa-helm.links
new file mode 100644
index 00000000..e14db22b
--- /dev/null
+++ b/debian/elpa-helm.links
@@ -0,0 +1 @@
+/usr/share/doc/elpa-helm/html /usr/share/info/helm-figures
diff --git a/debian/rules b/debian/rules
index ca47f8c9..b6453321 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,5 +4,9 @@
dh $@ --with elpa
override_dh_auto_build:
+ make doc
override_dh_auto_install:
+ mkdir -p debian/elpa-helm/usr/share/doc/elpa-helm/html
+ cp doc/*.html doc/helm-figures/*.png \
+ debian/elpa-helm/usr/share/doc/elpa-helm/html