summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2019-10-14 00:35:15 +0200
committerChristoph Egger <christoph@debian.org>2019-10-14 00:36:52 +0200
commitb153a366dd9c4b648db6416856616bc4ff539f04 (patch)
treec20003c196b22045d010f7bf64ea1b0c289383a7
parent974a9c839e3bd99d5a0d71d92b624b06c444473c (diff)
Make things even more reproducible
-rw-r--r--Makefile4
-rw-r--r--debian/patches/reproducible.diff14
2 files changed, 16 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index bbe7fd8b..6ce12651 100644
--- a/Makefile
+++ b/Makefile
@@ -2,11 +2,11 @@ include version.mk
include config.mk
include colors.mk
-HLWMSRC = $(wildcard src/*.cpp)
+HLWMSRC = $(sort $(wildcard src/*.cpp))
HLWMOBJ = $(HLWMSRC:.cpp=.o)
HLWMTARGET = herbstluftwm
-HCSRC = $(wildcard ipc-client/*.c)
+HCSRC = $(sort $(wildcard ipc-client/*.c))
HCOBJ = $(HCSRC:.c=.o)
HCTARGET = herbstclient
diff --git a/debian/patches/reproducible.diff b/debian/patches/reproducible.diff
index ed0d34e2..8779be6c 100644
--- a/debian/patches/reproducible.diff
+++ b/debian/patches/reproducible.diff
@@ -1,5 +1,19 @@
--- a/Makefile
+++ b/Makefile
+@@ -2,11 +2,11 @@ include version.mk
+ include config.mk
+ include colors.mk
+
+-HLWMSRC = $(wildcard src/*.cpp)
++HLWMSRC = $(sort $(wildcard src/*.cpp))
+ HLWMOBJ = $(HLWMSRC:.cpp=.o)
+ HLWMTARGET = herbstluftwm
+
+-HCSRC = $(wildcard ipc-client/*.c)
++HCSRC = $(sort $(wildcard ipc-client/*.c))
+ HCOBJ = $(HCSRC:.c=.o)
+ HCTARGET = herbstclient
+
@@ -18,6 +18,15 @@
HERBSTLUFTWMDOC = doc/herbstluftwm.txt
TUTORIAL = doc/herbstluftwm-tutorial.txt