summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2020-04-10 12:48:37 +0200
committerChristoph Egger <christoph@debian.org>2020-04-10 12:48:37 +0200
commitc065f3e65d5aac3683ca4e43f3f8ea7e802b3d88 (patch)
tree7082b61b3e5056a024c26625be4ecc6c32c6ba93
parent349997b3399ea8166e355c295bcfa0649107b3cd (diff)
Import upstream patches to fix 32-bit buildsdebian/0.8.0-2
* Import upstream patches to fix 32-bit builds * Fix build reproducibility
-rw-r--r--debian/changelog7
-rw-r--r--debian/control19
-rw-r--r--debian/patches/reproducible.diff74
-rw-r--r--debian/patches/series4
-rwxr-xr-xdebian/rules6
5 files changed, 41 insertions, 69 deletions
diff --git a/debian/changelog b/debian/changelog
index 294dbeca..f549e8ae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+herbstluftwm (0.8.0-2) unstable; urgency=medium
+
+ * Import upstream patches to fix 32-bit builds
+ * Fix build reproducibility
+
+ -- Christoph Egger <christoph@debian.org> Fri, 10 Apr 2020 12:48:21 +0200
+
herbstluftwm (0.8.0-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 86474372..de5ce825 100644
--- a/debian/control
+++ b/debian/control
@@ -3,16 +3,25 @@ Section: x11
Priority: optional
Maintainer: Christoph Egger <christoph@debian.org>
Build-Depends:
+ asciidoc,
cmake,
debhelper (>= 12~),
+ docbook-xml,
+ docbook-xsl,
libx11-dev,
- libxrandr-dev,
libxinerama-dev,
- asciidoc,
libxml2-utils,
- docbook-xml,
- docbook-xsl,
- xsltproc
+ libxrandr-dev,
+# python3,
+# python3-ewmh,
+# python3-pytest,
+# python3-pytest-xdist,
+# python3-pytest-xvfb,
+# python3-xlib,
+# tox,
+ xsltproc,
+# x11-utils,
+# xterm
Standards-Version: 4.1.4
Homepage: https://herbstluftwm.org
Vcs-Git: https://salsa.debian.org/debian/herbstluftwm.git
diff --git a/debian/patches/reproducible.diff b/debian/patches/reproducible.diff
index 8779be6c..471ab051 100644
--- a/debian/patches/reproducible.diff
+++ b/debian/patches/reproducible.diff
@@ -1,63 +1,11 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,11 +2,11 @@ include version.mk
- include config.mk
- include colors.mk
-
--HLWMSRC = $(wildcard src/*.cpp)
-+HLWMSRC = $(sort $(wildcard src/*.cpp))
- HLWMOBJ = $(HLWMSRC:.cpp=.o)
- HLWMTARGET = herbstluftwm
-
--HCSRC = $(wildcard ipc-client/*.c)
-+HCSRC = $(sort $(wildcard ipc-client/*.c))
- HCOBJ = $(HCSRC:.c=.o)
- HCTARGET = herbstclient
-
-@@ -18,6 +18,15 @@
- HERBSTLUFTWMDOC = doc/herbstluftwm.txt
- TUTORIAL = doc/herbstluftwm-tutorial.txt
-
-+DATE_FMT = %Y-%m-%d
-+ifdef SOURCE_DATE_EPOCH
-+ BUILD_DATE ?= $(shell date -u -d "@$(SOURCE_DATE_EPOCH)" "+$(DATE_FMT)" 2>/dev/null || date -u -r "$(SOURCE_DATE_EPOCH)" "+$(DATE_FMT)" 2>/dev/null || date -u "+$(DATE_FMT)")
-+else
-+ BUILD_DATE ?= $(shell date "+$(DATE_FMT)")
-+endif
-+
-+export CPPFLAGS += -DBUILD_DATE="\"$(BUILD_DATE)\""
-+
- .PHONY: depend all all-nodoc doc install install-nodoc info www
- .PHONY: cleandoc cleanwww cleandeps clean
-
-@@ -93,7 +102,7 @@
-
- doc/%.1 doc/%.7: doc/%.txt version.mk
- $(call colorecho,DOC,$@)
-- $(VERBOSE) $(A2X) -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=`date +%Y-%m-%d`" $<
-+ $(VERBOSE) $(A2X) -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=$(BUILD_DATE)" $<
-
- doc/%.html: doc/%.txt version.mk
- $(call colorecho,DOC,$@)
---- a/ipc-client/main.c
-+++ b/ipc-client/main.c
-@@ -17,7 +17,7 @@
- #include "client-utils.h"
-
- #define HERBSTCLIENT_VERSION_STRING \
-- "herbstclient " HERBSTLUFT_VERSION " (built on " __DATE__ ")\n"
-+ "herbstclient " HERBSTLUFT_VERSION " (built on " BUILD_DATE ")\n"
-
- void print_help(char* command, FILE* file);
- void init_hook_regex(int argc, char* argv[]);
---- a/src/globals.h
-+++ b/src/globals.h
-@@ -12,7 +12,7 @@
- #define HERBSTLUFT_AUTOSTART "herbstluftwm/autostart"
- #define WINDOW_MANAGER_NAME "herbstluftwm"
- #define HERBSTLUFT_VERSION_STRING \
-- WINDOW_MANAGER_NAME " " HERBSTLUFT_VERSION " (built on " __DATE__ ")"
-+ WINDOW_MANAGER_NAME " " HERBSTLUFT_VERSION " (built on " BUILD_DATE ")"
-
- #define HERBST_FRAME_CLASS "_HERBST_FRAME"
- #define HERBST_DECORATION_CLASS "_HERBST_DECORATION"
+--- herbstluftwm-0.8.0.orig/doc/CMakeLists.txt
++++ herbstluftwm-0.8.0/doc/CMakeLists.txt
+@@ -14,7 +14,7 @@ function(gen_manpage sourcefile man_nr)
+ COMMAND ${ASCIIDOC_A2X}
+ -f manpage
+ -a \"herbstluftwmversion=herbstluftwm ${VERSION}\"
+- -a \"date=`date +%Y-%m-%d`\"
++ -a \"date=$(BUILD_DATE)\"
+ ${src}
+ DEPENDS ${src_orig}
+ )
diff --git a/debian/patches/series b/debian/patches/series
index 6de750fc..5d7ca5d1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,3 @@
-#reproducible.diff
+reproducible.diff
+32bit-21f7280ad3cff8362c770cce02d932dce29dc1d6
+32bit-b0d3c867418cc8700cfe9d00f022809189997830
diff --git a/debian/rules b/debian/rules
index 413003b9..d3c2627f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,8 @@
#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export BUILD_DATE = $(shell dpkg-parsechangelog -SDate | date -f- +"%Y-%m-%d")
+PYTEST_VERSION = $(shell python3 -c 'import sys ; print("py" + "".join([str(i) for i in sys.version_info[:2]]))')
%:
dh $@ --buildsystem=cmake
@@ -12,5 +14,9 @@ override_dh_auto_install:
$(CURDIR)/debian/herbstluftwm/usr/share/bash-completion/completions/herbstclient-completion
-rmdir $(CURDIR)/debian/herbstluftwm/etc/bash_completion.d
+#override_dh_auto_test:
+# (cd obj-* ; tox -c .. -e py3)
+
+
override_dh_installwm:
dh_installwm --priority=20 herbstluftwm