summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorHans-Peter Deifel <hpdeifel@gmx.de>2012-05-29 23:04:35 +0200
committerThorsten Wißmann <re06huxa@stud.informatik.uni-erlangen.de>2012-06-01 09:52:52 +0200
commit3fd005d3d144e38e0c0a984bcbe0dedd1bf00e2e (patch)
treedf2c33997c98749ef95260a0ce7e22b5fa180e4b /Makefile
parent8b1e99ae8183b80ad55ef5892a9b1288d8ecdbd9 (diff)
Add make-variable to enable verbose builds
$(VERBOSE) in config.mk can now be used to enable verbose build. Verbose build will print all command invocations in addition to the colored [CC], [DOC], etc lines. This is especially useful for debugging the build-system. Add make-variable to enable verbose builds
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index c59d8346..27f930dd 100644
--- a/Makefile
+++ b/Makefile
@@ -21,13 +21,13 @@ clean: clean-herbstclient cleandoc
cleandoc:
$(call colorecho,RM,doc/herbstclient.1)
- @rm -f doc/herbstclient.1
+ $(VERBOSE) rm -f doc/herbstclient.1
$(call colorecho,RM,doc/herbstclient.html)
- @rm -f doc/herbstclient.html
+ $(VERBOSE) rm -f doc/herbstclient.html
$(call colorecho,RM,doc/herbstluftwm.1)
- @rm -f doc/herbstluftwm.1
+ $(VERBOSE) rm -f doc/herbstluftwm.1
$(call colorecho,RM,doc/herbstluftwm.html)
- @rm -f doc/herbstluftwm.html
+ $(VERBOSE) rm -f doc/herbstluftwm.html
build-herbstclient:
$(MAKE) -C ipc-client
@@ -48,11 +48,11 @@ tar: doc
doc/%.1: doc/%.txt
$(call colorecho,DOC,$@)
- @$(A2X) -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=`date +%Y-%m-%d`" $<
+ $(VERBOSE) $(A2X) -f manpage -a "herbstluftwmversion=herbstluftwm $(VERSION)" -a "date=`date +%Y-%m-%d`" $<
doc/%.html: doc/%.txt
$(call colorecho,DOC,$@)
- @$(ASCIIDOC) $<
+ $(VERBOSE) $(ASCIIDOC) $<
install: all
@echo "==> creating dirs..."