summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClemens Lang <neverpanic@gmail.com>2012-08-30 16:51:13 +0200
committerThorsten Wißmann <edu@thorsten-wissmann.de>2012-08-30 17:03:35 +0200
commit5362a2b479ca75af81f752c69e5ce201a8ed5e4e (patch)
tree95cb9dea4c70596590f67dfa58fba264e67b4147 /Makefile
parent80961936da706f340850a42f72cd9ee2c8ba65de (diff)
Separate CFLAGS and CPPFLAGS
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 72508507..5b311649 100644
--- a/Makefile
+++ b/Makefile
@@ -34,12 +34,13 @@ $(TARGETS):
%.o: %.c version.mk
$(call colorecho,CC,$<)
- $(VERBOSE) $(CC) -c $(CFLAGS) -o $@ $<
- $(VERBOSE) $(CC) -c $(CFLAGS) -o $*.d -MT $@ -MM $<
+ $(VERBOSE) $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
+ $(VERBOSE) $(CC) -c $(CPPFLAGS) -o $*.d -MT $@ -MM $<
info:
@echo Some Info:
- @echo Compiling with: $(CC) -c $(CFLAGS) -o OUT INPUT
+ @echo Preprocessing with: $(CC) -E $(CPPFLAGS)
+ @echo Compiling with: $(CC) -c $(CPPFLAGS) $(CFLAGS) -o OUT INPUT
@echo Linking with: $(LD) -o OUT $(LDFLAGS) INPUT
clean: cleandoc cleandeps