summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSimon Ruderich <simon@ruderich.org>2014-02-01 21:56:33 +0100
committerThorsten Wißmann <edu@thorsten-wissmann.de>2014-02-04 13:41:33 +0100
commitf64e7a59d7d7ad0390c1410b219cd524cf44c1bd (patch)
tree086a1c93db5c1d06cbe26359e14add5a77f77493 /Makefile
parent5e32daac8fc6fba1e2d082e6d400116447c9090f (diff)
Makefile: Use $(CFLAGS) when linking.
Required for options like -flto which compile while linking.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 82882996..1e1b4eb6 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ $(HCTARGET): $(HCOBJ)
$(TARGETS):
$(call colorecho,LD,$@)
- $(VERBOSE) $(LD) -o $@ $(LDFLAGS) $^ $(LIBS)
+ $(VERBOSE) $(LD) -o $@ $(CFLAGS) $(LDFLAGS) $^ $(LIBS)
-include $(DEPS)