summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2018-12-06 20:38:26 +0100
committerDidier Raboud <odyx@debian.org>2018-12-06 20:47:37 +0100
commitb440fdd39ddf2133d8a14e84e2e796902b707bf0 (patch)
tree8fa5fb62e2303af2e76d3083059211cca1c7b76d
parent657af56709c1723405be5e186a199888b947e05c (diff)
parent93e608212f0501ff08304da91c0caecc34bf8546 (diff)
merge patched-debian/master into debian/master
-rw-r--r--Makefile.am10
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/patches/0030-Fix-linking-of-libhpipp-and-the-ext-python-extension.patch59
-rw-r--r--debian/patches/series1
4 files changed, 67 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 8d5d78c9f..d8d8be0dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -306,7 +306,7 @@ dist_pcard_DATA = pcard/__init__.py pcard/photocard.py
# pcardext
pcardextdir = $(pyexecdir)
pcardext_LTLIBRARIES = pcardext.la
-pcardext_la_LDFLAGS = -module -avoid-version
+pcardext_la_LDFLAGS = -module -avoid-version -lpython$(PYTHON_VERSION)m
pcardext_la_SOURCES = pcard/pcardext/pcardext.c pcard/fat.c
pcardext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
@@ -321,7 +321,7 @@ lib_LTLIBRARIES += libhpipp.la
libhpipp_la_SOURCES = protocol/hp_ipp.c protocol/hp_ipp.h protocol/hp_ipp_i.h
libhpipp_la_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
libhpipp_la_LDFLAGS = -version-info 0:1:0
-libhpipp_la_LIBADD = libhpmud.la
+libhpipp_la_LIBADD = -lcups libhpmud.la
# cupsext
cupsextdir = $(pyexecdir)
@@ -329,7 +329,7 @@ cupsext_LTLIBRARIES = cupsext.la
cupsext_la_LDFLAGS = -module -avoid-version
cupsext_la_SOURCES = prnt/cupsext/cupsext.c prnt/cupsext/cupsext.h
cupsext_la_CFLAGS = -I$(PYTHONINCLUDEDIR) -Iprotocol
-cupsext_la_LIBADD = -lcups libhpipp.la
+cupsext_la_LIBADD = -lcups -lpython$(PYTHON_VERSION)m libhpipp.la
endif #HPLIP_CLASS_DRIVER
if !HPLIP_CLASS_DRIVER
@@ -341,7 +341,7 @@ dist_scan_DATA = scan/__init__.py scan/sane.py
# scanext
scanextdir = $(pyexecdir)
scanext_LTLIBRARIES = scanext.la
-scanext_la_LDFLAGS = -module -avoid-version -lsane
+scanext_la_LDFLAGS = -module -avoid-version -lsane -lpython$(PYTHON_VERSION)m
scanext_la_SOURCES = scan/scanext/scanext.c
scanext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
endif #SCAN_BUILD
@@ -351,7 +351,7 @@ endif #!HPLIP_CLASS_DRIVER
if !HPLIP_CLASS_DRIVER
hpmudextdir = $(pyexecdir)
hpmudext_LTLIBRARIES = hpmudext.la
-hpmudext_la_LDFLAGS = -module -avoid-version
+hpmudext_la_LDFLAGS = -module -avoid-version -lpython$(PYTHON_VERSION)m
hpmudext_la_SOURCES = io/mudext/hpmudext.c
hpmudext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
hpmudext_la_LIBADD = libhpmud.la
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 42d6b66c4..d7f35164b 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-b4660ea0afef42fd1c203dba41ba3d2e3d66df09
-b4660ea0afef42fd1c203dba41ba3d2e3d66df09
+93e608212f0501ff08304da91c0caecc34bf8546
+93e608212f0501ff08304da91c0caecc34bf8546
cd8d0ed87577d790ebbe7b3840aa047942c8b9d3
cd8d0ed87577d790ebbe7b3840aa047942c8b9d3
hplip_3.18.12+dfsg0.orig.tar.xz
diff --git a/debian/patches/0030-Fix-linking-of-libhpipp-and-the-ext-python-extension.patch b/debian/patches/0030-Fix-linking-of-libhpipp-and-the-ext-python-extension.patch
new file mode 100644
index 000000000..db7e02490
--- /dev/null
+++ b/debian/patches/0030-Fix-linking-of-libhpipp-and-the-ext-python-extension.patch
@@ -0,0 +1,59 @@
+From 93e608212f0501ff08304da91c0caecc34bf8546 Mon Sep 17 00:00:00 2001
+From: Didier Raboud <odyx@debian.org>
+Date: Thu, 6 Dec 2018 20:37:59 +0100
+Subject: Fix linking of libhpipp and the *ext python extensions
+
+Closes: #886391
+---
+ Makefile.am | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 8d5d78c9f..d8d8be0dd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -306,7 +306,7 @@ dist_pcard_DATA = pcard/__init__.py pcard/photocard.py
+ # pcardext
+ pcardextdir = $(pyexecdir)
+ pcardext_LTLIBRARIES = pcardext.la
+-pcardext_la_LDFLAGS = -module -avoid-version
++pcardext_la_LDFLAGS = -module -avoid-version -lpython$(PYTHON_VERSION)m
+ pcardext_la_SOURCES = pcard/pcardext/pcardext.c pcard/fat.c
+ pcardext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
+
+@@ -321,7 +321,7 @@ lib_LTLIBRARIES += libhpipp.la
+ libhpipp_la_SOURCES = protocol/hp_ipp.c protocol/hp_ipp.h protocol/hp_ipp_i.h
+ libhpipp_la_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
+ libhpipp_la_LDFLAGS = -version-info 0:1:0
+-libhpipp_la_LIBADD = libhpmud.la
++libhpipp_la_LIBADD = -lcups libhpmud.la
+
+ # cupsext
+ cupsextdir = $(pyexecdir)
+@@ -329,7 +329,7 @@ cupsext_LTLIBRARIES = cupsext.la
+ cupsext_la_LDFLAGS = -module -avoid-version
+ cupsext_la_SOURCES = prnt/cupsext/cupsext.c prnt/cupsext/cupsext.h
+ cupsext_la_CFLAGS = -I$(PYTHONINCLUDEDIR) -Iprotocol
+-cupsext_la_LIBADD = -lcups libhpipp.la
++cupsext_la_LIBADD = -lcups -lpython$(PYTHON_VERSION)m libhpipp.la
+ endif #HPLIP_CLASS_DRIVER
+
+ if !HPLIP_CLASS_DRIVER
+@@ -341,7 +341,7 @@ dist_scan_DATA = scan/__init__.py scan/sane.py
+ # scanext
+ scanextdir = $(pyexecdir)
+ scanext_LTLIBRARIES = scanext.la
+-scanext_la_LDFLAGS = -module -avoid-version -lsane
++scanext_la_LDFLAGS = -module -avoid-version -lsane -lpython$(PYTHON_VERSION)m
+ scanext_la_SOURCES = scan/scanext/scanext.c
+ scanext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
+ endif #SCAN_BUILD
+@@ -351,7 +351,7 @@ endif #!HPLIP_CLASS_DRIVER
+ if !HPLIP_CLASS_DRIVER
+ hpmudextdir = $(pyexecdir)
+ hpmudext_LTLIBRARIES = hpmudext.la
+-hpmudext_la_LDFLAGS = -module -avoid-version
++hpmudext_la_LDFLAGS = -module -avoid-version -lpython$(PYTHON_VERSION)m
+ hpmudext_la_SOURCES = io/mudext/hpmudext.c
+ hpmudext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
+ hpmudext_la_LIBADD = libhpmud.la
diff --git a/debian/patches/series b/debian/patches/series
index 0a1698eea..695d8d77c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -27,3 +27,4 @@ ui-patch-upstream-like.patch
0027-Fixed-incomplete-removal-of-hp-toolbox-features-whic.patch
0028-hp-check-Fix-core.distro-vs.-core.distro_name-mixups.patch
0029-Make-base.g.xint-more-generous-in-what-it-can-take.patch
+0030-Fix-linking-of-libhpipp-and-the-ext-python-extension.patch