summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-01-04 16:39:50 +0100
committerDidier Raboud <odyx@debian.org>2016-01-04 16:39:50 +0100
commit5155e8134d7214062cb695fe7328d045721bfdcb (patch)
tree8861b5ccec7bb8366491a8c49c9f6d4684afa46f /Makefile.am
parent713723e324bd0eaf491488948be59a22a7396491 (diff)
Imported Upstream version 0.9.10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 24 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 67364d670..5964f91d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -288,11 +288,32 @@ install-data-hook: test-destdir
if [ "$(rpm_install)" = "no" ]; then \
$(mkinstalldirs) $(DESTDIR)$(cupsdir); \
$(INSTALL_SCRIPT) $(DESTDIR)$(hpfaxdir)/hpfax $(DESTDIR)$(cupsdir); \
- $(mkinstalldirs) $(DESTDIR)$(hpppddir); \
- $(INSTALL_SCRIPT) $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd $(DESTDIR)$(hpppddir); \
- gzip -qf $(DESTDIR)$(hpppddir)/HP-Fax-hplip.ppd; \
+ $(mkinstalldirs) $(DESTDIR)$(hpppddir)/fax; \
+ $(INSTALL_DATA) $(DESTDIR)$(faxppddir)/HP-Fax-hplip.ppd $(DESTDIR)$(hpppddir)/fax; \
+ gzip -f $(DESTDIR)$(hpppddir)/fax/HP-Fax-hplip.ppd; \
fi
+uninstall-hook:
+# Remove Icon file.
+ rm -f $(DESTDIR)$(icondir)/$(ICON_FILE)
+ rm -f $(DESTDIR)$(ICON_PATH)/$(ICON_FILE)
+#
+# Remove hp-xxx commands.
+ for i in $(dist_cmd_SCRIPTS); do \
+ newname=$${i%.*}; \
+ rm -f $(DESTDIR)$(hplipdir)/$$newname; \
+ rm -f $(DESTDIR)$(bindir)/hp-$$newname; \
+ done
+#
+# Remove hplip.conf and hplip start/stop script.
+ rm -f $(DESTDIR)/etc/hp/$(PACKAGE).conf
+ rm -f $(DESTDIR)/etc/init.d/$(PACKAGE)
+#
+# Remove fax support.
+ rm -f $(DESTDIR)$(hpfaxdir)/hpfax
+ rm -f $(DESTDIR)$(cupsdir)/hpfax
+ rm -f $(DESTDIR)$(hpppddir)/fax/HP-Fax-hplip.ppd.gz
+
#
# Add prerequisites for testing (or building?) "make install DESTDIR=/build".
test-destdir: