summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJari Aalto <jari.aalto@cante.net>2012-02-28 13:40:47 -0500
committerAndrew Shadura <andrew@shadura.me>2016-06-21 12:44:43 +0200
commitafd7cade2009ea4e90e4aaec80a266ce8e05197e (patch)
treee28127714afa4507485697bf2bcd3ec0a474e468 /debian/rules
parent8b3c90e3ff12464a9e2263a1aa87dd45aa9a9a6a (diff)
Update to packaging format 3.0
The dpatch patch management system has been deprecated for some time. The Lintian currently flags use of dpatch packages as an error. The new 3.0 packaging format is an improved version which, among other things, contains patch management built-in. Signed-off-by: Jari Aalto <jari.aalto@cante.net> Signed-off-by: Andrew Shadura <andrew.shadura@collabora.co.uk>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index f371fb1..33eb6c6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-include /usr/share/dpatch/dpatch.make
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
@@ -25,7 +24,7 @@ confopts = --disable-subversion \
--disable-xmltoman \
--disable-lynx
-config.status: patch configure-stamp
+config.status: configure-stamp
configure-stamp:
dh_testdir
[ ! -f ifplugd.spec ] || mv -f ifplugd.spec ifplugd.spec.ups
@@ -40,13 +39,12 @@ endif
touch $@
build: build-stamp
-build-stamp: patch-stamp config.status
+build-stamp: config.status
dh_testdir
$(MAKE)
touch $@
-clean: clean-patched unpatch
-clean-patched:
+clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
@@ -95,4 +93,4 @@ binary-arch: build install
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install