summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-08-27 00:41:05 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-08-27 00:41:05 +0200
commit0bb7732c5e4e79e9bf096b44f596e69be0554d59 (patch)
tree9f03dd32432e2822a4bf190bdbfbbb6ae7227daa /setup.py
parentbf994e55638522d821728c2d5166cfffe395349c (diff)
New upstream version 0.4.0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py59
1 files changed, 25 insertions, 34 deletions
diff --git a/setup.py b/setup.py
index 9abe2e9..8b2c01f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,58 +1,49 @@
import sys
from setuptools import setup
-VERSION = "0.3.6"
+VERSION = "0.4.0"
INSTALL_REQUIRES = (
- 'Pillow',
+ "Pillow",
+ "pikepdf",
)
-TESTS_REQUIRE = (
- 'pdfrw',
-)
-
-
setup(
- name='img2pdf',
+ name="img2pdf",
version=VERSION,
author="Johannes 'josch' Schauer",
- author_email='josch@mister-muffin.de',
+ author_email="josch@mister-muffin.de",
description="Convert images to PDF via direct JPEG inclusion.",
- long_description=open('README.md').read(),
- long_description_content_type='text/markdown',
+ long_description=open("README.md").read(),
+ long_description_content_type="text/markdown",
license="LGPL",
keywords="jpeg pdf converter",
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Other Audience',
- 'Environment :: Console',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: Implementation :: CPython',
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Other Audience",
+ "Environment :: Console",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
- 'License :: OSI Approved :: GNU Lesser General Public License v3 '
- '(LGPLv3)',
- 'Natural Language :: English',
- 'Operating System :: OS Independent'],
- url='https://gitlab.mister-muffin.de/josch/img2pdf',
- download_url='https://gitlab.mister-muffin.de/josch/img2pdf/repository/'
- 'archive.tar.gz?ref=' + VERSION,
+ "License :: OSI Approved :: GNU Lesser General Public License v3 " "(LGPLv3)",
+ "Natural Language :: English",
+ "Operating System :: OS Independent",
+ ],
+ url="https://gitlab.mister-muffin.de/josch/img2pdf",
+ download_url="https://gitlab.mister-muffin.de/josch/img2pdf/repository/"
+ "archive.tar.gz?ref=" + VERSION,
package_dir={"": "src"},
- py_modules=['img2pdf', 'jp2'],
+ py_modules=["img2pdf", "jp2"],
include_package_data=True,
- test_suite='tests.test_suite',
zip_safe=True,
install_requires=INSTALL_REQUIRES,
- tests_requires=TESTS_REQUIRE,
- extras_require={
- 'test': TESTS_REQUIRE,
- 'gui': ('tkinter'),
- },
+ extras_require={"gui": ("tkinter"),},
entry_points={
"setuptools.installation": ["eggsecutable = img2pdf:main"],
"console_scripts": ["img2pdf = img2pdf:main"],
"gui_scripts": ["img2pdf-gui = img2pdf:gui"],
},
- )
+)