summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-04-05 20:28:44 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-04-05 20:28:44 +0200
commite7866e5e3c125b734332dd93843ef683332c0a43 (patch)
treefedab8befa17c89fae1ed4cd68131108eed546c4 /setup.py
parent140ed3b81e844b06f82bb5819fe335b514b2aed4 (diff)
New upstream version 0.3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b0438fe..c467cd7 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ from setuptools import setup
PY3 = sys.version_info[0] >= 3
-VERSION = "0.3.3"
+VERSION = "0.3.4"
INSTALL_REQUIRES = (
'Pillow',
@@ -24,6 +24,7 @@ setup(
author_email='josch@mister-muffin.de',
description="Convert images to PDF via direct JPEG inclusion.",
long_description=open('README.md').read(),
+ long_description_content_type='text/markdown',
license="LGPL",
keywords="jpeg pdf converter",
classifiers=[
@@ -54,9 +55,11 @@ setup(
tests_requires=TESTS_REQUIRE,
extras_require={
'test': TESTS_REQUIRE,
+ 'gui': ('tkinter'),
+ },
+ entry_points={
+ "setuptools.installation": ["eggsecutable = img2pdf:main"],
+ "console_scripts": ["img2pdf = img2pdf:main"],
+ "gui_scripts": ["img2pdf-gui = img2pdf:gui"],
},
- entry_points='''
- [console_scripts]
- img2pdf = img2pdf:main
- ''',
)