summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules6
2 files changed, 13 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 9a37e63..120cab0 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,14 @@ Section: python
Priority: optional
Build-Depends: debhelper (>= 11),
dh-python,
+ ghostscript <!nocheck>,
help2man,
+ imagemagick <!nocheck>,
+ libimage-exiftool-perl <!nocheck>,
+ libtiff-tools <!nocheck>,
+ mupdf-tools <!nocheck>,
+ netpbm <!nocheck>,
+ poppler-utils <!nocheck>,
python3-all,
python3-pdfrw,
python3-pil,
diff --git a/debian/rules b/debian/rules
index 76520dd..b525322 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,3 +10,9 @@ override_dh_auto_clean:
override_dh_auto_build:
dh_auto_build
help2man --no-info --name="lossless conversion of raster images to pdf" ./src/img2pdf.py -o img2pdf.1
+
+override_dh_auto_test:
+ dh_auto_test
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS) $(DEB_BUILD_PROFILES)))
+ ./test.sh
+endif