summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/0004-gcc-11-warning.patch22
-rw-r--r--debian/patches/series1
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 712e706..7e666a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+infinipath-psm (3.3+20.604758e7-6.2) unstable; urgency=medium
+
+ * Non-maintainer upload
+ * Work around FTBFS with gcc-12. Closes: #984057
+
+ -- Christoph Biedl <debian.axhn@manchmal.in-ulm.de> Sun, 16 Oct 2022 13:18:17 +0200
+
infinipath-psm (3.3+20.604758e7-6.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/patches/0004-gcc-11-warning.patch b/debian/patches/0004-gcc-11-warning.patch
new file mode 100644
index 0000000..da556f5
--- /dev/null
+++ b/debian/patches/0004-gcc-11-warning.patch
@@ -0,0 +1,22 @@
+Description: Disable warning in the cmpxchgl wrapper
+Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
+Origin: no # upstream is dead
+Bug-Debian: https://bugs.debian.org/984057
+Last-Update: 2022-10-16
+
+--- a/include/linux-i386/sysdep.h
++++ b/include/linux-i386/sysdep.h
+@@ -106,10 +106,13 @@
+ uint32_t prev;
+ struct xchg_dummy { uint32_t a[100]; };
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Warray-bounds"
+ asm volatile(LOCK_PREFIX "cmpxchgl %1,%2"
+ : "=a"(prev)
+ : "q"(new), "m"(*(struct xchg_dummy *)ptr), "0"(old)
+ : "memory");
++#pragma GCC diagnostic pop
+
+ return prev;
+ }
diff --git a/debian/patches/series b/debian/patches/series
index cdf9028..df69493 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0001-Fix-truncation-warnings-with-gcc7.patch
0002-Include-sys-sysmacros.h-to-avoid-warning-about-minor.patch
0003-gcc8.patch
+0004-gcc-11-warning.patch