summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2024-01-28 11:41:26 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2024-01-31 20:04:59 +0000
commit3e7215242eafc89b2d0cae1f5c3952461d0dc894 (patch)
tree7e2bd5550b611d9b52537f97bbfb2e82f4aa02af
parent014fbb1551cd37eb5b253763860a91f71371e68c (diff)
Add a README.example
-rw-r--r--Makefile.am2
-rw-r--r--Makefile.in2
-rw-r--r--README.example23
3 files changed, 25 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7850d48..87dcf78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,7 @@ man_MANS = innduct.8 innduct-stats-report.8
innduct_SOURCES = duct.c conn.c filemon.c infile.c recv.c xmit.c \
cli.c defer.c help.c statemc.c __oop-read-copy.c
-dist_doc_DATA = README.states README.statistics
+dist_doc_DATA = README.states README.statistics README.example
innduct_LDADD = -lm -loop
diff --git a/Makefile.in b/Makefile.in
index 6b06eaa..be9c4e7 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -362,7 +362,7 @@ man_MANS = innduct.8 innduct-stats-report.8
innduct_SOURCES = duct.c conn.c filemon.c infile.c recv.c xmit.c \
cli.c defer.c help.c statemc.c __oop-read-copy.c
-dist_doc_DATA = README.states README.statistics
+dist_doc_DATA = README.states README.statistics README.example
innduct_LDADD = -lm -loop
MAINTAINERCLEANFILES = configure config.h.in Makefile.in
all: config.h
diff --git a/README.example b/README.example
new file mode 100644
index 0000000..dd79eaa
--- /dev/null
+++ b/README.example
@@ -0,0 +1,23 @@
+Example configuration
+=====================
+
+On chiark, we have newsfeeds entries that look like this:
+
+ eternal-september/eternal-september.org\
+ :!*,uk.*,cam.*,ed.*,alt.*,..(details elided)....\
+ :Tf,Wnm:
+ the.earth.li/earthli\
+ :!*,....(details elided)...\
+ :Tf,Wnm:the.earth.li
+
+This specifies innd log feed file
+ /var/spool/news/outgoing/eternal-september
+ /var/spool/news/outgoing/the.earth.li
+
+We have an /etc/news/ducts.table containing entries like this:
+ the.earth.li
+ eternal-september feeder.eternal-september.org --port 433
+
+The news user's crontab has lines like this:
+ 10-59/20 * * * * innduct-forall 'ulimit -c 10240; innduct -q !duct'
+ 36 3 * * * find /var/spool/news/outgoing/ -type f -name '*_backlog_*' -mtime +60 -print0 | xargs -0 rm