summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-12-06 01:49:24 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-12-06 01:49:26 +0000
commita5b1f745e128f541586d90913241a95f8a9e0dd6 (patch)
treef058a13a0bb1550a137e87302c3c5280c184b771
parentcc9e500c9ae3d74c3735168710a5f1a67bd14f81 (diff)
Move "autoconf" target stuff into autogen.sh
Also, arranges for autogen.sh to strip the Makefile and config.h targets from the generated Makefile.
-rw-r--r--Makefile.am9
-rw-r--r--Makefile.in23
-rwxr-xr-xautogen.sh2
3 files changed, 6 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index 7badc29..21003db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,12 +47,7 @@ innduct_SOURCES = duct.c conn.c filemon.c infile.c recv.c xmit.c \
innduct_LDADD = -L/usr/lib/news -lstorage -linn -lm -loop
-autoconf:
- aclocal-1.4
- autoheader2.50
- autoconf2.50
- automake-1.4
- perl -i.bak -pe '$$_="" if m/^(?:Makefile|config\.h):/..m/^$$/' \
- Makefile.in
+autogen autoconf:
+ ./autogen.sh
MAINTAINERCLEANFILES = configure config.h.in Makefile.in
diff --git a/Makefile.in b/Makefile.in
index 779c03c..5b1bba9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -365,16 +365,6 @@ $(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
$(am__cd) $(top_srcdir) && \
$(AUTOMAKE) --foreign Makefile
.PRECIOUS: Makefile
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- @case '$?' in \
- *config.status*) \
- echo ' $(SHELL) ./config.status'; \
- $(SHELL) ./config.status;; \
- *) \
- echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
- cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
- esac;
-
$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
$(SHELL) ./config.status --recheck
@@ -384,10 +374,6 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
$(am__cd) $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
$(am__aclocal_m4_deps):
-config.h: stamp-h1
- @test -f $@ || rm -f stamp-h1
- @test -f $@ || $(MAKE) $(AM_MAKEFLAGS) stamp-h1
-
stamp-h1: $(srcdir)/config.h.in $(top_builddir)/config.status
@rm -f stamp-h1
cd $(top_builddir) && $(SHELL) ./config.status config.h
@@ -910,13 +896,8 @@ uninstall-man: uninstall-man8
uninstall-binSCRIPTS uninstall-man uninstall-man8
-autoconf:
- aclocal-1.4
- autoheader2.50
- autoconf2.50
- automake-1.4
- perl -i.bak -pe '$$_="" if m/^(?:Makefile|config\.h):/..m/^$$/' \
- Makefile.in
+autogen autoconf:
+ ./autogen.sh
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/autogen.sh b/autogen.sh
index 39441f7..4623850 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,3 +1,5 @@
#!/bin/sh
set -e
autoreconf --install
+perl -i.bak -pe '$_="" if m/^(?:Makefile|config\.h):/..m/^$/' \
+ Makefile.in