summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-07-07 15:21:08 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-07-07 15:21:09 +0100
commitaa3992fb5ffe43760a4d469e62aef5f1f2f4f3ed (patch)
tree15f9d2f28bbdaba1b10008402bdbe7b68af2908e
parentbf6f956b4ebf81b866cd787c340e49cf413fb265 (diff)
Fix stats logging and log missing better.
-rw-r--r--debian/changelog3
-rw-r--r--statemc.c11
2 files changed, 8 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 13c9abf..1128763 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
-innduct (2.1~~iwj1) unstable; urgency=medium
+innduct (2.1~~iwj2) unstable; urgency=medium
+ * Fix stats logging and log missing better.
* Fix many bugs and compiler warnings.
-- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 07 Jul 2022 11:24:20 +0100
diff --git a/statemc.c b/statemc.c
index deeee36..2e49692 100644
--- a/statemc.c
+++ b/statemc.c
@@ -238,8 +238,9 @@ static void notice_processed_counts(Counts *counts, int completed,
? masprintf(" autodeferred=%ld", ipf_xtra->autodefer)
: masprintf("%s","");
- notice("%s %s read=%d (+bl=%d,+err=%d)%s%s"
- " missing=%d offered=%d (ch=%d,nc=%d) accepted=%d (ch=%d,nc=%d)"
+ notice("%s %s read=%d (+bl=%d,+err=%d)%s%s missing=%d"
+ " offered=%d (ch=%d,nc=%d;mi=%d)"
+ " accepted=%d (ch=%d,nc=%d;mi=%d)"
RESULT_COUNTS(RCI_NOTHING, RCI_TRIPLE_FMT)
,
completed?"completed":"processed", what,
@@ -247,9 +248,9 @@ static void notice_processed_counts(Counts *counts, int completed,
counts->events[read_err],
inprog, autodefer, counts->events[nooffer_missing],
CNT(Unchecked,sent) + CNT(Unsolicited,sent)
- , CNT(Unchecked,sent), CNT(Unsolicited,sent),
- CNT(Wanted,accepted) + CNT(Unsolicited,accepted)
- , CNT(Wanted,accepted), CNT(Unsolicited,accepted)
+ , CNT(Unchecked,sent), CNT(Unsolicited,sent), CNT(Unsolicited,missing),
+ CNT(Wanted,accepted) + CNT(Wanted,accepted)
+ , CNT(Wanted,accepted), CNT(Wanted,accepted), CNT(Wanted,missing)
RESULT_COUNTS(RCI_NOTHING, RCI_TRIPLE_VALS)
);