summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian sysvinit maintainers <debian-init-diversity@chiark.greenend.org.uk>2018-12-12 22:32:47 +0000
committerDmitry Bogatov <KAction@debian.org>2018-12-12 22:32:47 +0000
commit41433fbc78ea76533f4794af41b5d27cc76c90a9 (patch)
tree4509ea8030d3a781692975e3998282ae5eb43271
parent8bd12654dd6839abefeca6c54d8f1d3c12fbf3e0 (diff)
Separate check from install so checks can be made optional
In order to support DEB_BUILD_OPTIONS=nocheck cleanly the install and check targets are best separated. Also allow COPTS, LDFLAGS and CC to be overridden by environment (Kel Modderman <kel@otaku42.de>). . Author: Wookey <wookey@linaro.org> Last-Update: 2012-04-09 Gbp-Pq: Name 130_crossbuild_fixes.patch
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 89de21c..7d0c2bb 100644
--- a/Makefile
+++ b/Makefile
@@ -27,13 +27,13 @@ else
ifeq ($(ARCH),i386)
COPTS = -g -O3 -mcpu=i586 -mtune=i686
else
- COPTS = -g -O2
+ COPTS ?= -g -O2
endif
endif
CFLAGS = -W -Wall -Wunreachable-code $(COPTS) $(DEBUG) $(LOOPS) -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
$(ISSUSE) -DINITDIR=\"$(INITDIR)\" -DINSCONF=\"$(INSCONF)\" -pipe
CLOOP = # -falign-loops=0
- LDFLAGS = -Wl,-O,3,--relax
+ LDFLAGS ?= -Wl,-O,3,--relax
LIBS =
ifdef USE_RPMLIB
CFLAGS += -DUSE_RPMLIB=1
@@ -144,7 +144,7 @@ else
tests/common
endif
-install: $(TODO) check
+install: $(TODO)
$(MKDIR) $(SBINDIR)
$(MKDIR) $(SDOCDIR)
$(MKDIR) $(CONFDIR)