summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMartin Zimmermann <info@posativ.org>2014-11-09 21:18:05 +0100
committerMartin Zimmermann <info@posativ.org>2014-11-09 21:18:05 +0100
commitf06be982e75f1cfc332db71da14c15df39be5f86 (patch)
treeb78f1f8ed8ebef9be9fedee23c5ae7c2783900f3 /Makefile
parentd469324392b3ffd566c5028e7cf2bc9013661961 (diff)
add target to lint for Python 2 and 3
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8510d75..22fa937 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@ ISSO_JS_DST := isso/js/embed.min.js isso/js/embed.dev.js \
ISSO_CSS := isso/css/isso.css
-ISSO_PY_SRC := $(shell git ls-files | grep .py)
+ISSO_PY_SRC := $(shell git ls-files | grep -E "^isso/.+.py$$")
DOCS_RST_SRC := $(shell find docs/ -type f -name '*.rst') \
$(wildcard docs/_isso/*) \
@@ -30,6 +30,12 @@ all: man js site
init:
(cd isso/js; bower install almond requirejs requirejs-text jade)
+check:
+ @echo "Python 2.x"
+ -@python2 -m pyflakes $(ISSO_PY_SRC)
+ @echo "Python 3.x"
+ -@python3 -m pyflakes $(ISSO_PY_SRC)
+
isso/js/%.min.js: $(ISSO_JS_SRC) $(ISSO_CSS)
r.js -o isso/js/build.$*.js out=$@