summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Zimmermann <info@posativ.org>2013-10-09 16:28:54 +0200
committerMartin Zimmermann <info@posativ.org>2013-10-09 16:33:49 +0200
commit61a486d2eacb0be43d20c48e3c3d933dd2029648 (patch)
treeb17c11bb6bd767af3ff0c59078e839a4440f9d2d /setup.py
parentf9133b984edd53790cf9c075225111c34874105e (diff)
support for Python 3.3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c688990..93d1317 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,9 @@ from setuptools import setup, find_packages
requires = ['Jinja2>=2.7', 'werkzeug>=0.9', 'itsdangerous', 'misaka', 'html5lib']
+if (3, 0) <= sys.version_info < (3, 3):
+ raise SystemExit("Python 3.0, 3.1 and 3.2 are not supported")
+
if sys.version_info < (3, 0):
requires += ['ipaddress', 'configparser']
@@ -28,7 +31,8 @@ setup(
"Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
"License :: OSI Approved :: BSD License",
"Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7"
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3.3"
],
install_requires=requires,
entry_points={