summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMartin Zimmermann <info@posativ.org>2014-05-28 10:12:01 +0200
committerMartin Zimmermann <info@posativ.org>2014-05-28 10:12:58 +0200
commit8c6a7e209ee1397d0aae1eade62ff62ff62fad13 (patch)
tree5a168ee72d32aa31a053dcb1ee406d431474060e /tox.ini
parent94ee6a6981738ee20ac7a057a6275ca603a62e45 (diff)
pin versions for Squeeze and Wheezy, also remove py26 from default run
Python2.6 is EOL and my distributions is about to remove it. Travis CI uses Ubuntu 12.04 LTS and can still test Python2.6 for at least three years.
Diffstat (limited to 'tox.ini')
-rwxr-xr-xtox.ini36
1 files changed, 24 insertions, 12 deletions
diff --git a/tox.ini b/tox.ini
index 55cf244..bfb9a38 100755
--- a/tox.ini
+++ b/tox.ini
@@ -1,28 +1,40 @@
[tox]
-envlist = py26,py27,py33,py34
+envlist = py27,py33,py34
+
+[testenv]
+deps =
+ nose
+commands =
+ python setup.py nosetests
+
[testenv:py26]
deps =
argparse
- configparser
unittest2
+ configparser
{[testenv]deps}
+
[testenv:py27]
deps =
configparser
{[testenv]deps}
-[testenv:backport]
-deps =
- configparser
+
+[testenv:debian]
+deps=
werkzeug==0.8.3
html5lib==0.95
itsdangerous==0.22
ipaddr==2.1.10
misaka==1.0.2
- {[testenv]deps}
-[testenv]
+
+[testenv:squeeze]
+basepython=python2.6
+deps=
+ {[testenv:py26]deps}
+ {[testenv:debian]deps}
+
+[testenv:wheezy]
+basepython=python2.7
deps =
- nose
-commands =
- python setup.py nosetests
-install_command =
- pip install --allow-external ipaddr --allow-unverified ipaddr {opts} {packages}
+ {[testenv:py27]deps}
+ {[testenv:debian]deps}