summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Bennett <steveb@workware.net.au>2010-01-24 13:58:17 +1000
committerSteve Bennett <steveb@workware.net.au>2010-10-15 11:02:46 +1000
commit54f0f29b3d487ae04cb181ba957565662a21a5a0 (patch)
tree2e098c1726f8298036ded97158724bd7dd5d00f6 /configure.ac
parent57d2640b4ebbed560098538639e580d3d7d55d8d (diff)
Documentation, build system updates
Document reference-related commands *: ref, getref, setref, finalize, lambda were missing Build system updates *: Add check for long long to configure *: Change -Dwith_jim_ext_... to -Djim_ext_... *: Fix jim-eventloop when compiling with no long long
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bb2d251..3c3891e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,9 @@ AC_INIT([jim], [0.62], [steveb@workware.net.au])
AC_PROG_CC
AC_PROG_MAKE_SET
+# Checks for types
+AC_CHECK_TYPES(long long,EXTRA_CFLAGS="$EXTRA_CFLAGS -DHAVE_LONG_LONG")
+
# Shared library support. Because we don't believe in automake!
AC_CANONICAL_HOST
case $host in
@@ -52,8 +55,8 @@ AC_ARG_WITH(jim-ext,
AC_MSG_RESULT(enabling jim extensions: $jim_extensions)
AC_SUBST(JIM_EXTENSIONS,$jim_extensions)
for i in $jim_extensions; do
- dnl AC_DEFINE_UNQUOTED(with_jim_ext_$i)
- EXTRA_CFLAGS="$EXTRA_CFLAGS -Dwith_jim_ext_$i"
+ dnl AC_DEFINE_UNQUOTED(jim_ext_$i)
+ EXTRA_CFLAGS="$EXTRA_CFLAGS -Djim_ext_$i"
done
JIM_LIBTYPE=static