summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Egger <christoph@debian.org>2020-11-20 18:04:08 +0100
committerChristoph Egger <christoph@debian.org>2020-11-20 18:05:37 +0100
commitd2791530b2ee28f312f348682cc3655c11e2e2ba (patch)
treec4bdd9e6008a32ac6e6b132ec952d6ff394ebc15
parent5269e39d854132455ffdb9f6dffddb6787258dca (diff)
parent2c5634d006aa26a033bcfc29ac79b8042d70109f (diff)
Merge from sid [dgit]
-rw-r--r--debian/changelog15
-rw-r--r--debian/compat2
-rw-r--r--debian/control24
-rw-r--r--debian/copyright10
-rw-r--r--debian/manpages2
-rwxr-xr-xdebian/rules3
6 files changed, 35 insertions, 21 deletions
diff --git a/debian/changelog b/debian/changelog
index 0d9dbc9..6050189 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,22 @@
katarakt (0.2-3) UNRELEASED; urgency=medium
+ * Import bugfix patches from VCS
+
+ -- Christoph Egger <christoph@debian.org> Fri, 20 Nov 2020 18:02:25 +0100
+
+katarakt (0.2-2) unstable; urgency=medium
+
+ [ Christoph Egger ]
* Bump standards version to 4.1.0
* Update URLs
* USE SOURCE_DATE_EPOCH in debian/rules
- * Import bugfix patches from VCS
+ * Use Rules-Requires-Root
- -- Christoph Egger <christoph@debian.org> Fri, 20 Nov 2020 18:02:25 +0100
+ [ Simon Ruderich ]
+ * Update to Qt 5
+ * Update to compat 10
+
+ -- Christoph Egger <christoph@debian.org> Tue, 31 Oct 2017 11:54:02 +0100
katarakt (0.2-1) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index 92372e2..7cf3137 100644
--- a/debian/control
+++ b/debian/control
@@ -2,26 +2,29 @@ Source: katarakt
Section: utils
Priority: optional
Maintainer: Christoph Egger <christoph@debian.org>
-Build-Depends: debhelper (>= 9~),
- qt4-qmake,
- libqt4-dev,
- libpoppler-qt4-dev (>> 0.18),
- libinotify-dev [kfreebsd-any],
+Build-Depends:
asciidoc,
- faketime,
- libxml2-utils,
+ debhelper (>= 10~),
docbook-xml,
docbook-xsl,
- xsltproc,
- pkg-config
+ faketime,
+ libinotify-dev [kfreebsd-any],
+ libpoppler-qt5-dev (>> 0.18),
+ libxml2-utils,
+ pkg-config,
+ qtbase5-dev,
+ xsltproc
Standards-Version: 4.1.0
Homepage: https://wwwcip.cs.fau.de/~go18gomu/katarakt/
Vcs-Git: https://alioth.debian.org/anonscm/git/collab-maint/katarakt.git/
Vcs-Browser: https://anonscm.debian.org/gitweb/?p=collab-maint/katarakt.git;a=summary
+Rules-Requires-Root: no
Package: katarakt
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends:
+ ${misc:Depends},
+ ${shlibs:Depends}
Description: simple PDF viewer with two layouts
It's a PDF viewer. It views PDFs.
.
@@ -33,4 +36,3 @@ Description: simple PDF viewer with two layouts
The grid layout is much more advanced and offers continuous (smooth,
per pixel) scrolling, zooming and adjusting the column count. Pages
keep their correct relative size and are shown in a grid.
-
diff --git a/debian/copyright b/debian/copyright
index 02d64d4..884a365 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -10,17 +10,17 @@ License: Simplified BSD
License: Simplified BSD
This software is licensed under the "Simplified BSD License":
-
+
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
-
+
1. Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.
-
+
2. Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.
-
+
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER(S) ''AS IS'' AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
@@ -30,7 +30,7 @@ License: Simplified BSD
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
+
The views and conclusions contained in the software and documentation are those of the
authors and should not be interpreted as representing official policies, either expressed
or implied, of the copyright holder(s).
diff --git a/debian/manpages b/debian/manpages
index 4bdf6a2..31ea41b 100644
--- a/debian/manpages
+++ b/debian/manpages
@@ -1 +1 @@
-doc/katarakt.1 \ No newline at end of file
+doc/katarakt.1
diff --git a/debian/rules b/debian/rules
index fc65afd..260674b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,10 @@
#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export QT_SELECT = qt5
%:
- dh $@ --parallel
+ dh $@
override_dh_auto_install:
install -m 755 katarakt $(CURDIR)/debian/katarakt/usr/bin/