summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL18
1 files changed, 14 insertions, 4 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 253f1df..63b0ff8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,7 +1,17 @@
+use strict;
+use warnings;
+
use ExtUtils::MakeMaker;
-# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-# the contents of the Makefile that is written.
+
WriteMakefile(
- 'NAME' => 'Algorithm::Diff',
- 'VERSION_FROM' => 'lib/Algorithm/Diff.pm', # finds $VERSION
+ NAME => 'Algorithm::Diff',
+ VERSION_FROM => 'lib/Algorithm/Diff.pm', # finds $VERSION
+
+ # Note that EXE_FILES is not provided. The programs shipped with
+ # Algorithm-Diff have traditionally not been installed to the $PATH, and are
+ # unlikely to get installed there in the future.
+
+ META_ADD => {
+ license => 'http://dev.perl.org/licenses/',
+ },
);